2

I received a MacBook7,1 a few days ago and wanted to use dosdude1's Catalina patcher to install it on my system. The first attempt actually yielded a result that constantly showcased weirdness. When I looked at the page again, I noticed that he recommended having upgraded the BootROM through Sierra. Now, the MacBook did indeed come with Sierra but I had already flattened the SSD to put Catalina on it instead. And now, I am well stuck.

Trying to use createinstallmedia from the Sierra installer app's resources folder does spawn an uncountable amount of processes, but does not actually ever ask me to erase the drive and tell me that it's copying files over. And any other createinstallmedia that I had available to try just outright did the same or refused to accept the application image.

Then I thought of booting up a Sierra VM. After all, I did have the image already, so installing it into a VM and using the createinstallmedia tool from within there should yield me a usable result. But no - just dropping macOS into a VM won't work at all, even if the host is a macOS either.

I have tried several methods, but I am quite out of ideas by now. I may also have a failing harddrive, but using the latest GParted Live DVD to load the Smart Monitor GUI only had me tell me that everything was fine with it. Weird.

How can I create a Sierra image on macOS Catalina (my other, 2014 MacBook Pro) that I can boot off on my MacBook7,1? Alternatively, I have a Windows 10 PC available, so if there is a method to make such image on Windows, this would also help.

Small bonus: Do you happen to know why createinstallmedia just basically throws out so many other createinstallmedia processes?

  • What marketing year is 7.1 air? Also why not format the USB drive as FAT and copy the installer app to the drive? The 2014 MacBook Pro will boot to internet recovery so you can probably do an erase install there if no one comes up with something. – bmike Dec 1 '19 at 20:13
  • @bmike I had originally overseen that I needed to update the BootROM on the Macbook7,1 - so I had already formatted the harddrive in preparation of Catalina, thus not having a bootable macOS install on it anymore. Also, it's the white MacBook from 2010. – Ingwie Phoenix Dec 2 '19 at 7:03
1

The 2014 MacBook Pro should be able to download and run the Sierra Installer.

The answer to that question is the process you can / should follow to download the installer and then run the create script.

What specific error message do you get following the process here?

You might need to post a screen shot of exactly what the terminal window shows in case you've got a syntax error we can spot. Also, the diskutil list command showing the USB drive you target might help.

  • Creating the bootable install media goes through flawless. But the error I get...well, I wish I could read it. I am visually impaired and it only appears brief. You know when a MacBook reboots and shows the four-five blocks of text basically immediately when it boots up? That is what I am getting. – Ingwie Phoenix Dec 2 '19 at 7:05
0

I have it solved - and in fact, I am posting from the new maschine right now!

First, let me clarify the situation a little bit:

  • I have a MacBook from mid 2015 that I would like to sell. It officially supports Catalina and runs fine.
  • I bought a MacBook from 2010 - the white one which identifies as MacBook7,1. I want to use this one as my main laptop since I built a very expensive desktop PC and only need a laptop for when I travel to friends and/or family. For this case, the 2010 MacBook is well more than enough.

First things first: I created a bootable Catalina install media on the 2015 MacBook and had it patched through dosdude1's `Catalina Patcher" utility. I was worried that maybe the BootROM was not updated - but I realized that I had well been able to boot off an APFS device the whole time, which means that the update had been performed already by the previous owner of the 2010 MacBook. Big relief and oopsie there on my end.

But here is what I did not do: Diagnose the device.

When you boot, hold D on your keyboard to get into Apple's hardware diagnostics tool. Mine reported a 4MEM/9/400000 (I hope I am not missing a 0?) almost immediately, indicating that my memory was deffective.

So I went to my desktop computer and burnt a copy of UBCD, the "Ultimative Boot CD". This includes a couple of hardware tests and benchmarks - including "TestMemory86". Running this multiple times after swapping positions and sticks used in the maschine, I eventually eliminated the dead SD-DIMM...but kept it, since I need to buy new RAM anyway so I have a bit of a refference at hand.

After that, the maschine didn't just install, but also boot perfectly fine into macOS. Setup and all that was flawless and I have had no further crashes eversince!

So, if you are coming here after encountering weird behaviour with a second, or even third hand MacBook - I highly recommend running the diagnostics tool. Although I spent about four days trying to get this maschine to work and wasted a lot of time and efford there, I hope others may be able to avoid this desaster :)

I hope someone will find this helpful =)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .