I recently bought a Corsair Force LE 240GB SSD and tried to do a net recovery on a macbook pro A1278 (MacBook Pro 13" Early 2011 with i5) to the latest El Capitan, but for some reason, this is only possible if it is connected via USB (as an external drive). As soon as it is connected internally instead of the standard HDD, it does not show up in disk utility and can't be used as startup disk or location to where the OS should be installed. I cloned the working version of my HDD to the SSD, but when it is booting internally from the SSD (which now has a working version of Mac OS X on it), it freezes as soon as the progress bar reached 100%. It sits there for over an hour (I canceled it at that point always). Booting from the same drive externally boots into a clean working version of El capitan without any problems.

Judging from what I read online, a possible issue might be that the internal SATA cable doesn't support SATA III, which is used by this SSD. Before I go and buy a replacement cable, I would like to make sure there isn't another problem that could also cause this.

I have so far only tried net recoveries, and am currently downloading the OS image to burn it to a USB and try from there again. This is to eliminate errors that might come from a broken OS file (my Internet connection sometimes stops working). Update: Also a recovery from USB with the internal SSD brings the same problems.

The drive itself works flawlessly on Ubuntu 16.04 and Windows 10, both as external and internal drive.

  • Can you specify further than A1278? This refers to several distinct models.
    – JMY1000
    Commented May 28, 2016 at 22:27
  • I updated the model description: macbook pro 13" early 2011 with i5 processor
    – DK2AX
    Commented May 29, 2016 at 6:51
  • Just a note - though untested in a MacBook, but on 2 'cheesegrater' Mac Pros - having only SATA II will affect the overall speed attainable, but in itself shouldn't affect whether it will boot. Have you thought about trying to just clone the existing drive, Carbon Copy Cloner or similar? That's worked for me every time. If you can get that far, then you can work from the internal recovery partition on it if you want to re-work it.
    – Tetsujin
    Commented May 29, 2016 at 7:24
  • @Tetsujin Yes, Ive done that (Also using CCC). The drive is then recognised as internal drive, but when I start up the macbook from the SSD, the boot hangs when the progress bar is at 100%. Ive waited there for over an hour, but nothing happens, I also tried this 3-4 times so far.
    – DK2AX
    Commented May 29, 2016 at 7:34
  • Can you work from the Recovery partition once you've cloned it, then do a fresh/repair install?
    – Tetsujin
    Commented May 29, 2016 at 7:37

1 Answer 1


The problem was the internal SATA cable. After exchanging it - this is quite an easy operation, there are plenty of videos on Youtube that describe exactly how it's done - the drive booted flawlessly and is running at a negotiated link speed of 6 Gigabit.

To make sure an SSD will work with a Macbook, the Link Speed of the SATA controller should be checked in About This Mac > System Report > Hardware > SATA/SATA Express

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .