2

I've been working on a very problematic Early 2011 MacBook Pro. Recently I managed to install macOS Sierra, using another Mac to perform the install. There are lots of other avenues I've been down with this.

When I connect the KingSpec 4TB SATAIII SSD drive to the MacBook Pro via USB I am able to boot into Mac OS fine. Here are some images showing the Disk Utility.

However, when the drive is mounted internally. It will not boot.

  • Powering on normally, the flashing folder icon appears.
  • Holding down the option key, no drives appear.
  • Booting into recovery mode, it says that the file system is not recognized.

I've had loads of issues attempting to get this working. Such as installing High Sierra and being faced with the "Server Unreachable" issue, even fixing that by editing a variable in Terminal.

I have already replaced the SATA cable with one bought online. Found articles indicating a potential issue with SATA II/III but the outgoing HDD was SATA III. It could be that it was compatible with II and this new one isn't? I'm a bit wary of another few hundred pounds going at this Mac though.

Has any one been in this situation before and resolved it?

10
  • 2
    Do you have two boot disks? I would think your next step is to boot from external and have the intended drive seated in the Mac and check what the system information / system profiler thinks the negotiated speed is with the controller. Does the drive vendor offer any support on firmware needed to be compatible with this era Mac controller?
    – bmike
    Commented Jul 8 at 12:51
  • Seeing if I can get another SSD on eBay right now. That should give me more options. I’ll try out the above and report back. I’ll also investigate the vendor now.
    – Matt Canty
    Commented Jul 8 at 14:10
  • 1
    Good luck, this vintage hardware may be quite slow booted from non SSD external, it if you’re patient a less expensive option to do the test might make sense.
    – bmike
    Commented Jul 8 at 16:15
  • Your external drive has a sector size of 4096 bytes. Perhaps the internal drive requires a 512 byte sector size. Commented Jul 8 at 20:00
  • 1
    Link speed with nothing connected is just a theoretical max. The intent was to see if the device connects hardware wise and what speed it negotiates to rule out hardware failure or bad cabling.
    – bmike
    Commented Jul 9 at 13:34

1 Answer 1

1

TL;DR; I used a 2TB Crucial BX500 2.5-inch SSD

Clearly that KingSpec 4TB SATAIII SSD did was not compatible with the MacBook Pro (Early) 2011. It worked ok via USB but not internal SATA connection. Even after replacing the cable.

My guidance to anyone in future would be to find a retailer such as Mr Memory. There you can see specific hardware associated with your specific model.

Unlike other points in my adventure, every step just worked:

  1. Erase: OK
  2. Install: OK
  3. Migration: OK
  4. General use: OK OK OK OK

I'm very happy now. I thought I was actually going mad at one point.

For the record, I ordered the 2TB Crucial BX500 2.5-inch SSD

1
  • OWC has a sterling reputation for ensuring firmware of drives is broadly compatible as well as addressing bugs should hardware ship before they are found and squashed.
    – bmike
    Commented Jul 11 at 10:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .