1

El Capitan has brought back a problem that I had with Yosemite at first - it disappeared after a later OS update.

I have a headless MacMini on my home network, with a daisy chain of firewire disks attached to it. I use them for backing up photographs and movies (~3TB worth), and the MacMini runs CCC to keep all disks synced. The two disks I use most often have aliases in my dock so I can access them easily.

After the 10.11 upgrade they keep mounting spontaneously on my desktop.

They are not among my login items. I have cleared the Recent Items from the Apple menu, and have cleared Recent Servers from the Finder/Go/Connect to Server... menu. Directory Utility shows no mounts. I have disabled the Guest account as I had read it can cause unwanted connections.

The one clue I have is that I can dismount the two disks, but they will remount on opening some apps like Preview or TextEdit - perhaps something to do with their open dialog looking for files to open? I have no files on either disk that they have ever opened or saved to those disks.

Using Main Menu Pro I have cleaned the system cache, all user caches, font cache, DNS cache and all logs. I'd do it all again with Onyx, but it hasn't been updated for 10.11 yet. The disks still keep mounting!

BTW, today I updated another mac at home and it has started automounting just one of those two disks - the only one of the two that it has ever mounted. I'm missing something - any ideas what it might be?

  • I have tried two more things - a safeboot and then booting into recovery mode, running DFA and restarting. I hear this might clear some system caches, but neither manoeuvre got rid of my network disks. – chrism Oct 3 '15 at 16:36
1

Further to my automounting network disk woes: Zapping PRAM doesn't work either, nor does playing with what shows in the sidebar of Finder windows among the Bonjour, Connected Server, and Shared sections of Finder prefs, but.....

I might have just found the answer, and it's weird. I had noticed that opening Preview or TextEdit would always mount these network disks, and those two apps, in Apple's infinite wisdom, start up with an Open... dialog set to one's Documents folder. I had made aliases of the two disks and placed those aliases in my Documents folder. By dragging them to my Dock I had a clickable icon for each that showed them to be network disks (just dragging the icon of the mounted disk directly to the Dock shows them with a generic folder icon). I wondered if the Open dialog of Preview was mounting the disks as part of showing what was available in Documents for it to open, so I dragged the aliases onto the Desktop. The disks still mounted, so I tried a restart to see if Preview would still do it. It did. So then I cleared the System cache, all user caches and restarted again. This time the disks didn't mount! Being either brave or foolish, I dragged the aliases back into the Documents folder, and they still don't mount on opening Preview! I have restarted since just to see if they would reappear on opening Preview, but they don't. It's odd how this has happened immediately on upgrade to 10.10 and again with 10.11. With 10.10 it went away with a 10.10.x upgrade, but this time I may have solved it

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .