14

Editing DefaultFonts.plist doesn't seem working anymore on the pre-release build 15A279b of El Capitan:

sudo vim /Applications/Notes.app/Contents/Resources/en.lproj/DefaultFonts.plist

It still shows that the file is readonly. I guess it's because the new System Integrity Protection feature.

Is there another way to change the default font in Notes app?

  • defaults read com.apple.Notes NoteFont (?) – sam Feb 3 '16 at 6:54
3

And the keyboard's plists of PressAll also can no longer be modified to add the new accents.

Tip: You do not need to modify the default font and size in Notes.

To change the font, you can select all or one sentence and press Cmd + T.

To change the font size, you can press Cmd, Shift and + at the same time to increase or Cmd + - to decrease the size.

Another tip: If you want to use the user font in Notes in OS X, please, install and use AnyFont in iOS to install your favourite font in iOS.

  • 8
    Thanks for the tip, Gustavo! I do however want to change the default font, because it's troublesome to change the font for every time I create a new note. – hujunfeng Oct 5 '15 at 4:04
  • 1
    @hujunfeng did you figure out how to change the default font size ? I am having the same problem. Might switch to using evernote because of this. – gprasant Nov 4 '15 at 21:45
  • 2
    @gprasant, no I still don't know how to do it. It might not be possible with El Capitan unfortunately. – hujunfeng Nov 5 '15 at 3:55
  • 3
    This doesn't answer OP's question of how to change default font. – antonagestam Jan 11 '17 at 4:14
2

Here's what worked for me on El Capitan:

1.Disable System Integrity Protection

  • Restart your mac
  • Press and hold CMD+R to boot in recovery
  • In the menu bar select utilities>terminal
  • Type csrutil disable
  • Reboot

2.Change font size:

  • Fire up the terminal and type in

    cd /Applications/Notes.app/Contents/Resources

  • Then

    sudo nano pad.css

  • In the editor replace the @[FONT-SIZE] with your font size.

  • control+X and then select Y and then return.

Start your notes app and you should see the difference :)

[EDIT]

To switch on (or re-activate) SIP, repeat the steps at '1' above. However, instead of using csrutil disable in Terminal, use csrutil enable.

  • Sadly this does not work in Sierra 10.12.6. : ( – Gabriel Jensen Oct 3 '17 at 21:10
  • ...because Sierra has it in Notes preferences. Finally! – Gabriel Jensen Oct 4 '17 at 15:49
1

Workaround: Pushing Cmd-+ increments the font size by one point each time.

The default body font size is 12 point. So, if you want to get your notes to be 16 point, just always press Cmd-+ four times after starting a new note.

(and go to Format menu, New Notes Start With, and make sure Body is checked)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .