Is there a way to cancel or disable the minimize animation completely in Mac OSX?

  • 1
    which one? all of it ? – Ruskes Jan 28 '15 at 2:26
  • 1
    something like this in your Terminal will do it defaults write com.apple.finder DisableAllAnimations -bool true – Ruskes Jan 28 '15 at 2:33
  • 1
    @Buscar웃 Thank you you are welcome to link to another answer or leave as response. – William Jan 28 '15 at 2:33
  • 1
    ok read this one apple.stackexchange.com/q/14001/46541 – Ruskes Jan 28 '15 at 2:35

To manage automatic window animations, use the commands below. NOTE THAT you'll have to quit and restart an application for the changes to take effect because it checks these settings on app launch.


To disable automatic window animations, enter the following Terminal command:

defaults write NSGlobalDomain NSAutomaticWindowAnimationsEnabled -bool NO


To enable window animations:

defaults write NSGlobalDomain NSAutomaticWindowAnimationsEnabled -bool YES

  • 2
    What version of Mac OSX are you using because I can't seem to get these to work. – William Feb 9 '15 at 21:29
  • 1
    These were from 10.9. I haven't confirmed in 10.10...different company and new role. – SaxDaddy Feb 10 '15 at 22:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .