16

Is there a way to completely disable Spaces in Yosemite (without turning off Mission Control, Dashboard, etc.)?

As someone who frequently switches between multiple monitors and using my Macbook on its own, I frequently run into baffling setups where windows on one monitor become a Space on another monitor. I'd like to end this behavior.

10

I did this recently to get an iMac to better support an X-Arcade Tankstick and MAME. I do not know that it totally disabled Spaces, but is has effectively eliminated them for me.

  1. System Preferences > Mission Control: Uncheck everything.

    Set shortcut for Mission Control to "-"

  2. System Preferences > Keyboard > Shortcuts > Mission control: Uncheck everything

  3. In a Terminal window enter:

    defaults write com.apple.dock mcx-expose-disabled -bool true"
    

For more info you can check out:

  • this is not working for Sierra – SpaceDog Aug 17 '17 at 16:28
3

I think I got the solution:

IF you only want to disable the spaces option, open mision control (by pressing F9, or by the Mission Control key (also F3). Once your spaces are shown on the upper part of the screen, you can just go over your diferent "spaces" with you mouse and then a cross will appear letting you shut down.

enter image description here

hope this is helpful!

0

I did it this way In system preferences: Keyboard, unchecked the Mission control and the 3 below it and it turned it off.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .