8

I'm about ready to throttle someone if I can't figure this out. I have been working to disable all animation effects throughout OSX (10.9.2). since I got my new laptop about 3 months ago. I think I have most of them figured out, but I'm at a loss when it comes to disabling the minimize window application. The dock gives three options, none of which is acceptable for me. How can I disable this extremely aggravating behavior?

I'm open to any suggestions, hacks, patches, utilities, or dark magic rituals that will change this behavior. I'm not interested in people telling me that it can't or shouldn't be done. This is my personal computer, and I should be able to dictate it's behavior.

  • 2
    you are mentioning three options, I guess you already discovered the "suck" animation? – Hug Aug 13 '14 at 21:12
  • 1
    Depending on how geeky (and programming/hacking savvy) you are, you can look into an iPhone jailbreak tweak called "hooks law" which modifies animation timings on iOS and whose developer mentioned on twitter that he ported it to OS X. In it, you could reduce the animation time to zero. – Hug Aug 13 '14 at 21:13
  • 1
    Does this answer doesn't work for you ?, do you want something else ? – Francisco Corrales Morales Sep 13 '16 at 19:50
16

While Yosemite doesn't provide an option to prevent the minimise animation, it does provide an option to use the "scale effect", rather than the "genie effect". I find this animation to be much quicker and much less distracting.

See System Preferences -> Dock

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .