2

I reinstalled macOS. I must have mistakenly chosen Afghanistan as my region. However, now I cannot change it.

In Settings > General > Language & Region, there is a drop-down list to select a new region. I chose Americas > United States, and the Settings app flickers for a moment, and puts back the "Afghanistan" value.

My laptop has been in the United States this whole time. macOS is at the latest security patch version: 13.4.1 (c) (22F770820d).

My iCloud ID is logged in from the laptop. Oddly, though, it shows a parrot icon, but my other devices show a sunflower icon. On the laptop, in Settings > Apple ID, I can see my other devices. On my iPhone, in Settings > Apple ID, I can see the laptop.

2 Answers 2

3

Change the AppleLocale via terminal.app...

defaults write NSGlobalDomain AppleLocale -string "en_US"

if you still have trouble, you can also try deleting the folder: ~/Library/Preferences/ByHost and rebooting, then running defaults write NSGlobalDomain AppleLocale -string "en_US"again.

The Settings > General > Language & Region now responds should you wish to change the Region again.

1
  • This fixed it. My entire process: defaults write; Settings app showed Afghanistan; sudo defaults write; Settings app showed Afghanistan; restart macOS; Settings app showed US.
    – Jeff
    Jul 17, 2023 at 19:03
0

You will need to reinstall MacOS.

First boot into Recovery Mode. On Intel Macs, hold down Cmd+R while booting. On Apple Silicon Macs, power off and then hold down on the power button. You will see Continue holding for startup options. When you see "Loading startup options" let go of the button.

Now select Reinstall MacOS. This will not (I repeat NOT) delete any of your data. In the setup process, make sure to select United States as your region.

2
  • This is, so far as I know, the only way to change Region. I was about to put this answer in, but you beat me to it.
    – IconDaemon
    Jul 16, 2023 at 20:58
  • Sorry for dv but as accepted answer shows, incorrect.
    – JL Peyret
    Jul 17, 2023 at 19:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .