0

This is in connection with the other thread I started today.

I have two external USB drives plugged into a Mac Mini (late 2014), running Yosemite. One of them is an SSD (SanDisk), and the other is a hard drive (Seagate).

After being left idle for an hour or two, the Seagate spontaneously unmounts itself. And not in a manner that the OS particularly likes: a message appears, telling me it was pulled out without being unmounted.

Anybody know why this would happen (assuming that the drive hasn't simply gotten flaky; it stayed mounted just fine on a Linux box), and how it could be remedied? Is there a way to remount it when this happens, that doesn't involve physically unplugging it and plugging it back in?

5/8/2023: Here is an excerpt from a "diskutil list" after unplugging and replugging the errant drive:

/dev/disk2
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *1.0 TB     disk2
   1:                 DOS_FAT_32 BACKUP2                 1.0 TB     disk2s1
/dev/disk3
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk3
   1:                        EFI EFI                     209.7 MB   disk3s1
   2:       Microsoft Basic Data BACKUP                  999.9 GB   disk3s2

As I said in a comment, when the drive has spontaneously unmounted itself, the whole /dev/disk3 section is missing.

9
  • 2
    How is it connected? Hub? Direct? If a hub, is it powered? Is the Mac going to sleep during this time?
    – Allan
    May 6, 2023 at 0:46
  • 1
    Could be HW problem with the cable, or the USB connector(s) themselves. Can you test with a different cable? How old is the Seagate HDD? Does this happen if the SSD is disconnected from the Mini completely? When used by itself, does the HDD crash on any USB port it is connected to? Do you have Put hard disks to sleep checked in System Preferences > Energy Saver > Power tab?
    – IconDaemon
    May 6, 2023 at 1:22
  • I unchecked "Put hard disks to sleep" this morning; when I looked after lunch, the Seagate had once again unmounted with an error message. I found a different "Micro-B-superspeed" cable for it, and plugged it back in with that cable. I'll check again late this afternoon. May 8, 2023 at 21:47
  • I didn't have to wait very long. It unmounted with an error message already. By then, I'd looked at the diskutil mount/unmount tutorial at osxdaily.com/2013/05/13/… I did a "diskutil list", and even though the power light on the drive was on, it didn't even show up in a diskutil list! May 8, 2023 at 21:58
  • The Seagate drive doesn't have any date-of-manufacture stamp on it, but it's a "Backup Plus Portable Drive," model SRD00F1, and it's connected directly. May 8, 2023 at 22:13

2 Answers 2

1

I think I may have stumbled upon the solution (wish I'd followed up on the third question in the first comment sooner):

Letting the system put the drive to sleep wasn't having a side effect of causing it to spontaneously disconnect, but letting the system put itself to sleep may have had that effect.

As I said in my last comment from yesterday, I turned off "sleep" entirely, i.e., I checked "Prevent computer from sleeping automatically when the display is off." And this morning, the Seagate had remained mounted all night.

And if anybody is interested in the "other thread" I alluded to, and hasn't already found it, see: Is there an easy way to automatically schedule a move of files matching a certain pattern from a user directory to a USB drive?

2
  • 1
    The 1st comment asked if the MAC was sleeping but you, ahem, STUMBLED across this. May 9, 2023 at 16:12
  • So it did. Somehow, I'd either misunderstood the last part of that comment, or missed it entirely (either way, the penalty of doing so many different things at once), but I certainly didn't bother to try disabling sleep until late yesterday. And I deserved to have my nose rubbed in my oversight, so thanks for that. May 9, 2023 at 16:18
0

As it happens, just today, I discovered independent evidence that the Seagate is starting to flake out. So while the sleeping was a trigger, it wasn't the root cause. Time to replace the device.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .