1

Apple friends.

I was provided an education MacBook Air a while ago. It's was a rent, however I have paid it off now and am almost leaving school thankfully. Because of this, I have been meddling around with settings and files inside it and have found an abundance of education-created restrictions such as monitoring applications and configuration profiles. I have been trying to clear a lot of these, but am having some troubles. So I have a few questions to ask. For reference, this is Monterey 12.4.

  1. I am an administrator or, at the very least, have administrator permissions. However there are different files (primarily system ones) that I am unable to delete. Like the "move to bin" option isn't present at all. I've tried running the sudo and rm commands in terminal to delete them, but it tells me the operation isn't permitted (despite being admin). Logging in as the system/root user doesn't change this either. Even as the highest permission (root), it doesn't let me delete or change any important system files. There are no other users other than myself, a spare I created and the root. I can't boot into any modes (recovery, safe etc) to delete them either [see 2] What can I do here?
  2. There is a built-in firmware lock and I don't have the password to it. Yipee!! Because of this, I can't boot into any modes such as recovery or safe to delete or change certain files. I have tried to delete it using the terminal (sudo firmwarepasswd -delete), but it said password incorrect despite using my correct admin and login password. This was the same result with sudo firmwarepasswd -verify. I tried to set a new firmware password instead (sudo firmwarepasswd -setpasswd) and I actually got more results. It asked for my password. I entered it, it allowed it. Then it told me to enter a new firmware password, which I did. Then it asked to re-enter password, and that's where the issue continued. I did everything right, entered the exact same password, yet it gave me "ERROR | setPasswdFromCommandLine | Unable to verify password ERROR | main | Exiting with error: 4" Trying this in root didn't work either. I'm seriously stumped. What can I even do now?

Thank you.

1 Answer 1

3

The two things to check are:

  1. Ask the school to verify that Apple School Manager / Apple Business Manager can remove device enrollment profile. Better to get a proof of sale receipt as well from them
  2. Ask them to release the Mac from MDM and provide / release the firmware password.

The first helps when you need to erase things and the second will avoid you running into a policy where Apple will only unlock a device for the original purchaser.

Once these are completed, you will want to perform an erase install to validate you have complete control of your property.

1
  • Thank you for your response. 1. I am unable to contact either. We are on break, and I want to take matters into my own hands. I can't ask for the firmware password because of this.
    – Sir.Axel
    Jun 3, 2022 at 1:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .