1

I have been facing a problem with searching for folders having solely numeric characters for their names. They have stopped appearing in the results. I am using macOS Catalina. At first, I thought that a mere restart would fix it, but it did not.

As a simple test, I created a folder named 12345678 inside my Downloads directory. Then I click on search and entered the folder name 12345678. The result was empty for both scopes (This Mac and Downloads folder)

Other folders having alphabetic names/alpha-numeric names appear correctly on the search results.

Does anyone know what the problem could be? Any advice would be very helpful.

PS: I'm not sure if this is related, but, many of my tags have also stopped working. Again to test this, I created a folder and added a Red tag. Then I got to Red tags in Finder, but the folder isn't there.

1
1

I think you have to surround the numeric name with quotes in search window. Ex: "12345678".

1
0

It turns out that the problem is somehow related to available storage.

I have a 240 GB SSD and when my free space becomes less than 20GB, the search problem arises. I cleared some old files to gain an additional free space of 1 GB and voila, the search started to work as before. I made multiple copies of some files to bring down the free space and the search problem appeared again.

Here are a few more side effects I noticed when the available storage went less than 20 GB:

  1. The content of any external drives (HDD and Flash drives) would not show up.
  2. Restart stopped working (I tried this 5 to 6 times and every time it froze at the Apple logo for several minutes). Shutting down and Turning it on worked alright.

Thank you everyone for your tips.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .