1

I have a Nanoleaf lightbulb that I can control via Siri using my HomePod mini. The Nanoleaf supports Homekit Adaptive Lighting, which I've configured as you see in this iMore article. So far so good.

If I say, "Hey Siri, set the Nanoleaf to blue!" it will turn the lightbulb blue.

If I say, "Hey Siri, set the Nanoleaf to Adaptive Lighting!" it says, "Hmmm, that's not a supported feature." Obviously this is not a key word for Siri.

What's the voice command to set it back to Adaptive Lighting?

1 Answer 1

2

Siri doesn't know how to do this (as of iOS 14.4, because the site you linked to is for iOS). You need to first create a Scene that sets the light to adaptive lighting. Then you can tell Siri to execute that Scene.

These directions work on any device that has the Home app.

  1. From the Home app, tap the + icon (top right) and select Add Scene.
  2. Select Custom.
  3. Name the scene to use the phrase you want to use to turn on adaptive lighting. I used "Turn on adaptive lighting".
  4. Tap Add Accessories.
  5. Select the light(s) to control (in your case, it will be your Nanoleaf bulb). Tap Done when finished.
  6. Under Accessories you'll see the Nanoleaf bulb. Long-press the device to show the color configuration screen. Tap the adaptive lighting icon which is the first icon on the top row, left. Set the brightness as desired.
  7. Tap the X to close the screen.

Now, you just have to give Siri the name of the scene and it will work.

1
  • The problem isn't Siri, it's the Nanoleaf bulbs. After interacting with their support, I've come to realize that they are fairly limited in how they can be controlled via Siri. Thus, I agree that your workaround of using a Scene is the best choice at the moment. Thanks! Mar 18, 2021 at 12:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .