17

I wanted to do a clean install on my shiny new M1 MacBook Pro, running macOS 11.1. I booted into recovery mode and navigated to disk utility, click my Macintosh HD entry, erase, then erase volume group.

Reformatting done, I selected "Reinstall macOS Big Sur." This progressed normally, and I was eventually greeted with setup assistant, asking me to select a language.

Everything works normally, up until I reach the "Create a computer account" dialog. No matter what information I enter here, the setup assistant freezes for 5-10 minutes [1]. It eventually reports that creating the account failed, with no further information. It asks me to try again - if I try to use the same short or full account name, it complains that the short or full name is in use and to select something else. If I change the full and short names and try again, the same thing occurs.

If I forcibly shut down the machine at this point and reboot, I am greeted with a normal login menu - e.g. no setup assistant. The accounts that I tried to create using the setup assistant are all listed, but I am unable to log into any of them - seems the password might be set to something other than what I specified.

If during the setup process I signed into iCloud (I have tried with and without signing in), I am given the option to reset the account password using my iCloud account - but this does not work, it shakes a bit as if the iCloud password is wrong. (The iCloud password works perfectly fine on another machine.)

I would write the whole thing off as a glitch, but it is 100% reproducible (on this machine, at least - I am afraid to try my existing machine for the moment). That is, erasing the hard drive and restarting the entire process results in the same errors. If there was a hardware issue, doesn't it seem more likely that we'd run into different set of problems each time?

So, wall of text finished: has anyone run into this, or have any advice on debugging?

I am on attempt 5+ at the moment.

[1] I can still bring up the Force Quit dialog, and adjust brightness/etc using the Touch Bar.

6
  • Now you've got it fixed: if your M1 is shiny and new, why do a clean install? The separation of the OS on a read-only partition, with third-party installs and user-specific content all in different places means that there's very little point and usually an easier way to fix any problems. – benwiggy Dec 15 '20 at 11:17
  • 2
    @benwiggy There was no good reason for this, it is just my long habit to fully format any machine I receive. – negacao Dec 15 '20 at 11:47
  • Brand new hardware sometimes has special builds, that are a different fork from the available download. I think you can trust a factory boxed Mac to be 'clean'. – benwiggy Dec 15 '20 at 19:52
  • Clean install has been a great way in the past to remove all customizations and private information. It enables anyone to start from a known starting point shared by an entire community of users. I certainly think of it as 'best practice' when handing off computers between team members, and as a result I'm in the same boat. – Kay V Dec 29 '20 at 15:06
  • there's another entry with this same title that's been closed for nonconformance: apple.stackexchange.com/questions/409316/… - it appears to have solved my issue (OS is now installed and working in initial operations. The accepted answer below (which now has locked comments) continuously failed for me. – Kay V Dec 29 '20 at 17:50
6

Use the other machine, you indicate that you have, to restore the M1 MacBook Pro M1 fully.

You can find Apple's instructions on doing that here:

https://support.apple.com/en-gb/guide/apple-configurator-2/apdd5f3c75ad/mac

It consists of the following steps:

  1. Install Apple Configurator 2 on your working Mac.

  2. Connect the two Macs using a USB-C cable. On the non-working MacBook Pro it needs to go into the left-hand side port that is nearest the back of the Mac.

  3. Run Apple Configurator 2

  4. Put the non-working MacBook Pro in DFU mode by pressing the power button and holding it down and simultaneously pressing and holding the right shift key, the left option key and the left control key - all for 10 seconds.

  5. After 10 seconds release all keys except the power button.

  6. The MacBook Pro should now appear in Apple Configurator 2. Select it and click Actions > Restore.

After the restore process is finished, you can setup macOS as normally - including the user accounts and passwords.

4
  • Comments are not for extended discussion; this conversation has been moved to chat. – bmike Dec 19 '20 at 15:46
  • @bmike fyi, your link is broken - interested to see the chat and searching chats does not seem to bring it up. – Kay V Dec 29 '20 at 14:28
  • Thanks @KayV you can flag any post like this for moderators to unhide / unfreeze / undelete chat rooms – bmike Dec 29 '20 at 15:38
  • 1
    This solution worked as of Feb 2021 where the other solutions we tried did not. (My friend was locked out of the new computer after Migration Assistant resurrected an old and forgotten login password.) I think of it this way: - We thought if would be helpful to reformat the partitions for some good reason and reinstall from scratch, but clearly Big Sur assumes some filesystem basis that we don't know precisely about. - So going through Apple Configurator provides what's required to restore the machine back to factory settings. – Daniel Jomphe Feb 10 at 9:58
9

paraphrasing @Remiks' answer (thanks Remiks - your writeup got me unstuck!). Remiks reports:

Apple Support shared a far easier fix using recovery tools

upsides over the published approach:

  • requires no 2nd machine or external drive
  • requires no new software (just the Mac OS already on your machine; no downloads of any kind)
  • works reliably (whereas Apple support warns configurator 2 is flakey)

Crazy idea, but should these become the official steps? Anyone aware of a situation actually requiring Configurator?

steps to follow:

  1. shut down your computer
  2. remove the computer from any iCloud accounts (thanks for the edit, @abbaf33f)
  3. hold the power button until the "options" icon shows
  4. select the "options" icon
  5. when next screen loads, select menu item to launch terminal
  6. in terminal type "resetpassword" and hit enter
  7. when a reset password box appears, reveal a new menu by clicking somewhere off to the side of the reset password box (thanks for the edit, @brendan-duke!)
  8. select "Recovery Utilities" then "erase Mac"; in new pop up confirm option to erase Mac
  9. once erased, exit back to recover
  10. reinstall the operating system
  11. once installed, create the account.

Remiks' reported result matches mine: this fix works on the first try.

On the other hand, the official apple steps failed repeatedly for me, and two Apple Sr. Advisors warned me as they attempted to assist that the published instructions were unreliable (yep, they were also frustrated that the Apple-supplied steps failed try after try).

6
  • 1
    I had weird permission issues on a M1 mac that was restored via migration assistant, which I attributed to some probable uid porting problems with my time machine backup.. I hit this problem around account creation when I tried to start over. I had trouble getting my computer into DFU but this “erase mac” solution worked!! I didn’t realize that menu existed otherwise I would have probably tried that early and saved a few hours!! Thank you!! – Thiyagaraj Jan 11 at 19:46
  • 1
    Remove the Mac from iCloud account, then go through the steps listed by @kayv and it worked! – abbaf33f Jan 23 at 18:56
  • @abbaf33f After removing from iCloud account, can I create the account and sign into my iCloud account during setup process? Tried that and now it's hanging on the Create Computer Account part. – user3577397 Jan 28 at 19:48
  • Can confirm needed to remove computer from iCloud before this would work. Thanks for this! This was shockingly difficult to simply restore a drive – sedavidw Feb 20 at 23:12
  • This solution worked for me. – emkays Mar 10 at 14:29
1

As of Feb '21 things are easier. I was able to boot into the config menu and after erasing "Macintosh HD" with Disk Utility, got the error that no users were available to give permission to reinstall like before. Figured I was headed to DFU mode and Configurator 2, I have done it before and it works. Instead I tried erasing "Data" also. After that I had to activate the machine again with an Apple ID, but then reinstalling Big Sur from the network proceeded.

It may make a difference that I had turned off the secure boot option before erasing "Macintosh HD"; don't know for sure.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .