0

I have a 6th generation iPad, and a Macbook Air late 2015. Up until today, I've had minor issues connecting it via USB (such as the charge cutting in and out), but nothing I haven't been able to get by. Today, my iPad is not connecting at all.

So when I plug in my iPad to my Mac via USB, nothing happens. It is not charging nor is it connected. I cannot mirror it via iMovie or zoom.

I have tried the following:

Many different USB wires (They all connect my phone no problem, but not my iPad)

Cleaning the charging port with a toothpick.

Restarting both devices.

Also do note: if I plug my iPad into the wall, it charges immediately. I don't need my iPad to charge, I just need it to be connected so I can mirror it. This is extremely important for my job. Does anyone have any advice?

Thanks!

0

Open up Diagnostic tests, by clicking About MY Mac, and run the test. This will also test which USB ports on the Mac are working. If your iPad charges then the power is working on the USB port, but the data transfer is probably not.

The iPad itself could also has a fault, and to test this, use a different device and see if that shows up on the device. Also try reseting the iPad to factory default (backup first) or just rebooting could work as well. If not of those work, try using a different USB port, or try using a different computer.

3
  • Hey there. When I click on about this mac, I do not see an option to run a diagnostic test. Can you explain where i should go to do that further? In terms of the USB's working, I will tell you that my iphone charges and connects without an issue. My iPad does not. I tried plugging in my mouse and USB jump drives. Those do not work either. So I doubt it is iPad as my jump drives and mouse would not work either, but yet my iPhone works so I'm not sure it's the USB's either. It makes no sense! – bomb456 Sep 28 '20 at 14:50
  • System Report button - on the left USB – Wiktoria Tranowska Sep 28 '20 at 15:01
  • Hey thereI I am sorry, but I still do not see it. Can you take a photo or clarify better where the system report is? – bomb456 Sep 29 '20 at 16:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .