1

I have a folder on a second internal HD that I share from my Mac mini (running 10.12). I usually connect to it through SMB, but I need to use AFP due to using an older Mac. However, I cannot get the folder to show up while connecting via AFP, it only shows via SMB. I have tested and found that any folder shared from my internal SSD/boot drive is accessible via AFP, but not any folders from my internal HD.

Any idea what's going on and how I can fix this?

1

The issue was solved by turning off and back on File Sharing in the OS X Server app. Not sure why restarting and turning on/off the System Preferences checkmark didn't solve it.

| improve this answer | |
0

You need to turn on AFP support for File Sharing as, I believe, it is off by default.

Open System Preferences and click on ‘Sharing’. On the ‘Sharing’ panel click the ‘Options’ button and then enable the ‘Share files and folders using AFP’ option. After making the change you may need to reboot the system in order for the setting to work properly.

| improve this answer | |
  • I do have it on. As I said, it already works for sharing folders from the boot drive, just not the other internal drive. – At0mic May 3 at 15:07
  • Then you might need to add the drive to the ‘Shared Folders’ section of the ‘Sharing’ panel. But first, I would just try turning file sharing off, waiting 10 seconds, and turning it back on. – user128998 May 3 at 15:13
  • I already did that. I already rebooted, waited, disconnected and reconnected the Ethernet cable. I've even disabled SMB completely. Nothing seems to affect it. – At0mic May 3 at 15:17
  • Have you tried removing the drive from ‘Shared Folders’ and re-adding it? – user128998 May 3 at 19:54
  • I'm not trying to share the drive itself, just a folder on it. I have tried removing the folder, adding different folders from the drive, nothing seems to affect it. – At0mic May 4 at 6:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .