2

I'm using a standard USB keyboard with my MacBook, added a custom keyboard layout (in Library/Keyboard Layouts) and it works fine, but mac OS keeps switching back to the default layout after a few minutes.

update: I just noticed that it switches when I focus the Microsoft Outlook App. Strange. Sadly setting the language of outlook to English doesn't solve that.

I tried deleting the file Library/Preferences/com.apple.HIToolbox.plist (as suggested in similar questions) but it didn't help.

I'm currently running Catalina 10.15.3

enter image description here

New contributor
strudelkopf is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • I've had a similar issue with my custom keyboard layout. I don't really know what actually fixed it, I just tried exporting the layout (from Ukulele, which I used to edit it) a couple of times until one of them worked and "stuck". Sorry, I can't remember what I might have changed in between tries. – Lizzan Feb 14 at 9:53
  • Assume you are not accidentally hitting the keyboard shortcut for switching layouts, Control + Space? – Tom Gewecke Feb 14 at 12:12
  • @TomGewecke turns out that shortcut was disabled for me. But at least now I can switch back quickly to my preferred layout – strudelkopf Feb 14 at 14:48
0

update: I just noticed it happens with other programs too (for example mac OS' own Notes app) :(

I consider this is a weird quirk of Microsoft Outlook. See here for more details: https://answers.microsoft.com/en-us/msoffice/forum/msoffice_word-mso_mac/disable-automatically-switch-keyboard-to-match/717be469-2267-483b-9d66-7f9e77fac01e

I guess I'll use the Outlook Webapp from now on sigh

New contributor
strudelkopf is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .