0

Like the title says, I was trying to change my username on my MacBook (running High Sierra Version 10.13.6), it removed my admin privileges so I do not have an Admin account.

I tried rebooting in command mode and deleting the applesetupdone file, but it says the file does not exist, and when I reboot does not allow me to set up a new admin account, following the steps below:

Boot into Single User Mode: Start/restart your Mac. As soon as you hear the startup tone, press and hold ⌘ + S until you see a black screen with white lettering. (If you end up back on the login screen after a flash of the black screen with white lettering, enter your password and it will return to the black screen.)

Mount the drive by typing /sbin/mount -uw / then ↩ enter.

Remove the Apple Setup Done file by typing rm /var/db/.AppleSetupDone then ↩ enter.

Reboot by typing reboot then ↩ enter.

Complete the setup process, creating a new admin account.

What else can I try or do from here? Googling isn't giving me any options if the above doesn't work. Thank you!

4
  • There are quite a few related questions here. If for some reason none of them apply, editing this to explain how the top voted / selected answers don’t make sense to you or outlining where you are stuck would be a good reason to reopen this for an answer. – bmike Nov 19 '19 at 0:42
  • I'm not sure what to do, I tried doing everything people are linking me too and they aren't working? it's not that they don't make sense, it just isn't working – Ray Charles Nov 19 '19 at 0:45
  • @RayCharles the one that bmike linked has two answers, read the second to understand what is being done. support.apple.com/en-in/HT202860 – anki Nov 19 '19 at 1:04

Browse other questions tagged .