0

I have been trying to reboot my MacBook air 2017 from the disk I've used for a while.

Couple of days ago my mac shutted down with a circular error sign. I've been able to boot it back with an external HDD and backed up all my data but when I wanted to erase my crashed disks I've got error that unable to erase disk now please proceed. When I try to redownload Mac OS Big Sur with recovery mode it says permission denied.

Then I started the device in recovery mode and tried to erase it there, it got me writable disk is required error. I've tried to unmount disks, via terminal nothing changed. Tried to erase it from the terminal it says permission denied.

Finally I now opened single user mode, I can't even /sbin/mount -uw / or sbin/fsck -fy

It says permission denied error with 66

Guys I just wanted to erase my disks, what do I do now. I am no computer expert but soon I'll be. I am really frustrated.

0

Just to clarify: It sounds like you’ve booted into the Recovery partition. Can you confirm that you’ve run Disk Utility from there, selected your physical drive (first going into View -> Show All Devices and selecting the SSD media itself), and tried to erase that disk? If that fails, can you post a photo of the failure?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .