0

I'm trying to remove all tab completion features from my shell to start over and rebuild it properly.

I have homebrew installed and it's running bash v. 5.0.7(1). I had the bash-competion brew package installed which has been uninstalled. I have removed all completion features from the .inputrc file and, as far as I know, any trace of completion features from my other startup files.

However, if I type ec<tab> it still completes the command for me with echo even after opening a fresh shell. How do I turn this feature off?

2

OK, turns out it's enabled be default so you have to disable it explicitly:

Add the following line to the ~/.inputrc file:

set disable-completion on

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .