1

How do I completely disable Siri in iOS 12.2? In previous versions of iOS, there was a simple setting you could toggle that would completely remove Siri from your system. This setting seems to have gone missing in the latest version.

I thought I had disabled it by toggling off all the individual settings on the Siri settings page, but these annoying “Siri Suggestions” keep popping up every time I type something into Safari.

Help me to nuke the AI please.

2

Make sure you have turned off Siri & Suggestions under Settings → Siri & Search → Safari.

Additionally, go to Settings → Safari and toggle off Safari Suggestions to disable Siri Knowledge from appearing in Safari.

Alternatively, you can also choose to browse in Private mode to disable all kinds of Siri suggestions.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .