2

Clicking an app icon from the dock causes all other windows onscreen to minimize. Is this intended? Is there a way to configure it so selected app's most recent window gets placed on top without minimizing the other windows?

iMac Pro 2017 on Mojave 10.14.3

I'm running: Karabiner SensibleSideButtons Snap TinkerTool

Using: USB Mouse and Keyboard

  • that's not the default behavior. I don't have any of those apps installed, so maybe one of those is causing it, but I wasn't able to see that behavior fiddling with settings in Dock or Mission Control. – dwightk Mar 17 at 18:14
  • This sounds like single-window-mode to me (which was a thing in long gone versions of macOS, but who knows, maybe it's still there). Can you check if the Terminal/commandline command "defaults read com.apple.dock single-app" brings up a result? – Gummibando Mar 17 at 18:19
  • @Gummibando it returned 1 Sounds like that might be a lead. Is there a command to change that preference? – Theron Rogers Mar 18 at 22:08
  • @dwightk good to know that it's not designed to be that frustrating. Hopefully I can get it functioning the way it should. – Theron Rogers Mar 18 at 22:10
  • @TheronRogers Please check if my answer helps. – Gummibando Mar 19 at 9:14
0

Try this in Terminal/commandline:

defaults write com.apple.dock single-app -bool false; killall Dock

My hunch is that you accidentially changed this setting in TinkerTool.

  • Writing the value via Terminal and signing back in fixed it but restarting the Dock after correcting the setting per your suggestion probably would've straightened it out too. I really appreciate your help. It's been bugging me for a while. – Theron Rogers Mar 19 at 15:33
  • Also found this to be a setting in TinkerTool so I probably toggled it accidentally. Oops. – Theron Rogers Mar 26 at 1:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .