6

I just install macOS High Sierra and Windows 10 through BootCamp Assistant.

The problem is that, Windows have a strange issue and I need a bootable USB to go to the recovery mode.

I tried to make one from BootCamp Assistant but in the latest macOS the process is different and there is nowhere the "Create a Windows 7 or later version install disk" option and the only option I have is to remove the windows partion.

So, how I can make a Windows Bootable USB in macOS High Sierra?

6 Answers 6

8

This can be done via console for Windows 10/11 iso images (Not sure about 8/7, but leave any comment if it worked for you).
Start connecting your usb drive and type diskutil list to display all connected drives.
You'll see something like:

/dev/disk0 (internal):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                         500.3 GB   disk0
   1:                        EFI EFI                     314.6 MB   disk0s1
   2:                 Apple_APFS Container disk1         500.0 GB   disk0s2

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +500.0 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume Macintosh HD            185.7 GB   disk1s1
   2:                APFS Volume Preboot                 47.1 MB    disk1s2
   3:                APFS Volume Recovery                512.8 MB   disk1s3
   4:                APFS Volume VM                      4.3 GB     disk1s4

/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *15.6 GB    disk2
   1:                 DOS_FAT_32 LALA                    15.6 GB    disk2s1

For my case, the usb drive was /dev/disk2. Knowing this, format your usb drive with:

diskutil eraseDisk MS-DOS "WINDOWS10" MBR disk2

where disk2 is the usb drive id known in the prior command and "WINDOWS10" is the volume label (to be used later).
Please double check this step, or you could delete all data in another drive.
Then mount your image with:

hdiutil mount your_windows_10_image.iso

the command will return the location of the mounted iso

/dev/disk3                                      /Volumes/CPRA_X64FREV_ES-MX_DV5

so finally copy all the files from the mounted iso to your usb drive:

cp -rpv /Volumes/CPRA_X64FREV_ES-MX_DV5/* /Volumes/WINDOWS10

Update:

Look closely the copied files, as if you see a message like:

cp: /Volumes/CPRA_X64FREV_ES-MX_DV5/sources/install.wim: File too large

that's because the install.wim file is larger than 4GB, too large for your just created FAT32 partition in your USB stick (back in the day I originally posted this answer, probably the file wasn't that big). In this case, you will need to slipt it and copy it with the Windows Imaging libraries. So, using Homebrew install them with:

brew install wimlib

then call after (clearly, replacing the volume folder names to yours):

wimlib-imagex split /Volumes/CPRA_X64FREV_ES-MX_DV5/sources/install.wim /Volumes/WINDOWS10/sources/install.swm 3000

and now you will have two or more files with a swm extension instead of wim, where they won't be larger than 3GB

-rwxrwxrwx  1 alter  staff   2.9G 26 Nov 01:03 /Volumes/WINDOWS10/sources/install.swm
-rwxrwxrwx  1 alter  staff   1.5G 26 Nov 01:08 /Volumes/WINDOWS10/sources/install2.swm
7
  • Only this works with the 10/18 Windows release. I tried literally everything else. Commented Apr 11, 2019 at 1:39
  • Shoot. Except it is missing /Sources/install.wim Commented Apr 11, 2019 at 1:46
  • Since the file is greater than 4.2GiB (4.6) my workaround was to install NTFS for Mac (free trial, 10 days). Commented Apr 11, 2019 at 2:08
  • ...which I'm sad to say, did not work. Sorry for all the comments. Ray of sunshine. Commented Apr 11, 2019 at 2:39
  • This will split that file up for you: twocanoes.com/… (you don't need to use boot camp, just the ISO it generates) Commented Apr 11, 2019 at 4:16
6

For the future search, this solution works for me:

https://joshb.github.io/2017/11/23/making-a-bootable-windows-10-usb-drive-on-macos-high-sierra/

4
  • Welcome to Ask Different! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – Glorfindel
    Commented Mar 20, 2018 at 20:55
  • Alternatively you can do it from Disk Utility by choosing to format (e.g. 'erase') the USB stick device, choose type FAT and select MBR
    – clearlight
    Commented Mar 30, 2018 at 6:33
  • Unfortunately I am not able to boot from a USB stick I copied over the Windows 7 DVD files from for some reason. :-(
    – clearlight
    Commented Mar 30, 2018 at 6:34
  • Note to future self - this worked for me after a lot of frustration: linuxbabe.com/ubuntu/… Commented Jun 24, 2019 at 2:25
5

Since macOS Sierra this is no longer normally possible, though you can alter* Bootcamp to reinclude this option. Alternatively, you can create a bootable USB using the terminal, or using an application like UNetbottin.
You can find instructions for how to use the UNetbottin here, and for using the terminal or reincluding the option in Bootcamp here*.

*Note, altering the package contents of Bootcamp also no longer seems possible in macOS Sierra. At the moment, I do not know of a method to change/overwrite this.

3

Having tried all the available tools and generating 10s of unbootable Sticks, I finally created a Linux/Ubuntu bootable stick, which was trivial, and then, using the live Linux, created a bootable Windows USB Stick in no time.

0

Hey guys I know this is an old topic but in case someone still looking for the solution. I found a way to edit the Boot camp assistant info.plist

You cannot alter info.plist if you are booted from the same hard drive. You'll need a second partition with MacOS X installed. in my case I have two partition with High Siarra installed on both partition. and boot from the one you don't want to alter. in my case my second HDD.

Now just open finder and navigate to the HDD you want to alter and just copy info.plist to Desktop and make a backup of it before you edit. now you can follow Bootcamp - No ISO Option

Note: I try to edit with OS X default TextEdit but it doesn't work and I use sublime text, then it works fine.

2
  • You can edit the plist w/o requiring a 2nd hard drive if you reboot the machine holding CMD + R (boot into recovery mode), in the Recover GUI/Menu select the option to open a terminal window. In that window type: csrutil disable and reboot. That disables the protection mode that prevents modifying system files...
    – clearlight
    Commented Mar 30, 2018 at 6:31
  • Couldn't you just copy boot camp assistant, make the modifications, and run the copy, without disabling SIP?
    – whoKnows
    Commented Jun 14, 2019 at 15:06
-1

Boot Camp Assistant has been stable as always. Failed several times before I made a Windows 10 install USB on Mac 10.14. Here are a few tricks:

  1. The USB Flash drive must be formatted as exFAT
  2. Make sure download the latest Windows Support Software
  3. If there is not an AutoUnattend.xml at the top level of the drive, download AutoUnattend.xml, unzip it, and add it to the drive. AutoUnattend.xml provides the location of the $WinPEDriver$ folder to load the drivers during boot.

If this still fails, then here are a few good alternatives to Bootcamp for creating bootable USB on Mac:

https://unetbootin.github.io/ (Free, Cross platform)

https://www.balena.io/etcher/ (Free, Cross platform)

https://www.uubyte.com/iso-editor.html (Freemium, Win & Mac)

1
  • 2
    Unetbootin is only for Linux distros. Balena doesn't support Windows 10. Uubyte looks underwhelming at best. Commented Apr 23, 2019 at 20:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .