1

I have an external USB drive that I use for Time Machine backups. I've noticed that when I right-click on an item the Open With menu lists not only apps in my Applications folder, but also apps in the Applications folder on the Time Machine backup. Rebuilding the Launch Service Database will help clear out the list, but then it just grows back. I attempted to exclude the external drive from Spotlight indexing, but the external drive doesn't appear in the list of drives to exclude. Below is a screenshot of my Open With folder.

enter image description here

0

You should be able to exclude Spotlight from adding the apps on the Time machine drive to the "Open With..." menu by opening System Preferences -> Spotlight -> Privacy. Then drag the icon of the Time Machine drive into the "Prevent spotlight..." window. This adds that drive to list of drives that Spotlight should ignore for searching operations.

Note that you can't prevent Spotlight from indexing that dive as Time Machine depends on Spotlight to keep a catalog of files, but if you do this and then rebuild the Spotlight index it should prevent Spotlight from adding apps on that drive to your "Open With..." menu.

3
  • I used Onyx to hide the Time Machine drive. That was why I couldn't hide it in Spotlight. – RHPT Mar 12 '16 at 0:50
  • 1
    Same problem as OP. But when I try to exclude my TM drive or any subfolder of it, I get an error: “TM” is a Time Machine backup folder. You cannot add it to the privacy list. – luckman212 Oct 23 '20 at 18:42
  • As @luckman212 notes, you can't do this any more. I managed to temporarily disable it, and clean up about half the noise in the "Open With" menu, by booting in recovery mode, disabling system integrity protection, rebooting, disabling Spotlight on all volumes with mdutil, rebooting into recovery mode again, removing all the .Spotlight-V100 folders I could find, enabling system integrity protection, and rebooting. But this morning I'm back to eight versions of Firefox and six of Chrome. – David Moles Jan 6 at 19:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .