0

Our home iMac running 10.6 suddenly stopped loading web pages. Also when trying to do a secure shell login to another host in Terminal.app it gives the error

ssh: connect to host [hostname] port 22: Operation not permitted

It can ping [hostname] any site on the internet, printer sharing and file sharing still work, and I can log into it from a remote host by ssh.

It connects by ethernet and DHCP to a Zyxel wireless access point which connects with an ethernet cable to our housing cooperatives network, which has a firewall between our network and an optical fiber link to the outside world.

When connecting the same ethernet cable to a Macbook, everything on the Macbook works fine. Using a different ethernet cable to the Zyxel works with the Macbook but not with the iMac. Bypassing the Zyxel and connecting to the wall jack to the cooperatives network does not fix it.

I added a rule to pass port 22 in /etc/pf.conf, started pf, and that restored ssh. Then I added a rule to pass http ports and that didn't help. Then port 22 stopped working.

Since I have been wanting to upgrade to 10.10, I did a clean install of 10.10 from a bootable USB installer, but in addition to restoring user files and applications from the Time Machine disk I also restored computer and network settings and the problem was still there. I did another clean install without restoring computer and network settings and everthing started working.

Thinking the problem had been solved, I used App Store to update OS X, and after the next reboot the problem came back.

I ran extended Apple Hardware Test from a USB and no problems were found.

I installed Icefloor from a USB and configured it to allow outbound ssh in pf and that didn't help so I disabled it and rebooted.

To summarize, outgoing ssh and http packets don't work but many other network services do.

Has anyone solved a similar problem and have any suggestions before I take the iMac to the distant Apple Store or the local Apple certified repair place?

Thanks,

Alan

1

Fixed by removing old NetNanny extensions as suggested in https://discussions.apple.com/thread/2296455

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .