0

Similar to How do I edit an info.plist file inside of a kext file?

There is a need to change how a kext works.

(Specifically /System/Library/Extensions/AMD6000Controller.kext/Contents/Info.plist needs a change in IOKitPersonalities > Controller > aty_config > CFG_FB_LIMIT from 0 to 3)

This can be achieved by manipulating the info.plist file inside the kext.

However, in newer versions of macOS, this requires either a certificate to re-codesign the kext or disabling SIP (at least partially with csrutil enable --without kext).

I am looking for alternative methods.

Loading the kext manually apparently doesn't offer the option to pass parameters.
Is there an nvram command to force this on boot?
Is using Clover the easiest way?

How to use a kext that has just the info.plist changed without codesign or SIP disabled?

1 Answer 1

1

If you have no problem in keeping SIP half-enabled like you mentioned, then you can proceed, but with caution. Unless you are really sure that this Info.plist change will work as expected, do the following:

  • Copy the modified kext into System/Library/Extensions after authenticating
  • Execute sudo chown -R root:wheel /sample_path_to_kext
  • Execute sudo chmod 644 /sample_path_to_kext
  • Execute sudo kextcache -i /
  • Restart

Alternatively you may use an app like Kext Wizard or Kext Drop and just perform sudo kextcache -i / at the end of their operation.

Lastly, I cannot stress enough how dangerous this is to your Mac. Please proceed only if you really know (or don't care) if something unexpected happens.

3
  • Welcome to Ask Different! – Thing is, "modify the kext" is done. I now already do run the modified plist. To recover from a failure of it isn't that hard. What is cumbersome is that eg I rather frequently have to reset nvram/pram, requiring then another SIP-dance. / In any case, can you provide links to KextWizard and KextDrop, as they are not really well known standard tools? Commented Mar 13, 2019 at 15:07
  • Hey! Not sure if I can paste links here, is it allowed? Also, I would be interested to know, as you say, how do you recover from a potential Kernel panic if something goes wrong? How do you restore the original kext?
    – Denicio
    Commented Mar 13, 2019 at 16:37
  • Allowed you should be, just try. // The questions differ for OSes, as it got more complicated in.13 & .14. Too long for comments. But it sounds like a good question to me, perhaps post it like one here? Commented Mar 14, 2019 at 9:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .