Hot answers tagged

445

System Prefs > Mission Control Uncheck Automatically rearrange Spaces based on most recent use. This will fix the order of all your regular Spaces - but not Fullscreen spaces, which always go to the right of existing numbered Spaces. From comments: Note this cannot fix the Mac confusing which external screen is which. That's not user-controlled at all, &...


160

I posted a bug on Radar#28495374 and here is the response from Apple: Fixed in 10.12. Go to Accessibility and Turn on Reduce Motion… Please let us know whether the issue is resolved for you by updating your bug report.


37

You can enable this feature in the "Keyboard" preference pane. Open System Preferences (e.g., from the Apple menu) Click on the "Keyboard" preference pane Go to the "Shortcuts" tab Choose "Mission Control" from the menu on the left Look in the box on the right for "Switch to Desktop 1" Enable the feature by "checking" the check box Be sure that the keyboard ...


34

This is something that I wanted for ages, so I finally got around and built an open source solution! It behaves similarly to TotalSpaces in that it uses SIMBL to hook into the display functionality, and uses an application with a top menu bar button to rename the desktops. To install it, just head over to my GitHub and follow the installation instructions! ...


29

Yosemite This behavior can be mapped to your desired key combination like so: System Preferences > Keyboard > Shortcuts > Keyboard > Move focus to active or next window Mavericks ^F4 does switch through windows in the current space but you may have to upgrade to Yosemite to map this behavior to ^~. But the problem can still be alleviated like so: ...


29

You can change the default preference easily: System Prefs > Mission Control > Automatically rearrange Spaces based on most recent use.


28

This seems to be Google Drive-related. The behavior has stopped after quitting Google Drive app (in the taskbar). If you have the same issue, please also report to the Google Support Forums so Google will know the extent of the issue: http://productforums.google.com/forum/#!category-topic/drive/report-a-problem/sv-ZC0ws3Mw This is now fixed - https://...


24

Nop, there is no way to do that =/ --> Now it's possible (EDIT) By the way, you can put an application into fullscreen and the Desktop will take the application's name. Related Questions : The commercial TotalSpaces by binaryage allows you to name spaces. Patrix : May be worth noting that you need to partially disable SIP in order to use TotalSpaces,...


22

A very low technology but quite direct solution is to assign keystrokes to each desktop (Preferences -> keyboard -> shortcuts -> Mission Control : allows you to assign ^1 to Desktop 1 and so on). Then write your desired Desktop Names on a small stickie note (a physical one!) and stick it near the number keys. All your Desktop names are constantly in view, ...


20

According to the Reddit thread, Is there any way to disable Mission Control coming up when I drag a window to the top of the screen?, the solution is: System Preferences > Mission Control Uncheck "Displays have separate Spaces" then log out and back in again. It works, I had the same issue & now it's sorted.


15

I am using the built-in Stickies app. I've created a sticky for each space on the top left corner. Just set the sticky window to Floating which keeps it on top of every other window. This way you get a nice label for each Space which is visible while you are working. To see all your Spaces just select the Stickies app, click Control + ↓ and you see the ...


11

I know Hyperswitch didn't exist when that question was asked, but it is a modern answer to that question, and it is much better than hacking with Karabiner (formerly KeyRemap4MacBook) and/or struggling with the system preferences (since they don't accept any key mapping for every command). Please see https://apple.stackexchange.com/a/127414 and upvote it if ...


11

You can only move spaces which are non-active. For example, lets say you have spaces 1 and 2. If space 1 is active, you can not move it. You first have to select space 2 then you can move space 1 to a different monitor.


11

I did this recently to get an iMac to better support an X-Arcade Tankstick and MAME. I do not know that it totally disabled Spaces, but is has effectively eliminated them for me. System Preferences > Mission Control: Uncheck everything. Set shortcut for Mission Control to "-" System Preferences > Keyboard > Shortcuts > Mission control:...


11

edit 2: This still doesn't COMPLETELY work for me as well: some windows are restored and some are not. The new bug id in Chromium is 1012034, and it still needs your votes! edit: It was implemented in the latest development version (Chrome 79)! Though, by default, in compliance with Apple's UI requirements, this feature still won't restore the workspaces ...


11

Add a sticky to each desktop, with the desktop label. Then you can right-click on the app icon and switch between desktops!


11

Try using Helium. It uses a 'customizable translucency' to keep a window on top of other windows. Plus, it won't intercept mouse clicks on top of it unless you want it to. As of now, it only supports a browser window but the question doesn't indicate if that's a requirement of the OP or not.


10

You can uncheck "Automatically rearrange spaces based on most recent use" on the "Mission Control" tab in system preferences. This will leave the desktops in the expected order.


10

I'm a Spaces user of long-time habit, even though I've always had 2 screens. I find the best way to get around is to pin specific apps to specific Spaces [then remember where they live, which is the only difficult bit] If no apps are yet assigned this way, then switch to the chosen Space before launching the app, then right click the app in the Dock & ...


8

Amethyst With Amethyst, you can send windows to specific spaces using configurable keyboard shortcuts. One possible setup is: Command + Control + 1   [send to Desktop 1] Command + Control + 2   [send to Desktop 2] Command + Control + 3   [send to Desktop 3] and so on . . . By default, Amethyst automatically tiles your macOS windows. If you do not want ...


8

It is Google Drive, it's causing Finder to crash and restart, which is why it keeps jumping back to the first desktop. It's related to the "Show file sync status icons and right click menu" setting. If you turn this setting off in the Google Drive preferences, the problem should go away.


8

I wanted to do something similar. While I'm not sure it's possible to make the "Move left" and "Move right" shortcuts behave like you want (at least not without a third-party tool), you can get pretty close with the "Switch to Desktop [n]" shortcuts. Here's what I did: In Mission Control, add or remove desktops from both displays so you have the same number ...


8

UPDATED SOLUTION: I came up with a better hack inspired by Karl's answer. Open up the Stickies app. Right click on it on the Dock and select Options -> All Desktops. Create one sticky. In it create a list like this: Desktop 1 - Email Desktop 2 - Gaming Desktop 3 - Home Business Make it tall enough and the font large enough so that it is legible when in ...


8

I have macOS Sierra 10.12.6, and this option is in Mission Control settings (also looks like it's in the same place on my old Mac running 10.7.5). Simply uncheck the option "When switching to an application, switch to a Space with open windows for the application", and Cmd-Tab will no longer make you switch Spaces. Clicking on an app icon in the Dock will ...


7

It seems like OS X automatically re-assigns ⌥→ and ⌥← to jump one word forward/backward, as soon as you disable the 'switching space' shortcuts in the Mission Control. System Preferences → Keyboard → Shortcuts and uncheck the Mission Control shortcuts


7

You just need to ctrl + click on the Finder Icon in the Dock. Go to the Options, and choose how the finder windows show in Desktops All Desktops All Window show in Desktop Spaces This Desktop All Window show Only in the current Desktop Space. When your are in another desktop space it will jump to the one for finder when you open folders into windows or ...


7

This is because by default Chrome is assigned to the first space. I believe this problem arises when you install Chrome and then enable Spaces afterwards. I have also experienced the problem and it is frustrating. Here is the solution: Find the Chrome icon in your Dock Right-click on it (or control + click with a one button mouse) Mouse-over the Options ...


7

Open Terminal.app, then run the following commands. Change the default workspace preference: defaults write com.apple.dock workspaces-auto-swoosh -bool NO Next, restart the Dock with this command: killall Dock References: How can I disable auto-switching desktops? Disable Space switching on Command-Tab


7

I actually figured out how to fix this on the fly. I believe this state occurs when you inadvertently make a swipe gesture while a ctrl-key is held down. I can't be sure of that, but the fix is to do exactly that: hold down the ctrl-key, and then do the desktop-switching swipe gesture (for me it is 3-finger swipe left or right). I don't know how to ...


7

I've seen this intermittently for a few releases now. I fix it by restarting the "Dock" process (which handles Spaces/MissionControl) using this Terminal command: killall Dock I don't know how to do that via the regular GUI, sorry. And before you run that command, do killall -s Dock to see the processes which will get killed. If only the one "Dock" process ...


Only top voted, non community-wiki answers of a minimum length are eligible