New answers tagged

1

If the Application is Terminal, this already has shortcut keys configured in Preferences: New Terminal at Folder ^+⇧+T New Terminal at Tab Folder ⌥+^+⇧+T


0

In Safari ⌥ + Tab appears to select every link through google. Tried it in DuckDuckGo and I don't get the same behavior but if you search and just use the up and down arrow keys without clicking anything it selects the various links. Chrome it appears you may need an extension such as Google Search Keyboard Shortcuts


0

Resolved by installing the dotfiles again. Still don't know what caused the problem…


0

The issue is that often conflicts exist between the shortcuts used for changing Input Sources and those used for showing the Spotlight search field. To check/change these, follow these steps: Go to Apple > System Preferences Select the Keyboard preference pane Select the Shortcuts tab In the list at left, if you notice a warning icon next to either or both ...


3

To get this to work the way you want, you have to set the option key to be used as a Meta key. To do this: Launch Terminal Go to Terminal > Preferences... Select the Profiles icon at top Select the profile you're using from the lefthand side Click on the Keyboard tab on the righthand side Now tick the Use Option as Meta key checkbox at bottom of the screen ...


2

I use PhpStorm 2019.2 on macOS 10.14.6 Mojave. The behavior/logic for CMD + ` is not any different from how it has been in any relatively recent version of macOS or PhpStorm. Pressing CMD + ` switches to the most recently used window, unless you haven't done anything in the currently active window, in which case it switches to the next most recently opened ...


-2

I think there is no shortcut for that in Mac. And it should have this function.


1

This should be possible using Cocoa bindings - see this answer: https://superuser.com/a/283948/659069 -- The example below (taken from the link above) binds a 'move line down' shortcut to Opt-DownArrow - you should be able to modify this to meet your needs. Create the file ~/Library/Keybindings/DefaultKeyBinding.dict and enter the following: { "~\...


1

Go to Iterm2 Preferences Profile Keys. Click on "load Preset..." drop down-menu Natural text editing and chose "Natural Text Editing" after that, the command "alt + arrow left/right" should function properly


-1

In case you use Noizio app, it reserves Command+Shift+Down/Up for volume adjusting. You can switch that off in Noizio > Settings > Shortcuts.


1

Yabai: tiling window manager with support for spaces https://github.com/koekeishiya/yabai/wiki#comparison-with-other-window-managers Requirements of Yabai "System Integrity Protection (SIP)" must be disabled "Displays have separate spaces" must be enabled Note Yabai allows you to switch to a different space without animation (great) Disable the Mission ...


2

Sharing a solution to this problem, although it's pretty uncommon case. Root cause of the problem was Karabiner elements setup. They have a ticket open corresponding to this case: https://github.com/tekezo/Karabiner-Elements/issues/1160 What you need to do to start registering this hotkeys is essentially enable unknown devices in Karabiner settings.


Top 50 recent answers are included