132

You should be able to do this by choosing the monitor on which the menu bar is active. Try - System Settings -> Displays -> Arrangement and drag the little white bar to the monitor where you want the notifications to show up.


116

The solution to disabling the "almost full" and "full" notification is to disable the daemon responsible for it: launchctl unload -w /System/Library/LaunchAgents/com.apple.diskspaced.plist or launchctl stop com.apple.diskspaced Alternatively, if you only want to prevent the "almost full" from appearing so often then you can lower the GB threshold via: ...


72

The correct answer to this issue isn't to message all your contacts. First close the Messages app. Then simply open up Activity Monitor and quit the Dock process to restart it. Here's how it looks: Your badge count should be reset after that. PS: You can access Activity Monitor from Spotlight (⌘ Space) by simply typing its name and pressing Enter. ...


70

Unfortunately, you can't change the screen position of the Notification Center Alerts and Banners. This is a huge gripe of mine as well, and I highly encourage you to complain about this issue to Apple here: http://www.apple.com/feedback/macos.html Hopefully they will one day change this. I also have not been able to find or formulate any hacks. I, too, am ...


62

Actually, it is possible - here's how: Create a smart mailbox ( Menubar > Mailbox > New Smart Mailbox ) which shows the content of all the mailboxes that you would like to get notifications for, and give it a nice name (for example, 'Notifications'). In my case the only rule in this mailbox is a 'Message is in Mailbox' - but you can be creative! Go to the ...


41

macOS Mojave See: How to access a launch daemon's values/ system defaults value macOS Sierra On Sierra this command didn't work for me: launchctl unload -w /System/Library/LaunchAgents/com.apple.diskspaced.plist due to System Integrity Protection engaged, so to stop the diskspaced service, run: launchctl stop com.apple.diskspaced Note: Use start ...


40

When you click on the notification icon in the top bar, you can select "Do not disturb" there by clicking the icon and scrolling up, the setting is hidden above the first notification. You'll see that the icon is greyed out to show the change in state. As a shortcut you can click on the notification icon in the top bar whilst keeping ⌥ ALT pressed to go ...


37

Settings App -> Notifications -> Messages -> Repeat Alerts change that to "never." :-) Let me know if that helped...


34

You can get rid of it without giving in to Apple‘s desire for you to “Try Now”. Even if you click the button, they will ask you to change your default and may still ask again at a later time. I have explained it in much greater details on my blog but the gist of it are these three commands: defaults write com.apple.coreservices.uiagent ...


28

After some unsuccessful googling, followed by loads and loads of digging and grepping through binary files, I stumbled upon a key in a .plist which, when written, appeared to make the system temporarily forget it had any updates to bother me with. Running: defaults write com.apple.systempreferences AttentionPrefBundleIDs 0 fixed my issue for now (...


27

If the App store doesn't know about updates it should not be able to notify you - so within System Preferences go into the "App Store" preference pane and deactivate the option to search for updates automatically.


27

I have a solution that I was able to reverse engineer. I've tested it on my machine, running Yosemite 10.10.4 (14E46). If you can find the bundle ID (in the Info.plist file for the app bundle), you can use this script to force the app to appear in the notifications preferences pane. # "Usernoted" seems to be the "user notifications daemon", so get it's PID. ...


26

Go to Settings > Notifications > Stock Widget and turn it Off. Notifications for all apps that can display them are managed in Settings. Two built-in apps, Stocks and Weather, get exceptional treatment and show in Notification Center as widgets. In the Notifications Settings, they are listed as Stock Widget and the Weather Widget. To prevent an app from ...


26

Yes, in iOS 8: To do this, simply go into the Calendar app, tap the “Calendars” button in the bottom center to bring up your list of Calendars, and then tap the red “i” to the left of the calendar you’d like to change. Scrolling all the way to the bottom will reveal an “Event Alerts” option — simply toggle this OFF to prevent alarms in that calendar from ...


25

You can create Automator service to run this Applescript and give it a keyboard shortcut in the System Preferences Keyboard shortcuts This will close Alert and banners Notification In Automator choose a new service Add a Run Applescript Action and replace it's code with: my closeNotif() on closeNotif() tell application "System Events" tell ...


24

Since the release of Safari 7.0.3 Apple finally gives us an option to turn off safari notification prompts. To disable safari notifications go to Preferences within Safari. Click the Websites tab (notifications tab for older versions of safari) and uncheck "Allow websites to ask for permission to send push notifications". And voilà. Websites panel for ...


22

I figured out that I needed to enter the following in the terminal: sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.apsd.plist I did this already, and it seemed to fix the issue, but would love to know if this is the advisable way to solve the problem. ======================================================== Also, in case you want to ...


21

Swipe with two fingers on the banner pop up and it will remove it. Not the best answer but convenient for when I need to access a control or tab. Source: http://www.cultofmac.com/189192/


21

You can easily activate Do Not Disturb on a Mac to silence notifications temporarily. Just hit the Notification Center icon (the rightmost in the menubar), scroll up to the top, and activate the Do Not Disturb toggle. You can also schedule Do Not Disturb sessions in System Preferences -> Notifications. Edit: As @beer's answer mentions, you can click on ...


21

To add to previous answers, if you are mirroring onto a projector or screen, it is possible to disable notifications by going to System Preferences -> Notifications -> Do Not Disturb -> When mirroring to TVs and Projectors and checking the box beside it.


20

Before you kill Dock you need to close Messages to make it work. I had this issue on Mountain Lion (Mac OS X 10.8.2). When Messages was open and I killed Dock it didn't help. But when I closed Messages and then killed Dock, the badge was gone and after opening Messages the unread messages appeared so I could read them.


20

This worked for me: Open Calendar on your Mac. In the left column list of calendars, right click (or command-I) on the calendar in question and "Get Info" Check the box labeled "Ignore alerts" Hit "OK"


18

The badge is notifying you of a Calendar notification. There are two cases which causes a badge: You've been invited to an event. An event on one of your shared calendars has been modified. To clear the badge, open Calendar and click Notifications on the toolbar, then take action on the notification by selecting Accept/Decline/Maybe on an invitation or OK ...


18

Figured out the completely non-obvious solution. In the Time Machine preferences you have to right-click on the drive icon and then select "Stop Using {Drive Name} for Backup". Extremely terrible UX, but at least it's doable!


16

When you don't have the external hard drive hooked up, go System Preferences >> Time Machine, and switch it to OFF. You will still be able to perform backups, it just won't happen automatically. In newer OS versions, you must uncheck the Back up automatically box and then right-click on the backup disk on the right side and select Stop using ‘Time Machine’ ...


15

An update for Mac OS X 10.9 (Mavericks). You can turn on Do Not Disturb in Notification Centre to mute notifications: You can show Notification Centre by clicking on the three-horizontal-lines icon on the far-right of the menubar, or perhaps by doing a two-finger swipe from the right edge of your trackpad (if this gesture is enabled in System Preferences -> ...


15

You can adjust the time the notification is displayed on the screen: In a terminal window type: defaults write com.apple.notificationcenterui bannerTime SECONDS Where SECONDS is the number of seconds the notice will remain visible. Default is 5 seconds. Log out and in again to activate the setting. http://www.defaults-write.com/notification-center-...


15

The following works: osascript -e 'display notification "Hello world!" with title "Hi!"'


14

As of Mac OS X 10.7 Lion, Terminal has exactly this feature. If you emit a bell (BEL, Control-G) in a background tab or window, the Terminal application Dock icon will show a badge with the number of “unread” bells and a bell icon is displayed in the tab of the terminal (If there is only one tab in the window, choose View > Show Tab Bar to see the tab, ...


13

This is an old question, but just in case someone stumbles on it and is specifically worried about the privacy implications of Notification Center, the answer is YES, OS X does keep a log of notifications on disk. The format is an sqlite database, and it can be found inside this folder: ~/Library/Application Support/NotificationCenter Inside you'll find ...


Only top voted, non community-wiki answers of a minimum length are eligible