edit: The option described below has been removed from Chrome. This should void the question as well as my answer. Old answer: In the Chrome Menu Bar under "Chrome -> Hide Notification Icon" you can get rid of the bell without having to go through flags (which doesn't work/exist any more!). It's the Option one from the bottom (I found the information in a ...


You want to change line 92 of the xml version of /System/Library/CoreServices/Menu Extras/Battery.menu/Contents/Resources/English.lproj/Localizable.strings: Make a copy of the strings file: cp /System/Library/CoreServices/Menu\ Extras/Battery.menu/Contents/Resources/\ English.lproj/Localizable.strings ~/Desktop Convert the binary strings file to xml: ...


Hold ⌘ and drag it away from the menubar.


"Lock Screen" is now available via the Apple menu.


That item is the VMWare fusion menu bar icon. The vendor has this article and steps to allow you to disable and configure it. http://kb.vmware.com/kb/1015330 To modify the behavior of this feature: Go to Virtual Machine > Settings. Click Application Menu (Applications in Fusion 3). Click the Applications Menu tab if using Fusion 3. From the Show ...


Go to System Preferences → Keyboard → Shortcuts → Input Sources and define a keyboard shortcut there. As you only have two sources, set a single shortcut for one of the options, then pressing the shortcut will toggle the input sources.


The Eject menu is part of the Menu Extras that are of the standard core service items for the Mac. It is not normally enabled. But one way of enabling it is to double click on the /System/Library/CoreServices/Menu Extras/Eject.menu file. The Eject menu is normally for your built in disc drive if you have one. It may or may not work on external disc ...


As explained in the referred question, hold down Command key, press the icon in your menu bar, move it. This works at least in Mountain Lion up to Yosemite. But still this only works for movable items. You can move the Wifi symbol, the Bluetooth symbol, etc. But you cannot move the Twitter or Dropbox symbol.


Open System Preferences Select User & Groups Select Login Options (not Login Items) (Click the lock to make changes at the lower left corner of the window) Uncheck "Show fast user switching menu as ...


Update 2015-03-04: According to some updated release notes from the Bartender app (v1.2.32; emphasis mine): Apple appear to have fixed the flickering item issue for multiple monitors in Yosemite with 10.10.3 Beta 2; but in doing so Bartender stopped working correctly. We have made changes to Bartender for 10.10.3 Beta 2 and anticipate it to now be ...


So I got fed up with this and decided to fix it the hard way. I found out where Spotlight initializes the status bar item, and I just patched the status bar size to zero. This requires editing the Spotlight binary. (Note that Search.bundle is just the little stub that gets loaded into SystemUIServer to allow Spotlight.app to control the status bar). You'll ...


Just ⌘ Command-Drag & Drop it away from the menu bar, this way you can also re-arrange your icons. This trick will only work for OSX icons (e.g. Time Machine or WiFi), for non OSX native icons (e.g. Dropbox or GeekTool) you need a third party app like Bartender or Menu Bar Rearranger.


Google has buried this option in a very hard-to-find location. Visit chrome://flags/#enable-google-now in Chrome.app Visit chrome://flags/#notification-center-tray-behavior in Chrome.app Change both settings to Disabled. (They're probably on Default currently.) (NOTE: this used to be chrome://flags/#enable-rich-notifications)


Hold ⌘ and drag it out of the menubar. Also, in the networking system preference, you can often find a show icon in the menu bar preference. I can't recall if this checkbox is easily shown when the hardware is no longer present, but it's an alternative to dragging the icon out directly in some cases.


SystemUIServer is the process responsible for the menu bar and any menu extras. You can restart it in Terminal using: killall SystemUIServer


I've been annoyed by this, too, and the simple, yet very, very painful answer is to hold alt ⌥option and press the green title bar button (which should turn into a + when you hold option/alt) If this doesn't make it cover the screen, you can finish the job by holding alt ⌥option and double-clicking a corner to resize the window to fill the screen. ...


According to the following blog entry Apple removed the option deliberately and it won't come back: http://www.macpoint.be/mountain-lion-is-coming/ I also missed the option, so I wrote an App. It's in beta now: http://batterytimeapp.com/


In System Preferences > Accessibility > Display, enable the "Reduce Transparency" option. (Note, though, that that disables transparency across the whole system; it doesn't seem like it's possible to disable the transparency just for the menu bar anymore.)


I was experiencing this behavior on a secondary display as well. Although it is merely a workaround, I can confirm that putting an app in Full Screen mode on the secondary display will force the OS to redraw the menu bar.


If a menu icon is allowed to move, command + mouse select will work. You might have to patch the program (or System Ui Server). Have you asked the developer if they can implement this as a feature? Only the Apple icons are movable on my 10.6.7 systems so it certainly isn't easy for a developer to get this working and may be impossible in practice. The ...


You just have to press the Command key while dragging the username out of the menu bar like you would to remove a dock item.


I'd recommend using the utility app called Bartender. http://www.macbartender.com This is a handy utility to manage and change the way menu bar icons are displayed. You can leave them in the menu bar, have them dropped down into the bartender bar which itself is opened via a small icon in your menu bar, but can hold any of the icons normally in the menu bar,...


Although I do not know the problem, there are several solutions. Reboot or Log out. Kill the SystemUIServer process, either via Activity Monitor or via killall SystemUIServer. The UI server will restart and the problem will be gone. I've seen it happen that I needed to kill it twice to fully take effect.


Hold ⌘ and drag it out of the menu. If date and weekday are shown, they will also be removed. Alternatively, you can disable and customize the clock in: System Preferences → Date & Time → Clock.


This works at least up to 10.9.2. To disable: sudo mv /System/Library/CoreServices/Search.bundle /System/Library/CoreServices/Search.bundle.bak killall SystemUIServer To re-enable: sudo mv /System/Library/CoreServices/Search.bundle.bak /System/Library/CoreServices/Search.bundle killall SystemUIServer


Fusion 8 In Fusion 8, this is in VMWare's Preferences. 1. Click VMWare Fusion and select Preferences... 2. There will be a dropdown for Applications Menu: 3. Set this to Never or Only when Fusion is running


If you have "Use all F1, F2, etc. keys as standard function keys" checked in System Preferences → Keyboard → Keyboard tab Ctrl + F8 moves the keyboard focus to the icons in the menubar If you have "Use all F1, F2, etc. keys as standard function keys" unchecked in System Preferences → Keyboard → Keyboard tab Ctrl + Fn + F8 moves the keyboard focus to the ...


Display Menu (free) on the Mac App store adds the menu options back for OS X 10.8


I just installed menumeters. If you go into the preferences for MenuMeters it is possible to add a network icon to the OSX menu bar. Clicking on the icon, indicates the current network (i.e., wifi or Ethernet). This is a reasonable solution, but it still requires you to click on the icon to see whether ethernet is connected.


This seems to have changed to chrome://flags/#enable-google-now I would make a comment instead of a new answer but I require 50 rep for that.

Only top voted, non community-wiki answers of a minimum length are eligible