Episode #125 of the Stack Overflow podcast is here. We talk Tilde Club and mechanical keyboards. Listen now

Hot answers tagged

14

Instead of guessing which php.ini you need to alter, run this command to locate the file: php -r 'phpinfo();' | grep 'php.ini' Even though I use MAMP PRO, by default my command-line PHP commands are not executed using their copy of PHP. In my case it says the file is found at /etc/php.ini Once you have located the file, follow the instructions on all of ...


10

I had the same problem - it's based on mod_userdir exclusion after updating to Mac OS X Mojave. There are a few steps to repair that: Load the module mod_userdir in /etc/apache2/httpd.conf At the end of the httpd.conf make sure to load httpd-userdir.conf In httpd-userdir.conf include a local file in /etc/apache2/users/<username>.conf Put a directory ...


9

The solution was to move the domain in the /etc/hosts file to the same entry as localhost. 127.0.0.1 localhost domain.com See this StackOverflow thread.


9

In the MAMP application, click on "Preferences..." then go on the "Apache" tab. There you will be able to locate the default folder. You can create a new one and set it as default there too.


5

The MAMP Pro 1.0/2.0/2.0 upgrade/3.0 serial numbers are stored in the following files: "/Library/Application Support/appsolute/MAMP PRO/Registration 1.0" or "/Library/Application Support/appsolute/MAMP PRO/Registration 2.0" or "/Library/Application Support/appsolute/MAMP PRO/Registration upgrade 1.0 to 2.0" or "/Library/Application Support/appsolute/MAMP PRO/...


5

Your host is part of the domain COMPANYWORKDOMAIN and user rob is a domain user (probably admin, network, managed) but no local admin user. nginx.conf line 7 is determined by the "Run server as:" settings in MAMP Pro and mustn't be edited manually: Since your user is no local admin account using rob will fail. So either use the standard Unix users (www/...


5

The Mojave update (or re-install) overwrites the apache directory but left my old configs with the ~previous suffix left. I did edit a lot of previous files in my apache path /private/etc/apache2. These files were renamed to like httpd.conf~previous and a new httpd.conf has taken place. I just renamed files, restart my apache and everything is working ...


4

From http://drupal.org/node/66187 (drupal may be irrelevant for your needs, but their site had a good explanaton - wanted to source it for you, and give credit to them) By default, MAMP has the memory limit that a script can use set at 8MB, which is the PHP default. Looking at PHP's php.ini-recommended file, this memory limit is normally set at 128MB. To ...


4

For Mac OS X Yosemite Update openssl by brew to version >= 1.0.2d TLS 1.2 works only with apache 2.4 and actually MAMP is still given with apache 2.2. SOLUTION: download and install the latest version of AMPPS which runs a version of apache 2.4.x create a self signed certificate with sha256 (as requested by iOS 9) with openssl req -x509 -nodes -sha256 -...


3

Probably you added one or more bin directories (containing mysql and php) to your $PATH. Remove them. The three php* files in /usr/bin belong to the default OS X system and are completely legit.


3

For my own outward-facing servers, I did everything from within the built-in server software itself, except managing virtual hosts, for which task I used VirtualHostX. The best tutorial I know for configuring Mavericks for web server use is done by Charles Edge, at his site, Krypted. I followed this same process essentially, and thus far, I've seen no ...


3

The answer to this superuser question and this stackoverflow question both say approximately the same thing, that you need to perform the following actions: If you haven't yet rebooted your computer, the process could still be running. First, reboot. Then if MySQL is still showing up after a reboot, from the Terminal, issue the following commands ...


3

Also had Apache not starting after upgrade to Catalina. I had my websites originally located in subfolders of the /Users/***/Sites/ folder, and according to this thread, made a new folder /Users/***/Repos and moved all websites there and updated MAMP Pro doc roots for all hosts. That didn't allow Apache to start. After that, I found this info: Check your ...


3

Catalina has more restrictions on system folders which we can apply an exception: Open System Preferences -> Security and Privacy -> Privacy tab -> Full Disk Access -> Press 'Unlock to make changes' padlock Open Finder Window -> "Go" menu -> "Go to folder" -> type "/usr/sbin/" Drag the file "httpd" to the list inside the Full Disk Access settings. Restart ...


2

For me, I did the following: Edit the /Applications/MAMP/conf/php5.4.4/php.ini and php.ini.temp to be: memory_limit = 128M ; Maximum amount of memory a script may consume (8MB) Then in finder simply make the php.ini and php.ini.temp read only for all users. This way, MAMP cannot overwrite it with default files. Restart the server and check your ...


2

Put it in the htdocs folder, but when you go to look at it with your web browser - htdocs will appear at http://localhost:8888/. So if you create an index.html file, that will be what gets loaded when you visit http://localhost:8888/


2

I haven't used MAMP in a while, but according to their FAQ it looks for the HTML files (by default) in: /Applications/MAMP/htdocs This seems like an odd place to store them. You can (and probably want to) change the default in MAMP's preferences to a different folder so you can store your files somewhere else.


2

I've solved this problem (I hope) I simply went online and downloaded the python 2.7.3 DMG installer for Mac and installed python again. Hopefully, this will let me run everything I want. As of now, easy_install has started working and I'm going to start playing with Django... :)


2

It seems there are 2 memcache extensions. There is memcached and memcache the latter one does not seem to be maintained anymore last stable from 2012. It looks like your code depends on Memcache since you are using brew, you could just do: brew install php55-memcache or pecl install Install brew by issuing: ruby -e "$(curl -fsSL https://raw....


2

AFAIK MAMP is not intended to run Apache/MySQL as www/mysql. However MAMP Pro allows you to run Apache and MySQL either as your user or as www/mysql. This can be done by selecting the respective users in Preferences -> General. MAMP Pro contains the free MAMP and a free 14-day trial of MAMP Pro.


2

Remote/delete the downloaded file Download it again, it should get a .zip extension Double-click the downloaded file to unpack it In Terminal, run cd ~/Downloads chmod +x Install_MySQL_5.6.25.command ./Install_MySQL_5.6.25.command


2

you need to update mkcert on your system. brew install mkcert --HEAD mkcert -install https://github.com/FiloSottile/mkcert/issues/174


2

I have the same issue after update but didn't find any solution yet. For now I moved all my projects into a new folder in root. This one worked for me so far.


2

I have the same issues. Updated MAMP to the latest build (5.5). Also switched the ports back to MAMP default ports (8888). That worked for me. Also checked if some diffrent server was running on port 80 lsof -nP -i4TCP:80 | grep LISTEN but nothing seem to be using port 80. Could it be Catalina has a new security setting for this?


2

Several applications (GIMP for example) are not working also (they can't access "special" folders like: ~/Desktop, ~/Documents and ~/Downloads, but other locations seem to work OK). I believe this is a "complementary feature" bestowed by the newly-released Catalina. Update Different.


1

I wouldn't anticipate any problems. I've seen those configurations work just fine. The only concern I see is that the built in versions of the software get updated automatically by Apple, and the versions you installed will not. However, Apples updates include the latest fixes more slowly, so if you are diligent in installing them, yours will be up to ...


1

As of July 21, 2016, there is a pre-release available of MAMP PRO 4 which includes OpenSSL 1.0.2, get the pre-release here: https://www.mamp.info/en/pre-release.html


1

This may not answer your question directly, but it is a solution.... I am not a fan of doing dev work on my production Mac. I also don't see any value in setting up a MAMP server because it will be a very rare occurrence that you get a hosting provider with MAMP setup. Chances are it will be LAMP and by a very small margin, WAMP. Why not set up a LAMP ...


1

go to https://www.mamp.info/en/forgotSerial.php enter your e-mail MAMP sent all your earlier purchases that were done with that particular e-mail


1

I don't think MAMP relies on the php package installed in Terminal (or in OS X for that matter). MAMP uses it's own php version located at /Applications/MAMP/bin/php/php5.5.3 The modules are in the folder I noted above in a subfolder called /modules. You would have to manually get mcrypt in the modules folder for MAMP to work with mcrypt.


Only top voted, non community-wiki answers of a minimum length are eligible