As the below mentioned solution is application-based (i.e. only works for apps like Google Chrome), another way to approach this problem is to ignore the maximize button entirely and to install the open source app spectacle which offers the keyboard shortcut: ⌘ + ⌥ + F It also has some other nice features, too. And it works for all apps. In order to ...


With latest version of Chrome, there is the option to show the Toolbar (which includes tabs) in the View menu.


Click the minimize/maximize button a second time or press Control-Command-F simultaneously. The button can be green or grey depending on how you have configured the appearance under the General pane of System Preferences. To resize window, simply double-click window bar. The best way to do this that I have found is to put the cursor in the upper left hand ...


Zoom function can now be performed more easily — by double-clicking window title. You don't need to precisely aim at the small green button anymore, which I believe is the reason it has been converted into full screen button by default. If you hold the shift key and double-click the window title Applications that use "smart zoom" will be forced to do full ...


If none of that works, open Terminal and enter killall Dock.


WORKAROUND: Read somewhere that to get (temporarily) the resizing bar, you drag one of the split windows by the title to the other side of the monitor. The bar will remain for a while. Resize, and if needed, switch back the windows. It has been working for me on an external LG monitor in Mojave.


I found that BetterTouchTool solves this problem nicely (Note: BetterTouchTool is no longer free, the trial expires after 45 days). The Preferences aren't quite intuitive: Select "Other" category at the top of the window. Make sure that "Global" is selected at the left side. Click "Configure New Trigger" button in the bottom part of the window. Select "...


Use spectacle, a free open source app that has a bunch of handy window management shortcuts. While it doesn't change the default behavior of the green button, it makes it superfluous for me to do so as I can do everything using keyboard shortcuts without using the mouse. For full screen, press: cmd + option + F It also has a bunch of options for 1/2 ...


This doesn't let you switch straight to a target app, but ctrl + cursor keys will let you move left and right through your spaces to reach the full screen app. The shortcut can be changed in system preferences -> Keyboard -> Shortcuts -> Mission Control.


Shift-CMD-F is for presentation mode and will hide the tabs. You want full screen mode instead, so use Control-CMD-F. Tabs will show in full screen mode.


This is a quite old question, but I stumbled on it looking for the same thing (although on ML). The script looks interesting, but it's a bit far-fetched for me, I was looking for something simpler and preferably without add-ons. This is what I found and works for me: in the hot corner's pref pane, hold Command, Option, Control and/or Shift after clicking a ...


Open Google Chrome on your Mac Move cursor to top of screen where OS Toolbar is located and click VIEW In the drop-down menu that appears, click "Always show toolbar in full screen"


I've been annoyed by this, too, and the simple, yet very, very painful answer is to hold alt ⌥option and press the green title bar button (which should turn into a + when you hold option/alt) If this doesn't make it cover the screen, you can finish the job by holding alt ⌥option and double-clicking a corner to resize the window to fill the screen. ...


macOS Sierra introduced 'reduce motion' which I find makes things much more pleasant ;) System Preferences > Accessibility > Display There, find and check the box labeled Reduce Motion


As you know, per your question, the preferences in the Preview app only apply to documents when first opened. It seems that OS X has a built in default view for full screen documents. I tried a couple things... I opened a PDF to Full Screen and set the view to Continuous to see if this would stick and that view would be chosen next time I went full screen. ...


View → Enter Full Screen (⌃⌘F), then View → Always show toolbar in full screen (⇧⌘F).


In Safari 10.0.1 on macOS Sierra it is quite simple - you have to uncheck View > Always Show Toolbar in Full Screen to hide the toolbar.


You can go to System Preferences -> Dock uncheck "Double-click a window's title bar to minimize" and then, when you double click on the title bar in a window, it will maximize the window without going into full screen mode. I find it easier than having to hold down the option key and clicking on the green button.


It's true there's no way to alter the default within OS X itself. Plenty of experts have tried, there have been detailed discussions at Stack Exchange and other sites, but there's no command you can run to turn full screen mode off, or change the default behavior. Fortunately there are 2 ways to get around this… Hold down the Option (Alt) key on your ...


You can use Mission Control (formerly known as Exposé) to move full screen apps across monitors. Mission Control initially shows lists of workspaces across the top of all monitors, and when you move the mouse cursor up into that area they change into thumbnails. If you drag one of the thumbnails from one monitor to another, the workspace corresponding to ...


There is a method: <meta name="viewport" content="minimal-ui”> (but it only works on iOS 7.1 - not on 7.0 nor 8.0) source: StackOverflow More details, from iOS 7.1 beta 2 change log and release notes: Safari Notes A property, minimal-ui, has been added for the viewport meta tag key that allows minimizing the top and bottom bars on the ...


Hold option and left click the green button to have it maximize but not go to full screen.


It appears that the trick is to move the cursor to the bottom of screen like I normally would, but KEEP MY FINGER ON THE TRACKPAD when I get there. If you take your finger off of the trackpad, the dock won't appear, but if you keep it there then it will. (There are other reports that moving the cursor to the bottom of the screen and then repeating the same ...


As implemented on iOS 9 and later, OS X 10.11 lets you split the unified full-screen view into two portrait sections with one application on the left side of the partition and a different one on the right. It's pretty basic, but it also is elegantly minimal with a clear geometry with only one degree of freedom. My hope is that as more people get used to ...


Make sure you have "Allow Exposé, Dashboard and others to use the screen" in keynote preferences under Slideshow. Then, before you slide over to Safari, press the "F" key to pause the slideshow. This prevents the slideshow from disappearing. You can then slide over, or use Mission Control, etc without affecting the slideshow. There is a bug here, to go ...


Here it is: /usr/bin/osascript -e 'tell application "Safari"' -e "activate" -e 'tell application "System Events"' -e 'keystroke "f" using {control down, command down}' -e "end tell" -e "end tell" Here it is in a clearer form (but you can't run it this way): /usr/bin/osascript -e "tell application \"Safari\"" -e "activate" -e "tell application \"System ...


I have this same problem with YouTube, Netflix, mPlayerX and VLC, where the Dock stays visible (on-top) after making the video go full screen. This problem can be fixed by going into System Preferences...Mission Control and turning off the option "Displays have separate spaces." You have to logout after making this change.


I tried searching for hidden preference keys from the output of mdfind kMDItemContentType=public.unix-executable -onlyin /System|xargs strings 2>/dev/null|grep -E '^[a-zA-Z0-9.-]{10,80}$'|awk '!a[$0]++', but I couldn't find anything. You can assign a shortcut for the Zoom menu item from System Preferences:


In addition to what others have said (using the ALT/OPTION + CLICK green maximize button), to designate a Desktop Space for one app, you can do a: 3 (or 4) Finger Swipe Up to bring up the spaces menu at the top of the screen. Bring your mouse over the top right and the (+) icon should expand and let you add a new space. Drag that space in whichever order ...


Open Terminal and type: killall Dock This will restart the process.

Only top voted, non community-wiki answers of a minimum length are eligible