Hot answers tagged

113

(This irritating bug seems to be biting me more often after updating to 10.10.4) When this happens and I don't want to have to reboot, I only restart the "Dock" process and the problem is gone. There's probably some GUI way to do it, but I just drop into Terminal and do: killall Dock But before that, run killall -s Dock to see what would be killed, to ...


18

The GUI way: Open Activity Monitor. In the search field, type in 'Dock'. Select Dock in the results. Click on the black X directly above on the left. When asked if you are sure you want to quit the process, choose Quit. The Dock process will quit and restart. All your gestures/shortcuts will now work again.


13

Here's a quick list of animation-related tweaks for macOS Sierra. Don’t animate opening applications from the Dock defaults write com.apple.dock launchanim -bool false Speed up Mission Control animations defaults write com.apple.dock expose-animation-duration -float 0.1 Remove the auto-hiding Dock delay defaults write com.apple.dock autohide-delay -...


10

Aidan Marr is correct. BetterTouchTool can be used to get the old behaviour. First, disable three finger swipe up in System Preferences > Trackpad. Then, use BetterTouchTool as follows: Select the "Trackpads" tab at top and "Select Application:" "Global" at left. Click "Add New Gesture" Select "Three finger swipe up" as your gesture and "Mission Control" ...


9

I found that the file responsible ist com.apple.dock.plist which sits in ~/Library/Preferences. In this file exists an entry to enable/disable mission control. For me this procedure helped to get mission control working again: Start terminal and execute the following commands: defaults write com.apple.dock mcx-expose-disabled -bool FALSE (this enables ...


8

To disable the shortcut for switching to spaces go to the keyboard shortcuts tab of the keyboard preferences pane. Select Mission Control on the left and then un-check the 'Move left/right a space' options.


5

Thankfully, this feature isn't completely gone. It has just, for some reason, been whisked away into the depths of less-than-obvious multi-touch gestures in OS X Lion and newer. You now have to double-tap an app icon on the Dock with two fingers to activate Dock Exposé. I'm not sure if this gesture ever existed on OS X Snow Leopard.


5

It seems like OS X automatically re-assigns ⌥→ and ⌥← to jump one word forward/backward, as soon as you disable the 'switching space' shortcuts in the Mission Control. System Preferences → Keyboard → Shortcuts and uncheck the Mission Control shortcuts


5

Have you tried restarting SystemUIServer? (killall SystemUIServer) When something like his is happening and restarting the Dock doesn't help, SystemUIServer is the next one to try.


5

Unfortunately I'm not aware of anything that can do what you're looking for. Mission Control is fairly limited in the ways in which you can customize it, either through the user interface or for developers. Similarly, OS X is pretty constrained in how you can configure multiple monitors (sadly, it's actually regressed a bit in this regard since 10.6). You ...


4

You can execute "Mission Control" with specific arguments to trigger the behavior that you desire: Mission Control: /Applications/Mission\ Control.app/Contents/MacOS/Mission\ Control Show Desktop: /Applications/Mission\ Control.app/Contents/MacOS/Mission\ Control 1 Application Windows: /Applications/Mission\ Control.app/Contents/MacOS/Mission\ Control ...


4

You shouldn't take a tag description on a web site not affiliated with Apple as a feature description. See http://support.apple.com/en-us/HT204100 for how Apple defines Mission Control (emphasis mine): Mission Control is the quick way to see everything that's currently open on your Mac. To use Mission Control, do one of the following: Swipe up ...


3

Restart Dock, of which Mission Control is a child process. In terminal, run: killall Dock


3

I get the same symptoms/failure. The following Terminal command fixes it for me: killall Dock But before you do that, run killall -s Dock to make sure it's only going to directly kill the one "Dock" process. Dock will restart and then mission control is working again - for me anyway. You can verify that the restart happened by looking at the process ID of ...


2

It happened again, and I tried simply closing the MacBook, waiting a couple of seconds, and reopening. Maybe it was a fluke, but it worked. I'll wait and see if it fixes the problem a second time to make sure that it really did something. This answer is less than ideal, e.g., if I'm in the middle of a big download, so I'd like to wait and see if this answer ...


2

FunctionFlip allows you to change the function keys individually.


2

If you assign an application to 'All Desktops', then it will follow you around as you switch desktops, and no matter which desktop you're in when you click the dock icon or select it with CMD-TAB, the application will come to the forefront on the desktop you're at.


2

You could also change it to a normal F-key with FunctionFlip. If anyone else is looking for a way to change it with KeyRemap4MacBook, just create a private.xml like this: <?xml version="1.0"?> <root> <item> <name>test</name> <identifier>test</identifier> <autogen>--KeyToKey-- KeyCode::EXPOSE_ALL, KeyCode::F19&...


2

Found a way to (sort of) do it: https://apple.stackexchange.com/a/76103/38367 The following command will enable the mouse scroll-up on an app icon to open exposé: defaults write com.apple.Dock scroll-to-open -bool true killall Dock More info on: http://osxdaily.com/2011/11/30/enable-hidden-stack-gestures-mac-os-x-lion/


2

^ + ↓ will show all the windows of the current app regardless of their desktop (without overlapping) And if you want to show all the windows(can be of diff apps) of your current desktop without overlapping then uncheck the Group windows by applicaiton check box and your mission control will not overlap the windows P.S. I have 10.9.4 installed.


2

I myself was looking for the answer to this this afternoon, but unfortunately it wasn't answered here, so I tried to figure it out myself with some experimentation, and this answer is what I came up with. FYI, I was doing this with OS 10.9 with somewhere between 2-9 windows open. The application windows, in what I'll call "view mode", are presented, more ...


2

I had this issue as well when I updated to OS X El Capitan (Version 10.11.4). Found out my dashboard got switched to "Off." What worked for me is to: go to System preferences open Mission control make sure "Dashboard:" dropdown is set to "As Overlay".


2

UPDATE: the solution below, sadly, no longer works after update to Xcode 8, because Apple shut down plugins support :( If anyone knows a working solution for Xcode 8 and above, please, write a comment below this answer to notify me, I'll be very grateful! It can be done using the ProjectWindowName Xcode plugin. You can install it via Alcatraz. Alcatraz is ...


2

It's a while since I used Mavericks but on OS X 10.11.5 El Capitan in the system preferences for Mission Control there's a Hot Corners button in the bottom left corner. Opening this I was able to assign the bottom left hot corner to 'Mission Control'. This is about as close to what I recall Expose doing as I can get. The resulting Mission Control view ...


2

Apple doesn’t design finder and expose to do this. It’s a design decision, so they might add a switch if enough people convince them it’s worth coding, but in the mean time, programmers have utilities to help. Front and Center app on the Mac App Store Here’s a very in-depth write up of how this used to be the default and now is not, if you’re into the ...


1

You can perform the following steps: Go to System Preferences Go to Trackpad Go to More Gestures Check App Exposé Done!


1

I didn't find any hidden preferences for it with gdb, but there is a preference that makes scrolling up show all windows: defaults write com.apple.Dock scroll-to-open -bool true killall Dock


1

There's actually a way to do with a third party app. There's an app called Afloat. Install it, restart your computer and when you return, the Window menu will contain the Afloat options. Afloat is mainly for keeping an app on top at all times, but it has an option in the Adjust Effects menu that allows you to Keep this window on the screen on all Spaces. ...


1

Take a look at KeyRemap4MacBook, it should do what you're looking for.


1

This would make scrolling up (or dragging up with two fingers) over an icon show app Exposé: defaults write com.apple.dock scroll-to-open -bool true osascript -e 'quit app "Dock"'


Only top voted, non community-wiki answers of a minimum length are eligible