New answers tagged

0

Delete the app associated with the bluetooth device. This may remove the device from your iOS bluetooth devices list.


0

Open the Terminal app (Applications -> Utilities -> Terminal), paste the following code, press Enter and type your admin password when prompted. sudo defaults write /Library/Preferences/com.apple.airport.bt.plist bluetoothCoexMgmt Hybrid Then reboot. This worked for me on macOS Catalina 10.15.1 Credit 1, 2


0

Since you have tried already trashing Bluetooth .plist file, you can try to follow three basic steps to release some kernel panic of the macOS which might fix your issue as the keyboard is working on other devices. Reset NVRAM or PRAM on your Mac Shut down your Mac, then turn it on and immediately press and hold these four keys together: Option, Command, ...


1

You should be able to set a device-spesific key change using Karabiner. If you can't easily set that, you can make a (custom) rule by finding a custom rule on karabiner's website, and then modifying it.


3

I'm on Catalina and it is now 2019. I was having Apple Music open every time I connected my bluetooth earbuds (Echo Buds). Since I never use Apple Music this worked for me: In Apple Music go to "Preferences..." and "Restrictions" Click all the checkboxes under "Disable" including one for "Apple Music" Click the lock to prevent further changes Click "OK" As ...


1

My endless research on this problem makes me think there's a hardware design issue in these 2018 MBPs. Or at least a firmware bug. Some people report switching from the left to the right USB-c ports fix it, others resort to a new Bluetooth adapter/dongle. Still others say moving items on their table/desktop (physical) was the solution. I also read from ...


0

Continuity and iCloud are the obvious paring agents, so I would disable handoff first on both devices and see if that quells things. If so, you might need to engage Apple Support to see if there’s a precise way to rejigger that, but for most people you would need to sign out of iCloud on one or both Macs to then sign in again and see if the pairing identity ...


0

Like one other person I read about, this same Bluetooth issue for me was caused by a new Displayport cable from my second monitor (I'm running two external monitors) to my Macbook Pro 2015 Mojave 10.14.6 (the other person said it was an HDMI cable from their second monitor). Resetting PRAM worked once. As did deleting .plist files, but the issue would ...


1

As you have already deleted .plist file , you can try the following option. Reset NVRAM Shut down your Mac device. Press the Power Button. Before the grey screen appears, press the Command, Option, P, and R keys all at the same time. Continues pressing the keys Mac restarts and a startup sound can be heard for the second time. Finally, release the Four (...


1

You could install blueutil and SleepWatcher via homebrew and set a .sleep code to do "/usr/local/bin/blueutil -p 0" in order to disable bluetooth when going to sleep mode. I had the same issue and this did the trick ! To use SleepWatcher: make a shell script in your home directory named .sleep and give it permission with the command chmod +x ~/.sleep. You ...


2

I was testing the theory today with a codec name error. Indeed, aptX remained 100 %. Very similar to Bug with the name. I hope they correct in the future. Checked in Bluetooth Explorer. Ran using the check box in the SBC codec menu and aptX to check bitrate in one case or another. It turned out when put in priority aptX the bitrate was exclusively ...


0

I tried a whole bunch of additional things that are related to sound rather than bluetooth. The issue is now resolved. I don't know which of the steps fixed it but if you have the same issue, doing all of them will likely resolve it: 1. Reload coreaudiod Enter the following into Terminal: sudo killall coreaudiod sudo launchctl unload /System/Library/...


Top 50 recent answers are included