7

After trying 15 times in vain, here is the method that worked for me (source) Go to "Add Bluetooth or other device" Find the wireless keyboard and double click on it. When prompted for a pin, enter anything on the screen, I used "123123". I dont know what else will work. NOW IS THE IMPORTANT PART. HIT 'Connect' on your screen and IMMEDIATELY enter '123123' ...


6

This problem frustrates me to no end. Recently I noticed that when I start a Vagrant/VirtualBox VM (vagrant up), and it prompts me for administrator access (one time I remember it asked for access to the microphone, and I was a bit confused), the audio drops to the low bitrate connection. I always have my mic set to an external USB mic, and speakers set to ...


5

In Windows 10's bluetooth settings (can be found in system tray), click on the icon and then click "Add Bluetooth Device". Then, on the Apple Wireless Keyboard, turm it on and hold down Command + W, while Windows is searching for bluetooth devices. Then after it finds your Keyboard, it will want to pair with it. Follow the on screen prompts and eventually ...


4

This open-source CLI app BluetoothConnector seems like a good solution. I tested and confirmed it's working as recently as macOS 10.14.4. It's available on GitHub as well as Homebrew: $ brew install bluetoothconnector $ BluetoothConnector --connect 00-11-22-33-44-55 --notify $ BluetoothConnector --disconnect 00-11-22-33-44-55


4

I know this thread is old but this worked for me... currently typing on my (1st-gen) Apple Wireless Keyboard, Lenovo X1 Tablet (3rd-gen - "Clamshell" mode), Windows 10 Pro 1809: 1 - I'm sure you can use Bluetooth in the Settings app, but I used Control Panel. I searched for "bluetooth" and clicked "Add a Bluetooth device" under "Devices and Printers." 2 - ...


4

Well, I had the same problems on My Macbook Pro 2018 with randomly disconnecting magic touchpad and keyboard. I found resolution here: https://www.reddit.com/r/macbookpro/comments/9brybd/issues_with_disconnecting_mouse/ So the problem is with usb type-c concentrator: if it is connected to the left side ports - it causes random disconnects of bluetooth ...


4

Nimesh’s answer is very clever and requires no extra tools, so that may be what you want. However, there is a much easier way, if you are willing to spend a few minutes to download and install some apps/tools once in order to have a simpler way to turn Bluetooth off/on in the future. First, download and install blueutil from http://www.frederikseiffert.de/...


4

After all, I found the solution here. I disable the Bluetooth Collaboration option and I change the Antena Diversity property to AUX. Instructutions: From Device Mananager (Windox key + X) Select Network Adapters Double click your adapter (mine is Broadcom 802.11ac Network Adapter) Click Advanced tab For the property Bluetooth Collaboration select value ...


4

Had the same problem, this worked for me: You can rename the LocalHostName separately from the Computer Name, which should give you the desired result, and shouldn't mess with any network settings. Under System Preferences -> Sharing, click the Edit button to the lower right of the Computer Name field. Here you can enter a different local hostname, and ...


4

Sounds like you have accidentally activated Mouse Keys. Turn it off https://support.apple.com/kb/PH18381


4

In general, WiFi uses the same antenna for both transmitting and receiving. In general, multiple WiFi antennas are used to get higher capacity (i.e. higher bandwidth). For example a common setup is 3x3 MIMO (multiple-input and multiple-output) where 3 antennas are used to exploit multipath propagation in order to increase the bandwidth available. In very ...


3

I just created a little menu bar app that forces the default input to be the built-in microphone of the mac if exists, if not you can choose your desired default input source. No more sound quality drops and it also increases the battery life. It is free and open source: http://www.milgra.com/airpods-sound-quality-fixer.html


3

It’s not as seamless as switching from an iOS device to an Apple Watch. AirPods have to be manually switched from iOS to Mac. You can do this from the Bluetooth menu on the Mac. I also develop an app called ToothFairy that makes this easier. It lets you quickly switch your Mac to the AirPods by clicking an icon in the menu bar or by pressing a hotkey. It ...


3

Any of these three apps turn your Mac into a Bluetooth keyboard, and should accomplish what you need: Typeeto Type2Phone Mocha Keyboard


3

I will add the answer. Looking through discussions.apple.com, as usual, yields bad advice: reset, reformat, disk cleanup. Essentially do a bunch of random nonsense until the problem sorts itself out. Before you do anything overly-complex or even irreversible. I recommend you try what I call the monkey's gambit: Unpair Forget Device Pair Repeat steps 1, 2,...


3

The issue was with the version of Bluetooth. The built-in version (2.0, I believe) wouldn't configure with the keyboard. I've since bought a Bluetooth 4.0 Dongle (cost about £12) and I can now use the keyboard. It's a bit of a faff, had to download a Bluetooth developer tool from Apple and I now have to manually switch from the internal Bluetooth to the ...


3

You can send one or more audio inputs to one or more outputs by creating a new aggregate device in the Audio Midi Setup app in your Utilities folder. This Apple Support document explains the steps. Other options include Soundflower, the open source virtual audio output device which was maintained by Rogue Amoeba for a while, or Loopback, which is Rogue ...


3

I tried a PRAM Reset and it seemed to work for me. Other things you can try are Check your system log tail -f /private/var/log/system.log If you see something like the following in your log, then likely the PRAM reset will help com.apple.xpc.launchd[1] (com.apple.preference.sound.remoteservice[4642]): Service exited due to SIGKILL | sent by com.apple....


3

Try resetting the Bluetooth module. Shift-Option click the BT menu bar item > Debug > Reset the Bluetooth module.


2

I had this same problem and I tried adding the paper shim without success. What is working for me right now is leaving the cover off completely. So far so good but it is only day one.


2

This article by Michael Kummer reports a fairly exhaustive list of failed attempts to fix bluetooth problems on mac, and finally suggests a compromised solution by disabling handsoff that seems working: https://michaelkummer.com/technology/mac-bluetooth-issues-affect-keyboard-trackpad/ Also seen in https://www.forbes.com/sites/bradmoon/2017/07/13/this-trick-...


2

Unfortunately the 2.4 GHz band, which Bluetooth uses, is rather crowded. Therefore interference with WiFi (802.11b/g/n/ax), microwaves, USB 3 devices, etc. are quite common. Apple has a support document on the issue and suggests a list of measures (see the link for all suggestions): How to reduce wireless interference These general steps can help ...


2

I finally figured out the solution. Some bluetooth modules in the 2015 Macs have actual hardware problems. To confirm this, I ordered a replacement 2015 bluetooth module for my MBP 2015 from iFixit. My Mac kept crashing upon waking up from sleep delivering the same kernel panic message the OP had regardless of whether i put in the original 22015 BT module - ...


2

This works for me. I have an iMac (late 2013) and an iPad Air 2. I have set up my Magic Keyboard to be recognized by both devices. You can force pair a 2nd connection by holding down the power button on the Keyboard (maybe you are missing this step). You don't want either device to "forget" the keyboard. Once you've done that, you can then disconnect the ...


2

As stated on a different answer, and I am not quite sure why it was downvoted, the first thing to look for is "bluetooth and 2.4 GHz interference". Make a simple test to switch to a 5GHz Wifi network, and try your Sony Bluetooth speaker once again.


2

As there are some upvotes and many views, I will answer my own question there: Yes, it is possible to write some small application in Swift or ObjC which does this. And some people did that already: BluetoothConnector blueutil BluetoothConnector is written in Swift, which does (currently) only support connecting and disconnecting (It seems to be pretty ...


2

If the batteries run out in my wireless mouse it never reconnects automatically and I have resorted to reconnecting a wired mouse to click on the bluetooth icon in the menu bar. Then I found that you can activate the bluetooth icon by pressing Control-F8 (the "Move focus to status menus" in the keyboard shortcuts) and using the cursor keys and the enter key ...


2

You can do this by disabling the Bezel UI, here are instructions on how to do so from an answer from another question related to that: To turn off bezels for this user until next login: launchctl unload -F /System/Library/LaunchAgents/com.apple.BezelUI.plist To undo, change unload to load, or just log out and back in. For macOS 10.12 Sierra: ...


2

If you use Siri, you can simply ask it to turn Bluetooth on and off. Just press and hold Command + Space keys to invoke Siri. Now speak Turn Off Bluetooth or Turn Bluetooth Off. Wait for desired time, invoke Siri again and speak Turn On Bluetooth or Turn Bluetooth On to enable it again. There's a second, but a bit clumsy approach you can take, if you don't ...


2

There is no setting exposed directly to the user to make that change in the Bluetooth menu behavior, i.e. e.g., in System Preferences > Bluetooth > [] Show Bluetooth menu in menu bar, it only determines whether or not it's shown on the menu bar, not which menu is displayed by default or with modifier key(s) pressed upon being clicked. That is hard coded into ...


Only top voted, non community-wiki answers of a minimum length are eligible