New answers tagged

1

TL;DR I turned the offending line into a comment by adding a ˋ#ˋ in the first column and restarted Apache. To fix this, I followed the Youtube tutorial and opened up the file "httpd-autoindex.conf" using Finder and navigated down to line 21 which has the error. It reads Alias /icons/ "/usr/share/httpd/icons/". Then I found this tutorial by just searching ...


2

By following the tutorial, you have created the file /etc/apache2/users/username.conf which contains the following: <Directory "/Users/username/Sites/"> AllowOverride All Options Indexes MultiViews FollowSymLinks Require host localhost </Directory> (note that you've replaced "username" with your actual username) If you want to allow the public ...


0

You can compile your own httpd version and make a new LaunchDeamon and point Server App to your httpd in the httpd_server_app.conf: ServerRoot "/usr/local/your-httpd" Disable the com.apple LaunchDeamon as shown above: $ sudo launchctl unload -w /Applications/Server.app/Contents/ServerRoot/System/Library/LaunchDaemons/com.apple.server.httpd.plist Then ...


Top 50 recent answers are included