Hot answers tagged

8

Try System Preferences > Profiles. It listed my 802.1X profiles and I was able to remove them from there. Alternatively, you can manually edit configuration files in /Library/Preferences/SystemConfiguration (see this post) - grep the files located there for the name of your profile. (Using OS X Mavericks) (Profiles is located in the second row from ...


5

With EAP-TLS, manipulating certificates, identity preferences and a single password entry all in keychain access can be done from the command line. Something like: security import ${PK12} -A -x -k login.keychain -P ${PW} security set-identity-preference -c ${CN} -Z ${FINGERPRINT} -s com.apple.network.eap.user.identity.default security set-identity-...


4

I had the same problem with my rMBP 15" late 2013. Like Exact same problem. Apple is terrible at quality and consistency control in making drivers. Intall this older kext(wifi driver) and it will fix your problem. I can connect to N only networks on 2.4 and 5 ghz and get 300 mbps transmit rates now. Here is what I did to get the WIFI working as described ...


4

Operating at 5GHz means that (in the margin - there are other factors) 802.11ac will penetrate walls, ceilings, floors less well than 802.11n at 2.4GHz. The AirPort Utility allows you to setup a separate Network Name for the 5GHz frequency (Wireless Tab / Click Wireless Options). This means that you can explicitly select whether to connect a device via n/2....


3

Go with: 802.11g/n That setting covers the first generation iPad through to the latest iPad that got announced yesterday as well as the first generation iPhone through to the latest iPhone 4S. Your devices should pick the faster protocol (N) if they support it. If not, they'll use the slower protocol (G). But between G and N you've got just about all ...


3

I agree with Gordon. The 802.1X security measures are in place for a reason. You should contact your IT team to see if they have other options for you or if they can set up a guest network. In the absence of that, I would recommend getting a MiFi from your carrier or turning your smartphone into a wireless hotspot. If you have access to LTE, it may be faster ...


2

This thread on discussions.apple.com presents an approach that involves twiddling the firewall and NAT rules in the terminal. I haven't tested that.


2

Pretty much any new iOS based device, including the Apple TV etc, will happily use Wireless "n" (150Mb or even 300Mb). Practically nothing that you own will still use "b" (11Mb) - the only devices I have are Nintendo DS, and an ancient Palm organiser. Almost everything else you might have that isn't particular new, or isn't Apple kit, will support "g" (...


2

As of 10.13.6 macOS doesn't support 802.11 v, k or r but interoperates with APs that have it enabled. https://support.apple.com/en-us/HT206207 https://framebyframewifi.net/2017/08/20/macos-wi-fi-roaming/ EDIT: No change (e.g. no support) in 10.14 Mojave.


1

I found the answer for anyone who is interested. According to this thread, no support for 802.11r/k for Os X up to 10.9: https://supportforums.cisco.com/discussion/12314591/8021r-and-fast-roaming


1

Usually on school campus you'll have wifi too, and also 802.1X protection is there for a reason. The only way to share internet from a 802.1X protected network , I think, is by creating a VPN connection on the mac (this will only work if your school's network allows it which i doubt). To do this go to your nettwork settings, unlock it (padlock) and click ...


1

First on the Mac do a network configuration (a location in Apple wording) appropriate for your need. Never use the too infamous and too magic "Automatic" location. A configuration with a "Wi-Fi" and "Bluetooth PAN" interfaces and nothing else. Configure them (I guess you are familiar with this aspect to start playing with a VPN and the problems of security ...


1

There is an app, WiFi Explorer, which shows all the networks your computer can see. It also shows the relative strengths and channel number of them. You could use this to determine that the problem is indeed 5 GHz. Maybe changing Airport channel will help. The app is not free and is available from the App Store.


1

The short answer is "Yes." You can enter your credentials within Terminal. You have to use the networksetup command That's if you can get to terminal... If you can, then the following will help get you connect. But, if you can't, scroll down the bottom for an alternate... However, you have to have a create an 802.1x profile for which to connect to your ...


1

Found a solution by removing the WiFi profile from the Wired config file. Location: /Library/Preferences/SystemConfiguration/ For me the file was: com.apple.network.eapolclient.configuration Basically it's an XML file that has, for me, the two profiles for the wired connection (this would also work if you're trying to edit the wifi, as that's in the com....


1

This button is tied to the eapolclient. When it's connected, you can disconnect it by killing the eapolclient process: $ ps ax | grep eapol 83601 ?? Ss 0:00.05 /System/Library/SystemConfiguration/EAPOLController.bundle/Contents/Resources/eapolclient -i en0 $ sudo kill 83601 When I do this the GUI button switches to show it's disconnected. The bad ...


1

In the end I did resolve the problem by approaching the same solution as the guy did. Which was going to the website of the manufacturer and download the most recent driver and now it's resolved.


1

If you open the dropdown, you can choose edit, there you can create a new location. In the new location, all settings should be on default, so your 802.1X setting shouldn't be there anymore.


1

You should be able to do all the configuration by group. Add all the users into an OD group and then set all the WiFi preferences there. You should also be able to set a certificate for the group and allow the entire group to authenticate against the Radius server. When it comes to setting up PKI then you enter into the dark realms of Kerberos. (Be very ...


1

You do all the work in the "Network" System Preference if memory serves. I don't have a 10.6 box handy to check but under 10.8 and 10.9 you first add the correct certificate to your keychain then when you select any of the "Enterprise" security options and EAP-TLS as the mode you can tell it to use the correct certificate and the username. I remember ...


1

The 802.1X configuration is protected with Keychain. To remove it, select a network configuration which isn't using your 802.1X setting. Then open Keychain Access (within Applications/Utilities). Unlock it. Select the login keychains, and search for labsenteret_peap which should be of kind 802.1X Password. Select it, remove it. Quit Keychain Access. ...


1

I had the same issue and followed the advice to grep eduroam in /Library/Preferences/SystemConfiguration. The file I had to modify was com.apple.network.eapolclient.configuration.plist. In this file you can actually see, the migrated profiles.


Only top voted, non community-wiki answers of a minimum length are eligible