This is some problem with spotlight indexing server.

Disabling Spotlight in Snow Leopard solves this. Launch the Terminal and type the following command:

`sudo mdutil -a -i off`

<sup>Via [OS X Daily](http://osxdaily.com/2009/09/20/disable-spotlight-in-mac-os-x-10-6-snow-leopard/)</sup>