Skip to main content

Questions tagged [rails]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers
507 views

Why can't I execute "bundle exec rake secret"? The error “bad interpreter: No such file or directory” occured

My ruby ​​version is 2.7.3, my mysql version is 8.0.23, my mysql2 version is 0.5.3, my rails version is 5.0.7.2, and my Xcode version is 12.5. I use macOS Big Sur(version 11.4) and the text editor &...
Marchan4's user avatar
1 vote
1 answer
92 views

rails error on macos mojave 10.14.5: config/load_config.rb:5:in `require': cannot load such file -- configurate (LoadError)

Im trying to install ruby and rails on macos using rbenv. On running rails new myapp and rails -v it gives error: 5: from bin/rails:8:in `<main>' 4: from bin/rails:8:in `require_relative' 3: ...
jagtar's user avatar
  • 11
2 votes
2 answers
386 views

High Sierra user trying to set up a new user for Rails, without interfacing w/ previous users

I'm getting this error when I'm trying to use Rails. It seems there are problems with using local files. pasting below to show the versions of ruby and rails ~ $ ruby -v ruby 2.4.2p198 (2017-09-14 ...
Ari Kalmen's user avatar
-1 votes
1 answer
31 views

What is my issue when trying to install rails?

I have all the pac managers and etc that i can get from any book or online resources anywhere, ive tried many methods and just about everything i can find online. Can someone who knows exactly what ...
Malik's user avatar
  • 1
0 votes
1 answer
1k views

Rails reporting error: Failed to build gem native extension

I have installed up-to-date command line tools, and followed steps on other threads with this subject. I know this seems like a duplicate, but I don't see any answers to my issue here: Jacobs-MacBook-...
rbApostate's user avatar
1 vote
0 answers
286 views

Mavericks server configuration for Rails app

I have just downloaded OS X Server for Mavericks and now I want to run my Rails app through the server. I have downloaded and installed Passenger. My server runs under username.no-ip.biz and my Rails ...
vice_versa's user avatar
1 vote
0 answers
137 views

Rails Command Fails Because of Space in Path

I tried setting up a Ruby on Rails project on my nice safe volume called "Data RAID". The set up failed with some strange errors that I eventually tracked down to the space in the path name. It works ...
curt's user avatar
  • 149
4 votes
2 answers
8k views

Uninstalled zsh, terminal gone weird

I uninstalled zsh pretty soon after I installed it as I realised I had got used to the normal Terminal. The uninstall went successfully and I restarted Terminal, but now it displays my computer-name (...
Tom Oakley's user avatar
3 votes
1 answer
1k views

Ruby 1.9.3's infamous OS X OpenSSL segfault in http.rb:799

[Post shortened and updated with an answer.] Ruby 1.9.3 compiled on OS X 10.7.4 with MacPorts crashes in my Rails apps when using SSL in http.rb, e.g. when authenticating to Facebook: (facebook) ...
Jens's user avatar
  • 227
2 votes
1 answer
240 views

Any known problems with Ruby/Rails in Lion -> Mountain Lion upgrade?

I am currently running OSX Lion on my Mac and I do a lot of Rails development. I am wondering if upgrading my system to OSX Mountain Lion is going to really mess up my Rails/Ruby work. I run Ruby off ...
flyingarmadillo's user avatar
-1 votes
1 answer
377 views

How much faster is the "15-inch 2.6 GHz Retina Display MacBook Pro" when developing Rails Apps? [closed]

I'm specially interested in how faster would it make the processing of Asset Pipelines (Sprockets). I currently have a first generation Unibody MacBook, and it feels really slow...
Boti's user avatar
  • 349
1 vote
3 answers
241 views

How can you install new versions of Ruby, Rails, and Git without running into the old versions?

I've been having this problem for the past several years where I like to stay up-to-date and install the latest versions of software like Ruby, Rails, and Git. However, I somehow always seem to have ...
Bijan's user avatar
  • 569
0 votes
1 answer
785 views

"Could not find RubyGem rails" on 10.7.1 Server

I just cannot get Rails to work on my 10.7.1 Server installation. After having run CC=/usr/bin/gcc-4.2 gem install rails --force as root, I still get this: % rails /System/Library/Frameworks/Ruby....
John Y's user avatar
  • 145
3 votes
1 answer
2k views

Is it possible to bypass a proxy when the proxy settings are set to Auto Proxy Config?

I've set up Automatic Proxy Configuration (PAC) in OSX Snow Leopard to point to a URL. I've also filled out the "Bypass proxy settings for these Hosts & Domains" box because I want to skip the ...
carpeliam's user avatar
  • 133
3 votes
1 answer
4k views

Configuring OS X 10.7 Lion Server to serve Rails Apps via Apache

I have a number of Rails Apps working just great under Snow Leopard, but would like to migrate these to Lion. However, like many others, the rug has been pulled from under my feet by the changes that ...
Snips's user avatar
  • 203