Questions tagged [php]

PHP is a server-side scripting language used to build dynamic web pages.

Filter by
Sorted by
Tagged with
12
votes
2answers
15k views

How to install composer via homebrew

I'm really new to MacOS so maybe this is simple question. I'm using High Sierra with default PHP 7.1 installed, I've also installed PHP 7.2 running: curl -s http://php-osx.liip.ch/install.sh | bash -...
12
votes
7answers
36k views

How can I increase command line memory_limit for PHP with MAMP PRO?

I've edited every single php.ini on my Mac (at least all the ones found by "locate") and still can't seem to increase the memory_limit directive for PHP. I'm using MAMP PRO and running PHP scripts in ...
11
votes
3answers
5k views

Advantages of using MAMP stack over Mac's native Web Sharing and downloaded MySQL

I'm wondering what are the advantages of using a MAMP stack instead of Web Sharing provided with Mac natively and MySQL downloaded and installed manually? I can see how in some cases MAMP can have ...
10
votes
1answer
17k views

How can I determine the compile-time options of PHP?

I'm trying to customize my php install, but I'm not that familiar with compiling programs from scratch. How can I tell determine what compile-time options were used for php? Specifically, I'm trying ...
9
votes
3answers
43k views

How to remove preinstalled Apache and PHP from Mac OS Sierra

I have been trying to figure out how to completely remove preinstalled Apache and PHP from my macbook pro ... The reason is that I am using the homebrew version of both Apache and PHP. The current ...
9
votes
1answer
12k views

Can't write to /usr even with sudo

Here's my problem: sudo php -d detect_unicode=0 go-pear.phar ...should let me run as root and modify /usr & /usr/share directories, but I get this: Below is a suggested file layout for your ...
8
votes
1answer
61k views

PHP version shown in command line differs from phpinfo(); in localhost:8000

I started my OS X PHP test server by typing php -S localhost:8000 I updated my PHP on OS X to 5.6 and when I check the version through the command line by typing: php -v It tells me that I have "...
6
votes
3answers
15k views

PHP not working after upgrading to OS Mojave

When i try to open localhost it gives me 403 error message like this "You don't have permission to access / on this server." I have tried changing the permission but nothing happens. It worked fine ...
6
votes
2answers
50k views

How can I uninstall PHP 5.4 and 5.5?

I'm new to PHP and Apache and I think I've messed some things up that I don't know how to fix. After following a tutorial I managed to update to PHP 5.5, and then started having problems. I went to ...
6
votes
2answers
2k views

Install MAMP (not PRO) For PHP And Mail Sending

I first tried searching here at apple.stack but couldn't find a solution that seemed to work for me, so I'm trying my hand at posting a question. I already spent a few good hours trying to make it ...
5
votes
2answers
15k views

Which php.ini file do I have to edit on Mountain Lion?

I recently upgraded to Mountain Lion and reconfigured my apache2 (https.conf) file in the terminal to load PHP and start automatically. My localhost/~username/phpinfo.php page comes up to show my ...
5
votes
1answer
21k views

Why does my OS X still run older php even though I updated it?

I have just updated my system php in terminal via command line. I deleted the export path in .bash_profile as it was pointing to mamp but for some reason my php still says 5.3 not 5.4 when I run php -...
4
votes
1answer
9k views

How do I enable PHP on Mountain Lion OS X 10.8?

Just upgraded to Mountain Lion, and wanted to make PHP work on the built-in version of Apache.
4
votes
1answer
2k views

Can I delete Xcode?

I'm a php developer, usually with the laravel framework. I want to get rid of Xcode because I'm tired of dedicating 9 gigabytes of storage to an application that I don't use at all. I seem to ...
4
votes
4answers
10k views

Web Sharing Apache Localhost - Access permissions

I want to install phpMyAdmin on the native Apache webserver that is bundled with Mac OS X 10.6. I turned on Web Sharing in System Preferences. Yet, me fear is that my computer is granting access to ...
4
votes
1answer
22k views

How to properly and for once reinstall PHP/Apache

So I'm struggeling with this since a long time and I'd like to find a proper solution. I have php5.4.. install and I want to upgrade to Php 7. No matter how hard I'm trying to do it I can't seems to ...
4
votes
4answers
7k views

phpMyAdmin 403 Forbidden Error after upgrade to Yosemite

I upgraded my Mac to Mac OS X Yosemite. I had a AMP stack installed via Homebrew on Mavericks and it worked fine. After upgrading to Yosemite, I have the following problems: when trying to load ...
4
votes
5answers
5k views

XAMPP VM and text editors

I recently installed XAMPP for OS X (XAMPP VM PHP 7.2.1) which now virtualizes the entire box for obvious benefits of higher security. Although I admire the new concept and see its benefits, I cannot ...
4
votes
1answer
320 views

Is it possible to update the preinstalled versions of both MySQL and PHP in OS X?

I'm running 10.6.4 and PHP reports itself as version 5.3.2 (5.3.3 is available) and mySQL reports version 5.1.45 (5.1.51 is available) I know they are minor releases but is it possible to easily ...
3
votes
1answer
5k views

What permissions do I need to give for my server setup?

I am trying to have a server setup for my web app locally on my MacBook Pro. I have installed Apache, PHP successfully and checked out my web app's code to /var/www location. Now there's a script in ...
3
votes
3answers
6k views

PHP 5.4 Installation on Mountain Lion

I just installed Mountain Lion, and of course I've had to set up Xcode Command Line Tools, reinstall Git, and do other things to get up and running again for programming. Naturally, PHP was pushed ...
3
votes
1answer
7k views

After MacOS High Sierra install, localhost fails and apache has syntax errors

After upgrading to MacOS High Sierra, I haven't been able to access my localhost. I tried restarting Apache, but it still didn't work. So I did apachectl configtest and got this error message: ...
3
votes
1answer
3k views

Uninstall default PHP on El Capitan

My Mac has the default installation of PHP 5.5 at /usr/bin/php and I want to remove it the right way because I want to have PHP 7 instead of this. So far no luck on how to uninstall the right way. I ...
3
votes
2answers
1k views

Upgrading to PHP 5.4 using Mac Port

I tried following the excellent instructions on this gist to upgrade my Mac to PHP 5.4, but before I do, I need to know: Is there an easy way to find out which php extensions do I have installed ...
3
votes
1answer
629 views

Post data to url using AppleScript

I am trying to take user input and send the data to a url on my site to do some checks against my database. In my php script I cant display any of the POST variables. it seems like the data is not ...
3
votes
1answer
370 views

how can i set up mamp or web sharing to show clients php application remotely?

I'm currently using mamp instead of web sharing and I'm trying to figure out the best approach to share php and mysql web application that I'm working on to clients. What is the best way to do this?
2
votes
1answer
209 views

Terminal could not find command “$ php -v”

I recently try to install ionCube loader and when I tried to check my PHP version via Terminal, it gave me an -bash: $: command not found. How can I fixed that?
2
votes
2answers
3k views

How to install memcache on Mavericks? (MAMP)

I have MAMP on my machine, and I would like to install memcache for php, because one of my project throws errors like Fatal error: Class 'Memcache' not found. I installed X-Code from appstore, and ...
2
votes
2answers
1k views

Is it possible to remove all installed terminal applications and extensions back to native without doing a clean OSX install?

Basically I would like to know if it is possible to remove all php, apache, homebrew, mac ports etc. installs back to native without doing a clean install of the OS? If not is the best way to go ...
2
votes
1answer
896 views

How to activate built-in PHP in macOS Server 5?

On our macOS Server 5.2, I want to run a PHP site. So my idea was to use the built-in PHP in OS X Server by simply ticking the checkbox "Enable PHP" in the Server app at the Websites general ...
2
votes
1answer
249 views

How to update internal PHP

How do I update the internal PHP on OS X 10.7.1? I've loaded a current version but since I don't have a simple plan how to update it, I won't do it. I guess it's just easy replacing of files in etc/...
2
votes
3answers
335 views

PHP on OSX 10.10

How do I install/allow php to run on Yosemite? I've read a lot about doing stuff through terminal, but none of the 'tutorials' are thorough, they just tell me to do 'sudo....' I've tried it, and still,...
2
votes
2answers
284 views

Make TextMate run php from a different binary, not the original php

I work with php and postgre, and since the stock php doesn't come with postgre I had to install a different php version. So I installed php5 from this website: http://php-osx.liip.ch It's a quick ...
2
votes
2answers
493 views

Web development on PowerPC

I'm interested in LAMP stack and Nodejs stack for PowerPC (iMac g5). Do they exist for Mac OS X 10.5.6 PPC?
2
votes
1answer
4k views

Setting PHP upload_max_filesize in Mountain Lion

I have edited /etc/php.ini and have inserted the following line of code to set the subject variable: upload_max_filesize = 20M However, within a Joomla website on this host, the PHP Information ...
2
votes
3answers
1k views

How can I run a PHP script by dropping file on icon?

I have a php script that takes a filename as an argument. When I run it from a terminal window I type ./my_script.php file_to_process.txt It works great! What I would like to be able to do is to ...
2
votes
1answer
322 views

How to reinstall php70-xdebug with the debug symbols?

I'd like to reinstall php70-xdebug package with debug symbols like: $ brew reinstall php70-xdebug --with-debug ==> Reinstalling homebrew/php/php70-xdebug Warning: homebrew/php/php70-xdebug: this ...
2
votes
1answer
8k views

Uninstall/ disable php 5.6.9 osx Yosemite

I´m running osx yosemite with homebrew, apache, php5.6.9 and have installed php 5.3. I need php 5.3 to run a certain api which known to have complications with ph5.6.9. But how can I disable php 5.6.9 ...
2
votes
1answer
5k views

Can't access apache-powered website at localhost [duplicate]

I was trying to enable php, mysql, apache on my macbook pro running yosemite. I followed this guide but it doesn't run. What's wrong in setting up a local web server on OS X Please help.....I get an ...
2
votes
1answer
77 views

How can I shut down an unlisted php-fpm?

I have two installations of php on my machine. One came with apache and is a 5.3 version, and I'm trying to use a 5.4 version with nginx. I'd like to work on project using nginx, but I can't figure ...
2
votes
1answer
3k views

How do I install the GnuPG PHP extension?

I'm having trouble installing a PHP native extension: GnuPG. Here's what I've tried so far. First: sudo port install gpgme sudo pecl install gnupg Output from the second command ends like so: ...
2
votes
2answers
4k views

How can I upgrade my PHP 5.3.1 to 5.3.2 on XAMPP Mac OS X?

I've just installed XAMPP on Mac OS X Snow Leopard, and everything is running correctly and setup completely well. However, I want to install an open source project that requires PHP 5.3.2 or higher. ...
2
votes
1answer
38 views

PHP won't include files properly since updating to Mojave

On our office Mac, we have a local Apache server running through the software AMPPS. Prior to updating to Mojave, everything was working correctly. Now, after updating, there is an issue with using ...
2
votes
0answers
50 views

PHP mail not sending (possible macOS Server or Firewall issue?)

This is a relatively complex problem and LONG description, so bear with me. Please ask questions in the comments if you think I can clarify something. I am hosting multiple websites on a single ...
2
votes
0answers
229 views

Installing a different version of Apache and PHP

I have OS X Yosemite, it comes with default Apache 2 and PHP versions. I want to set up a development environment with older version of Apache (2.2) and PHP (5.3). I have a product set up running on ...
2
votes
0answers
2k views

Better PHP syntax coloring for XCode, and support for short_open_tag [closed]

The syntax coloring definition for PHP in Xcode (as of 5.0) is pretty poor: probably some 30% of PHP keywords are missing from the definition and are not highlighted as such PHP blocks in the middle ...
2
votes
1answer
854 views

How to make ffmpeg use correct libfreetype version?

I have a PHP application that uses ffmpeg with libfreetype. I installed both ffmpeg and libfreetype from macports. But I keep getting this error: 2013-08-30 14:44:21 - Generate poster - Create ...
1
vote
1answer
402 views

How is $PATH created?

I am still relatively new to the workings of the Mac OS but have extensive knowledge of Linux. I updated my php on Mavericks using the php_osx and the instructions stated to use export PATH=/usr/...
1
vote
1answer
39k views

Change the user Apache runs as [closed]

Need help to create a new user to apache web server and assign root privileges to newly created user. Or how to login as root user in apache server because following php script showing you are logged ...
1
vote
1answer
7k views

Uninstall PHP on Mac Mountain Lion

I have installed PHP 5.4.40 on my Mac OS Mountain Lion, but need >=5.5.9 (for laravel/lumen-framework v5.1.0 installation), so i run installation with package installer, iMac-Dmitry:Projects dmitry$ ...