Questions tagged [java]

Java is a cross-platform programming language created by Sun Microsystems and is now owned by Oracle. Do not confuse this tag with JavaScript or JScript. Questions about installing/running Java on macOS are welcome, questions about Java programming must be asked on StackOverflow.

Filter by
Sorted by
Tagged with
0
votes
0answers
20 views

Using Jabba (java) in macos

I recently started using jabba and I installed a couple of java versions $ jabba ls adopt@1.13.0-0 openjdk@1.13.0 zulu@1.13.0 and setup $ java --version openjdk 13 2019-09-17 OpenJDK Runtime ...
0
votes
0answers
16 views

I downloaded Java and DocFetcher, but they try to open in Calibre

I downloaded Java and DocFetcher online, but they downloaded as dmg files and when I try to open them, they try to open in Calibre, an e-book software program. What am I doing wrong?
0
votes
1answer
26 views

Unknown Binary in Application Samples

I recently started sampling applications that freeze on my machine. I have an iMac with 8 cores and 32GB of RAM running Catalina 10.15.1 fully patched. It's far from resource constrained yet certain ...
1
vote
2answers
194 views

Java uninstalled but still cannot install java 6 macOS

I'm trying to install Java SE 6 because I need it to use Scilab, I follow this and this tutorials for uninstall java, but still cannot install Java SE 6. When I'm trying to install appears this ...
5
votes
0answers
95 views

How to track screentime of Java apps with Catalina

I am using macOS screen time as a mechanism for parental controls. Before updating to Catalina, the screen time tracked the total time a one user was logged in with his/her credentials, regardless of ...
1
vote
1answer
29 views

When try to I open a .jar I get “The java JAR file could not be opened”

Found this error:Could not find or load main class E Caused by: java.lang.ClassNotFoundException: E I am trying to install Forge so I can load mods for Minecraft.
11
votes
5answers
5k views

Cannot install JDK 13.01 on Catalina

I tried to install the x64 version of jdk (from https://www.oracle.com/technetwork/java/javase/downloads/jdk13-downloads-5672538.html), however, Apple refused to install it saying that the software ...
1
vote
1answer
1k views

Bundling Java applications for Mac OS X Catalina

I write amateur Java scientific applications which I provide freely for a small audience. (Probably I am the main user.) Most of them are still compiled under Java 1.6 where they run fine on Mojave ...
14
votes
3answers
3k views

Can't run OpenJDK macOS Catalina “Can't verify it's not a Virus”

I downloaded OpenJDK 13 from the official website and extracted it to my /Library/Java/JavaVirtualMachines/ folder. If I now try to run it with java -version I get a prompt saying something around the ...
0
votes
0answers
14 views

Eclipse crashes on Install Plugin Archive - OSX High Sierra 10.13.6 - Eclipse Indigo Service Release 2

Eclipse is working normally for creating projects, writing code etc. It is crashing at this plugin update dialog: Help -> Install New Software... -> Add... -> Archive... Application Specific ...
0
votes
0answers
15 views

Is there a way to customise keyboard shortcuts for a Java executable?

Is there a way to customise keyboard shortcuts for a Java executable? I cannot add it in System Preferences > Keyboard > Shortcuts > App Shortcuts as it's an executable and does not end in .app. It's ...
3
votes
1answer
554 views

brew cask install java6 - Cannot install on volume / because it is disabled - MacOS 10.15 beta

I've un/reinstalled brew, turned off macOS Gatekeeper, csrutil is disabled, and a bunch of other things but brew cask install java6 always results in this: > $ brew cask install java6 ...
1
vote
0answers
117 views

Getting the Java jar file could not be launched even though it runs normally from terminal, any help?

I exported my Java project but when i try to double-click on it and open it normally I get that it could not be launched and I should check my console for possible error, found nothing there. Tried ...
0
votes
1answer
53 views

How can I fix poor Java performance caused by Mojave update 10.14.6?

I installed the 10.14.6 macOS update yesterday, and now Java is performing very poorly. This is especially noticeable when using Maven to build Java applications. There are projects I build ...
2
votes
0answers
33 views

Set java version for one specific application

I have multiple Java Versions installed and want to run a packaged application (JabRef) with a specific version at /Library/Java/JavaVirtualMachines/zulu-8.jdk which is not JAVA_HOME. If I would run ...
0
votes
1answer
66 views

Remove or relocate Java icon in Dock

I am using a MacBook Pro running macOS Mojave with the latest version of Java. When i run my Java program, it shows 2 icons in the Dock. Is it possible to remove 1 or relocate both? I cannot use a ...
2
votes
0answers
103 views

Allow Java 1.7 app to run without “Install Legacy Java SE 6” message showing up and JRE not JDK

I am tasked with deploying an old Eclipse RCP (Java 1.6) application with minimal or no changes to the code on macOS Mojave 10.14 64bit. The application hasn't been deployed in a long while, the last ...
4
votes
2answers
9k views

How to run an app that require Java SDK on macOS Catalina 10.15?

Currently I am getting issue with new macOS Catalina limitation. Every time I run an app that require openJDK I get this message: "openjdk-12.0.1.jdk" can’t be opened because it is from an ...
1
vote
1answer
72 views

Running Java / Jython process in the background

I am trying to run a Jython script in the background. This is what the script looks like, a_jython_script.py for i in range(10000): print i When I try to run it in the background, it is ...
2
votes
0answers
37 views

“Please wait while Bamboo sets up your instance” taking for ever on Mac [closed]

I am trying to install and configure Bamboo on mac. I have installed it and now at the stage of running the setup wizard. After giving the license and selecting "Express installation", now am stuck at ...
11
votes
2answers
2k views

What if there is an error message that adoptopenjdk8 exists in multiple taps?

When brew cleanup shows the following error message: Error: Cask adoptopenjdk8 exists in multiple taps: homebrew/cask-versions/adoptopenjdk8 adoptopenjdk/openjdk/adoptopenjdk8 How can I resolve ...
1
vote
1answer
41 views

How to enable mouse control (accessibility?) for Java WebStart application?

We have an demo application that our salesman launches through Java WebStart. It works fine, exception on Macs (running MoJave) for a section that uses AssertJ Swing to drive the mouse and the ...
0
votes
0answers
87 views

Fix Application launcher from Java 1.6 Legacy to Oracle Java 7

I'm using a Mac Pro 64bit Mojave. Is it possible to create a .command or .sh or some other low-effort "launcher" for a Java program where all of the compiled code is in the "plugins" dir that does ...
0
votes
1answer
342 views

On Mac OS X 10.7, Java Control Panel crashes unexpectedly

I'm wondering if this is a serious problem that I should be concerned about. I have the latest version of Java installed (currently Java(TM) SE Runtime Environment (build 1.8.0_212-b10) via command ...
3
votes
3answers
1k views

Enabling “Hardened Runtime” from outside of XCode

This question is prompted by the new Notarization requirements that Apple will enforce for Mac Apps distributed outside of the Mac App Store targeting Mojave (in the near future.) I maintain a suite ...
3
votes
1answer
479 views

Did Oracle remove the Java System Preference in macOS?

I recently updated my Java install on macOS 10.14.4 from Java 10 to Java 11, and the Java System Preference pane disappeared after Java updated. I updated Java again on a different Mac running the ...
3
votes
2answers
442 views

Is it allowed to be an Apple trusted developer with pure Java

I am developing JavaFX with Spring applications that are shipped with native installers for Windows, Linux and macOS. I am hosting the macOS DMG and pkg installers outside Mac App Store on my web site....
1
vote
0answers
38 views

Java update failed

Just realized that java on my mini 2012 is 1.6.0_65-b14-468. Therefore I searched for anything newer compatible with JDownloader. Therefore I downloaded 1.8 (jre-8u201-macosx-x64). Apparently the ...
0
votes
0answers
93 views

Apache Netbeans 10 binaries not working

I have recently downloaded the Apache Netbeans 10 binaries from the Apache Netbeans (Incubating) site. I extracted the zip file to /Application/netbeans/. But when I try to run /Application/netbeans/...
0
votes
1answer
617 views

Using “Jar Launcher” on High Sierra how do I pass command line arguments to a java app (jar)

Is it possible to use "Jar Launcher" on Mac to pass command line arguments to a java app? For example: open myApp.jar --args -hello This ought to run myApp and pass it "-hello" but it doesn't. I'm ...
2
votes
2answers
99 views

I have Java 8. An app wants Java 6 (legacy one). Can I avoid that?

My government made a Java app to submit tax documents. That app, it's actually a very outdated version of Eclipse. When I run this ugly mess, I get a dialog that prompts me to install Java SE 6 (...
2
votes
0answers
69 views

How can a I run a bundled app with Java 11?

I followed the answer to this question to get a bundled app to work with Java 8... How to direct an app to use a specific Java version? I would like to know if I can get it to run with the latest ...
3
votes
2answers
4k views

How can I upgrade from Oracle JDK 8 to OpenJDK 8 using Homebrew and be sure it will be used by default?

If I have Oracle Java SE JDK 8 installed on my mac, how can I upgrade to Open JDK 8 and be sure it will be used by default? Motivation: Android build tools seem to need JDK 8, but according to the ...
4
votes
2answers
3k views

How can I upgrade my mac to OpenJDK 11 using Homebrew?

If I would have an older version of Java JDK on my mac such as Java SE 8 or OpenJDK 8, what would be a quick way to upgrade to OpenJDK 11 using Homebrew (using the brew command)? Motivation for using ...
1
vote
1answer
846 views

Python on High Sierra “No Java runtime present, requesting install”

I have python code that works just fine in multiple other places and "used" to work on my mac, but now when I try to run my code as: python <pythonfile>.py I get an error which says: No Java ...
0
votes
1answer
1k views

Does macOS Mojave comes with java pre-installed?

I just ran which java command and got the output /usr/bin/java I also executed java -version command and also got version information output. So I believe that there is an actual java executable and ...
0
votes
1answer
37 views

Do you see video artefacts on your MacBook Pro when opening the Java control panel?

Calling all MacBook Pro 15" 2018 owners, particularly owners of the 2.6 GHz model. Would you be willing to test something on your 2018 MBP? (15”?). Install the latest Java JRE (https://download.oracle....
7
votes
2answers
4k views

Obtain Java 11 for macOS?

I know in recent years the Java development cadence has changed, becoming much more rapid and more predictably scheduled. New plans were announced for regular Long-Term Support (LTS) releases. And I ...
2
votes
1answer
713 views

How do I remove java version “1.6.0_65”?

Every single time I try to install the Oracle Java Runtime Environment... I keep being stuck with Apple's Java 6. I have no idea how Apple's Java 6 ended up on my computer in the first place. The mac ...
6
votes
2answers
3k views

Can't set different Java version in Mojave with jenv

I want to have different Java versions on my machine. I installed jenv for that reason. However, I can't set the desired Java version to it. Actually couldn't set any version. I have Java 8 and 11 ...
2
votes
1answer
63 views

Is Java UDP communication broken on macOS?

I've been trying to figure out why a Java program that uses UDP communication on Windows works 100% fine but seems to regularly drop packets on a macOS build of the JVM (8.x). I saw another thread on ...
0
votes
1answer
557 views

deleting java from system library on mac

I can't delete java from my mac. I tried deleting it from system/Library, but it says the os mac system needs it. I want to install an older version because a specific website needs it, but it keeps ...
1
vote
1answer
6k views

In macOS, how to run a JNLP file with OpenJDK 8?

Due to the new license of OracleJDK8, I have to use OpenJDK8. I have installed AdoptOpenJDK8 from Homebrew and it works well. The problem is that I have to launch a Java application from a JNLP link, ...
1
vote
1answer
176 views

Is usr/local/bin the correct directory to place JAR files?

I have built an application that includes a JAR file I developed and I've had issues trying to run it correctly from the AppleScript application with: set foobar to POSIX path of (path to me) & "...
1
vote
0answers
64 views

Accessing specific version of Java in Safari

I am using Safari 12 running on macOS Mojave 10.14. The Web based VM detects the installed version of Java on my Mac as 1.5. For my particular needs version 1.6 is required. I have installed the ...
28
votes
3answers
42k views

How can I install java openjdk 8 on High Sierra

How do I install OpenJDK 8 on High Sierra? It looks like support for the Java Oracle JDK version 8 will be deprecated after January 2019 Java SE Overview Additionally, it looks like publishing and ...
1
vote
1answer
7k views

how to get JDK 7 for Mac OS High Sierra

In order to run some tools for a project I'm working on, I need to install specifically JDK 7. I already have JDK 8 up and running. I searched in Oracle and open-jdk web sites but seems to be ...
4
votes
1answer
362 views

Upgrading from OS X El Capitan to macOS High Sierra

I'm in the process of planning an upgrade from OS X El Capitan to macOS High Sierra, and I'm using things like Homebrew, Composer, Elasticsearch, and — by extension — Java. I'm using MAMP Pro with ...
5
votes
1answer
187 views

Is it safe to install a deprecated Java version?

I have an old version of Photoshop that requires an outdated Java runtime. "More info" takes me to this Apple support page where you can download the older JRE. Seems reasonable enough, but I am ...
1
vote
1answer
115 views

Can't update to Java SE 8u181 from 8u171 on El Capitan [duplicate]

as part of my update routine, I wanted to upgrade from the installed Java SE 8u171 to Java SE 8u181. Before anyone asks, yes, one software DOES need Java (LibreOffice). Problem is, the install ...