Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [homebrew]

System for installing command-line Unix applications and tools on OS X. Free and open-source.

0
votes
0answers
29 views

Can't install Inkscape on macOS High Sierra 10.13.6 (17G65) via DMG or Homebrew

I've been trying to install Inkscape 0.92.2 via DMG (Xquartz) and via Homebrew (Cask), having previously installed Xquartz (2.7.11) without issue, on my Macbook Pro 13. Once Inkscape has installed it ...
1
vote
1answer
33 views

Homebrew Vim with Python support depends on Python 3.7.0, and I have to use 3.6.5

I have to use Python 3.6.5 because of a library I use that keeps showing bugs on 3.7.0 (TensorFlow). I installed Python 3.6.5 using Homebrew as follows: brew install https://raw.githubusercontent....
0
votes
0answers
4 views

Questions from trouble getting the UniFi Controller to work on macOS High Sierra + Server (port 8080 in use)

After upgrading from Sierra+Server to High Sierra+Server I am running into the problem that port 8080 is occupied by default. This blocks the UniFi controller from launching. After the upgrade, I ...
0
votes
0answers
10 views

Converting .accdb to sqlite on a mac - open to using terminal or homebrew

How would you convert a Microsoft Access database .accdb to SQLite on a Mac? (High Sierra)
1
vote
1answer
73 views

“brew install python3” fails to compile pyexpat

brew install python3 fails with a pyexpat error, which means the installed Python can't parse XML (breaking pip etc). Here's the relevant excerpt from ~/Library/Logs/Homebrew/python/02.make: *** ...
1
vote
0answers
15 views

How to set PHP alias for all users

This is probably easy, but I don't know how to set it for all users. So, when I run: which php it shows /usr/local/php5-7.2.0-20171215-181251/bin/php However I've just installed PHP using brew on ...
3
votes
1answer
135 views

Installing Xcode command line tools

I performed a fresh install of macOS Mojave 10.14. Immediately after that I installed Xcode Version 10.0 (10A255) from the Mac App Store. Now, I wish to install Homebrew which requires Xcode command ...
0
votes
2answers
54 views

I need Git. Is it better to install command line tools (183mb) or `brew install git`?

I think that it is better to install Git from Homebrew: Less size Install only what I need - I do not need LLVM compiler, for example. Faster install All packages in one place No need to re-install ...
4
votes
2answers
109 views

How to get rid of “application downloaded from the internet” message when installing homebrew casks?

I used homebrew cask to install many applications for quite a while now. But recently macOS keeps asking me to first confirm the "application downloaded from the internet" question that is usually ...
1
vote
1answer
39 views

dnsmasq not working oh Mac OS High Sierra

I have a service running on localhost on MacOS High Sierra. curl foo.test does not work, but curl localhost does. To get to my setup, I installed dns using homebrew, brew install dnsmasq ...
1
vote
0answers
41 views

How to change AD password from MAC OS Sierra

I'm trying to change my Windows AD from my Mac password by doing: diego$ smbpasswd -U username -r DOMAIN_CONTROLLER_IP -bash: smbpasswd: command not found As the command was not found I tried to ...
3
votes
1answer
62 views

How can I stop brew prune and brew upgrade from fighting?

I am running Homebrew on 10.13.6, with the prefix /usr/local. When I run brew upgrade, two directories are created in /usr/local/share. These are: /usr/local/share/man/man2, and /usr/local/share/...
0
votes
3answers
75 views

Running `nano` uses the old nano(2.0.6) even though nano 3.0 is installed

I installed nano 3.0 with brew install nano, but when I run nano --version, it shows version 2.0.6, which is what came with macOS. Screenshot: echo $PATH also shows that /usr/local/bin is listed ...
2
votes
1answer
30 views

Gatekeeper notification doesn't show location of application

I just received a system notification that an application I downloaded with Homebrew was not allowed to launch. This is fine, but the notification gives me no information about where this app resides. ...
2
votes
1answer
82 views

Why is Homebrew finding phantom directories? [duplicate]

I'm running Homebrew on macOS High Sierra 10.13.6. I use a bash alias brewup to periodically check on my installation. brewup is defined as below: alias brewup= 'brew update; brew upgrade; brew ...
1
vote
1answer
24 views

Why do I have a .subversion folder hidden in my home folder on mac OS?

Why do I have a .subversion folder hidden in my home folder on mac OS? I don't remember installing subversion. Inside the .subversion folder is see the following: my-iMac:.subversion my-imac$ ls ...
-1
votes
1answer
38 views

Remove the G++ link to clang++ on High Sierra

It's a well-known fact that the g++ command actually links to clang++, from the llvm toolkit. Problem is, every makefile that uses g++ has to point explicitly to the location, and unless my end user ...
1
vote
1answer
46 views

Install pdfroff on macOS

What's the recommended way to get the pdfroff command working on macOS? It appears groff v1.19.2 comes still bundled with macOS 10.13, but pdfroff not anymore. So do I need to reinstall the entire ...
0
votes
0answers
54 views

Installing ffmpeg on mac os 10.9

I had ffmpeg 3.3.4 working very well on my system, then I force uninstalled all versions of ffmpeg including the version above while meddling with a dependancy for another application. Now, I cannot ...
0
votes
0answers
38 views

Post-install step not completing while installing wine with homebrew

I'm trying to install wine with brew install wine, but it keeps on showing Warning: The post-install step did not complete successfully and when I try again with brew postinstall wine, it shows the ...
2
votes
1answer
52 views

Link pre-installed apps to Homebrew Cask

I installed Slack by downloading the DMG from its website and copying the app bundle into /Applications directory. Alternatively, I could have used brew cask install slack. Is there a way to make ...
1
vote
1answer
35 views

Open homebrew version of emacs instead of Apple version

I installed emacs 26.1 via brew install emacs, but when I try to start emacs via command line, only the outdated Apple-supplied version (22.1.1) opens. However, emacs is apparently correctly linked: ...
1
vote
1answer
103 views

Some homebrew formulas broken after migration

I've migrated from an old MacBook Pro to a new one, using Apple's Migration assistant. Some home-brew formulas migrated with no problem, whereas others got broken at the library reference level. ...
1
vote
0answers
37 views

Brew doesn't recognize previously installed python

I want to use python2 with brew by default. That means that when I type python, it will go to python 2.7.11 . Currently, brew insists on not linking python that it itself installed. Also, when ...
1
vote
1answer
47 views

How to open a URL with Terminal through applescript by using mpg123?

I need to use mac terminal to open an audio stream from a URL through an applescript. I know that mac terminal is already equipped with afplay, but that only plays a file which is available on your ...
4
votes
1answer
64 views

Upgrading from OS X El Capitan to macOS High Sierra

I'm in the process of planning an upgrade from OS X El Capitan to macOS High Sierra, and I'm using things like Homebrew, Composer, Elasticsearch, and — by extension — Java. I'm using MAMP Pro with ...
0
votes
2answers
99 views

How to migrate to a new Mac, including SSH keys and dotfiles?

I have an up-to-date 2018 MacBook Pro that I am replacing with a different 2018 MacBook Pro. I'd like to migrate all the content from the first one to the new one, including the SSH keys, all the ...
1
vote
0answers
25 views

Can't see how to run vi having installed it (I want Vi to run Vi not Vim)

I am trying to run Vi (not Vim), because i'm curious about some older commands like :open. I saw this https://www.reddit.com/r/vim/comments/1u0q0b/how_to_install_traditional_vi_not_vim_on_os_x/ it ...
0
votes
0answers
47 views

Why does my pip3 installed with Homebrew try to write packages to the system library?

I have apparently done something horrific to my Python install. I just recently installed Python 3.7.0 using Homebrew. When I attempt to use pip3 to install a package, it fails: $ /usr/local/Cellar/...
3
votes
1answer
117 views

Is Mac OS Extended (Journaled) safe to be used as a developer instead of the Case-sensitive type?

I am coming from Linux world. I just realized that my MacBook is using Mac OS Extended (Journaled) partition type today and it's case-insensitive. That concerns me a lot as a developer. Because my ...
1
vote
0answers
140 views

Python quit unexpectedly when running Python programs from terminal

I am using Terminal to run code on my macOS High Sierra. I use Python all the time on my laptop (all day every day) and this is the first time I have seen this and it's come somewhat suddenly. I haven'...
0
votes
1answer
90 views

List all installed macOS packages

I've inherited a pre-owned Mac running macOS High Sierra. I wish to use it for Web app development. It's been well-used by the previous owner for Software development and DevOps. It runs like a ...
1
vote
1answer
167 views

Issues installing Mcrypt PHP module

I am trying to install Mcrypt PHP module but encountering some issues: Version of PHP installed: 7.1.16 macOS version: macOS High Sierra 10.13.6 Is the following command that I am running correct? ...
0
votes
1answer
98 views

How to install GNU base64 on Mac OS X?

I'm trying to run linux scripts on the mac, but even brew's updated base64 doesn't support -w0. I want something close to base64 (GNU coreutils) 8.22 Instead of base64 1.5 from brew or the unknown ...
1
vote
0answers
31 views

Is quilt broken on High Sierra?

I'm trying to use quilt to manage a patch set. I installed it with brew, but I'm having problems adding files to the patch series. When I add a file, I get an error that stat cannot read file system ...
2
votes
0answers
534 views

brew install package asks to install command line tools from a path that doesn't exist

I messed up my command line tools. I already had them installed (and were working pretty great), I also installed the beta 2 macOS 10 version from the apple developers site because the command brew ...
0
votes
1answer
32 views

Installing pyqt5 with homebrew just for python2

I don't have (and do not wish to have) python3 installed. I want to install pyqt5 just for python2. However every time I try to install pyqt5 with homebrew it keeps downloading python3 and trying to ...
1
vote
2answers
78 views

wget unable to download anything from https sources.

Using wget to download files from an https source is causing a host is down error. $ wget https://www.google.co.uk/images/branding/googlelogo/1x/googlelogo_color_272x92dp.png --2018-07-16 20:56:17-- ...
3
votes
0answers
67 views

Installing iodine on High Sierra

As far as I can tell Homebrew no longer holds iodine and I can't see it in the Boneyard either. So I'm wondering if there is another good way to get it onto a computer running High Sierra?
37
votes
4answers
24k views

Homebrew: Rollback from Python 3.7 to Python 3.6.5.x?

A brew upgrade upgraded my system Python to Python 3.7. Unfortunately, Python 3.7 breaks other software I need to use (including but not limited to Ansible). I imagine these problems will be worked ...
0
votes
1answer
428 views

Installing ffmpeg in mac os “command not found”

Hello I tried installing ffmpeg after installing homebrew. when I typed "brew install ffmpeg" it says "command not found" can you help please?
1
vote
0answers
23 views

Installation and configuration automation tool

I'm a developer and would like to automate MacOS configuration as much as possible. I'd like to avoid using TimeMachine as it just restores a backup. I'd like to be able to re-install a system from ...
5
votes
2answers
7k views

brew install mysql@5.7 results in missing mysql bin

I needed MySQL 5.7 installed so I ran brew install mysql@5.7. When I do brew services list I see mysql@5.7 started. When I try mysql -uroot I get an error that the bin could not be found. This didn'...
2
votes
1answer
98 views

What's the implication of deleting /usr/local/var?

On MacOS, what's the implication of deleting /usr/local/var (when it contains the following 3 folders - homebrew, run and mysql)? Note, you can assume I don't care about anything in the mysql folder ...
0
votes
0answers
691 views

Cannot install brew on Mojave with Xcode10 [duplicate]

I can not install some packages in home-brew like brew install octave. Installed on my Mac: macOS 10.14 Beta (18A293u) Xcode 9.3 (9E145) Xcode 10.0 beta (10L176w) This issue have ...
9
votes
5answers
14k views

Install Homebrew packages on macOS Mojave Beta

I am trying to install some dependencies for flutter, which requires homebrew. The only problem is that homebrew does not install any tools. For example, if I try both brew install --HEAD ...
2
votes
0answers
171 views

Split a large folder containing many files into a set of smaller folders

This seems like a pretty common use case: I have a folder containing multiple files which I'd like to split into multiple folders, where each output folder is no bigger than a given size. In short,...
0
votes
0answers
57 views

After upgrading weechat using Homebrew, brew says formula built but weechat was not symlinked

I installed weechat 1.9(an IRC client) with brew a long time ago. Today I was trying to update the program to the latest version with 'brew upgrade weechat'. The whole upgrading process was successful,...
2
votes
1answer
124 views

brew cask upgrade does not seem to work

~$ brew cask --version Homebrew-Cask 1.6.6 Homebrew/homebrew-cask (git revision 1c78e; last commit 2018-06-01) ~$ ~$ brew update Already up-to-date. ~$ ~$ brew cask outdated ~$ ~$ brew cask info ...
2
votes
0answers
88 views

Automate package installation via shell script for macOS?

I am trying to write a shell script to automate installation of a bunch of dependencies for a project on macOS which will be an equivalent script for the same that works on EL6/EL7 and uses the yum ...