Questions tagged [hard-drive]

A hard drive is a device for permanent or long-term storage in computers.

Filter by
Sorted by
Tagged with
8 votes
2 answers

Can Recovery Mode install OS X onto a blank SSD?

I want to install a new Solid State Drive (SSD) into the Mac. Can I just build in the SSD, start the MacBook in Recovery Mode and install OS X from there on? After reading a lot on the internet I ...
Janneman's user avatar
55 votes
6 answers

How do I clear the purgeable area on my disk?

I cleared space on my disk by deleting files and emptying trash. But, I am unable to make use of the space that I freed up. That is, as you can see the disk reports 142 GB as Available with 83 GB of ...
Josh's user avatar
  • 997
114 votes
8 answers

How do I get detailed SMART disk information on OS X (Mavericks or later)

I'm trying to get a detailed SMART status report on the drives in my Mac. I'm not talking about "Verified," I'm talking about the detailed report that's about 100 lines long listing all the vital ...
Mike Akers's user avatar
  • 1,243
10 votes
4 answers

I think I messed up the Fusion Drive on my 1TB iMac (with BootCamp)

this is a somewhat similar post to this one (Can't create partition on free space with Disk Utility) but not quite... It started with me creating a BootCamp partition (around 145 GB) for Windows ...
dalogrus's user avatar
  • 145
33 votes
3 answers

How to get the "securely erase" function of Disk Utility on El Capitan & Sierra

Up to Yosemite I regularly used Disk Utility with Erase > Security Options... > writes a single pass of zeros over the entire disk... as a simple method to fully check that a disk is fully safe before ...
dan's user avatar
  • 12.1k
8 votes
4 answers

How to control fan speed in macOS Sierra?

After replacing the hard drive in my 2009 iMac 27", I noticed that the hard drive fan spins at maximum speed since the sensor cable is not plugged in. (The new SSD drive doesn't support it) To solve ...
comfreak's user avatar
  • 1,109
5 votes
1 answer

Partition type suddenly FFFFFFFF-FFFF-FFFF-FFFF-FFFFFFFFFFFF, drive unmountable

I have two drives inside my MBP, an SSD for the OS and the original HDD for large Data. The HDD has 3 Partitions: My Data (Core Storage volume) 20Gb for Linux 4Gb for Linux Swap Recently I ran ...
oarfish's user avatar
  • 1,970
1 vote
1 answer

How to test hard drive - diskutility reports defective drive as perfectly fine

long story I have an USB drive to copy data between Mac, Windows (personally I don't own any) and PS4 - it is exfat formatted. Recently I noticed my Mac would freeze when I plug in this disc - also ...
bdecaf's user avatar
  • 1,183
70 votes
2 answers

What is Why does it grow so big?

When trying to clean up their hard disk, some users discover ~/Library/Caches/ is pretty big, sometimes in the order of many gigabytes. What is it?
hectorpal's user avatar
  • 861
24 votes
4 answers

How can I merge primary APFS partition with other empty APFS partition?

Using the latest Macbook Pro with currently High Sierra 10.13.1, I was using bootcamp for a year, and I decided to get rid of the Bootcamp partition this morning. The Bootcamp utility would not let me ...
Scaraux's user avatar
  • 433
3 votes
1 answer

HFS+ invalid number of allocation blocks

Okay so a few days ago I wanted to install Ubuntu GNOME over regular Ubuntu and it gave me the option to automatically overwrite my Ubuntu installation (that I had on a separate partition from my OS X ...
Roemer's user avatar
  • 147
3 votes
1 answer

New SSD problem

I've just installed a new SSD replacing an HDD in my old (late 2008) iMac. When I switched it on all I got on screen was a question mark. On the advice of my son I tried cmdR during switch on with ...
Charliehp's user avatar
35 votes
7 answers

What is the best way to clone a disk between two Macs?

What is the best way to clone a disk between two Macs? I ask this every couple years or so and every time I get the same answer. "Use Carbon Copy Cloner", they say. But the unfortunate fact is that ...
erotsppa's user avatar
  • 4,819
5 votes
3 answers

Recover deleted Encrypted OS X Extended volume

I accidentally formatted an external 1TB HD to FAT file system using Disk Utility in Mac OS. The disk used to be HFS+ encrypted. Encryption was done when I created the OS X Extended partition, not ...
waffle's user avatar
  • 81
21 votes
1 answer

Disable the disk check when reconnecting an improperly disconnected disk to OS X

If you disconnect a removable drive without ejecting it first, the next time you connect it, Windows or Mac run an fsck check on the disk to ensure data integrity. Windows will ask if you want to ...
Chris's user avatar
  • 469
5 votes
3 answers

APFS partition inaccessible, container missing

I'm running macOS Mojave on a late-2015 4k 21.5" iMac. I have lost access to my internal hard drive, but I can use my iMac by running macOS from an external drive or through recovery mode. When I ...
user306251's user avatar
3 votes
1 answer

Macbook Pro hard drive failing?

I'm trying to figure out if my Mac's hard drive could be failing, or that it could be some other component or the HD cable. After transporting my Mac about a week ago it started beachballing a lot. I ...
joff19's user avatar
  • 31
54 votes
11 answers

External Hard Drive Won't Mount

I've searched and tried a lot of stuff but still can't get it to work. I was able to use my seagate HDD properly last week but now it doesn't mount. I tried plugging it to a PC & another mac, it ...
demiculus's user avatar
  • 713
35 votes
3 answers

USB Drive Will Not Mount, Not Listed in Disk Utilities, but Found In System Profiler

I have a Seagate FreeAgent Go drive with the optional docking station. I use it to keep files that I don't access on a regular basis and as a place to do "quick backups" of things like my Paperless ...
Allan's user avatar
  • 99.9k
8 votes
1 answer

How to fix GUID hard drive corrupted to MBR

I am on OS X 10.9.5 with a late 2013 iMac. I have a 3TB hard drive that has an unusual problem. It is a Western Digital 3TB Red WD30EFRX. I formatted it with two partitions, both 1.5TB. One was a ...
junkelly's user avatar
191 votes
6 answers

Is it safe to delete ~/Library/Caches?

Is it safe to delete the file Caches, in the Library of the Mac OS X Hard Drive? It's a pretty big file, 3.56 GB, Caches reminds me of logs i don't need or browser cookies. Is it safe to delete the ...
GummyArgyle's user avatar
  • 3,091
56 votes
7 answers

Do Macs need to be defragmented?

I don't see any application to defragment my Mac (running OS X). Is defragmenting not necessary for Mac OS X? If so, why not?
spong's user avatar
  • 2,345
31 votes
4 answers

Why is a secure erase 'not necessary' for SSD's?

I'm about to trade in a 2010 MacBook Pro with an SSD. However, I'm unable to do a Secure Erase from the recovery disk (as I used to do with mechanical hard drives before selling or giving away a ...
Bill's user avatar
  • 332
14 votes
1 answer

Replacing SuperDrive with secondary storage?

I'm familiar with the OWC Data Doubler, a kit which allows you to remove your Macbook's SuperDrive and replace it with secondary storage. What alternatives exist for this product? A complete answer ...
Sean Moubry's user avatar
10 votes
9 answers

Checking for bad blocks without formatting

My Mac tends to pause every now then when preforming simple tasks such as right clicking, opening menus and typing (It actually just froze when I started typing this question.). I've read in a few ...
Ron's user avatar
  • 233
9 votes
4 answers

Why does my mac not have free space even after I delete files?

Today I want to install Catalina but it requires 17 GB of disk space, and I only have 8 GB. So I started to delete files but only found out that the disk space was unchanged or even shrinked more ...
Blaszard's user avatar
  • 3,583
6 votes
1 answer

Large difference in reported free disk space

I have a strange discrepancy in the amount of free disk space that's being reported. The finder says: My iStat Menus says: Which is the same as df -h reports: remco@Prosperpine ~ $ df -h Filesystem ...
Remco Overdijk's user avatar
6 votes
4 answers

iMac won’t boot up from internal drive but can boot from external drive, but internal drive can boot other Macs

I am seeking suggestions on what may be going in with an iMac I am currently troubleshooting, as it’s displaying behaviour I do not recall seeing before. Short story This iMac refuses to boot up. It ...
Monomeeth's user avatar
  • 64.4k
16 votes
3 answers

Is it necessary to eject external drives before logging out, restarting, or shutting down?

Is it necessary or recommended practice to eject external drives before logging out, restarting, or shutting down? (The drives are not being unplugged.) BTW, I am aware that I need to eject my ...
Phil M's user avatar
  • 691
9 votes
2 answers

How to fix Disk Utility, About This Mac, and Finder that disagree on hard drive space usage?

Has anyone seen this issue and know how to fix it? Look at the free space reported by running "Get Info" on my hard drive (Macintosh HD) in the Finder, "About This Mac" from the Apple Menu, and Disk ...
finiteloop's user avatar
7 votes
2 answers

Can I manually put an external hard disk to sleep?

Is it possible to manually put an external hard disk to sleep? Right now, I've already got "Put the hard disks to sleep when possible" checkmarked in the Energy Saver preference pane, and so they ...
Gary's user avatar
  • 4,283
6 votes
3 answers

iMac 27" late 2012 SSD upgrade

I'm the proud owner of an 27-inch iMac 2012 with high-end configuration, but the 1TB fusion drive keeps being the bottleneck. As my warranty has expired now, I want to upgrade the 128GB SSD to a ...
LukeLR's user avatar
  • 470
5 votes
1 answer

Extend main APFS partition fails with "target disk is too small for this operation"

/dev/disk0 (internal, physical): #: TYPE NAME SIZE IDENTIFIER 0: GUID_partition_scheme *251.0 GB disk0 1: ...
Ahmed Kamal's user avatar
4 votes
2 answers

Unable to boot into Mac OSX after updating dual-boot Ubuntu, Partition Type FFFFFFFF-FFFF-FFFF-FFFF-FFFFFFFFFFFF

On my Mac OSX Mojave machine.. I installed Ubuntu 18.04 to attempt to dual boot on the internal Apple SSD. Worked for a while, but after some updates to Ubuntu... hitting the power button boots up to ...
Rolando's user avatar
  • 153
4 votes
1 answer

Accidentally ejected External drive while downloading file, now having problems reading

I'm hoping someone can help! I recently downloaded a torrent directly onto an external hard drive, (using a 2009 MacBook Pro and 1TB Seagate Expansion portable Drive) somehow during the download the ...
Gearoid Óg's user avatar
25 votes
3 answers

What are next steps when fsck reports "could not be repaired after 3 attempts"?

My Mac Book Pro 13.-" doesn´t get past the grey booting screen with the apple and the spinning wheel (The loading bar appears but when it´s done nothing happens) I have 220 GB in one single ...
BenCis's user avatar
  • 251
15 votes
3 answers

How can I disable the 2nd hard drive in my 27" iMac?

I have an 2010 27" iMac with an SSD and a regular hard drive. Now that I've been using the machine for some time and have not come close to filling the SSD, I'd like to disable the spinning hard drive ...
Sebastian Good's user avatar
12 votes
4 answers

What are some tips for replacing my MacBook Pro hard disk with SSD?

I would like to replace my MacBook pro hard disk with an SSD, without reinstalling everything. I am looking for your experience on good SSD drive models that have good performance at a fair price the ...
Stefano Borini's user avatar
9 votes
4 answers

Disable mounting Internal Macintosh HD at boot [duplicate]

My iMac (mid-2010 model, Snow Leopard) has a problem with S.M.A.R.T status: Failing and it has become read-only. Because I didn't want to waste money on the repair, I bought an external HD, so the ...
user avatar
8 votes
3 answers

How to fix Mac hard drive partition showing as FDisk_partition_scheme

My situation seems very similar to how to fix GUID hard drive corrupted to MBR but with enough differences that I haven't been able to put together a confident solution. I have a 3TB Toshiba drive in ...
Doug Smith's user avatar
7 votes
1 answer

Unable to erase, reformat, or repartition USB drive

This afternoon I attempted to mount a .iso of Windows 7 to a bootable USB drive. It's about 370GiB, so more than enough to store it. I did the following to get myself into this mess. Note,/sda/disk2 ...
haloux's user avatar
  • 93
6 votes
4 answers

Recovering data off of a dead hard drive

My hard drive died in my macbook and it no longer will start up. It will not mount in an external enclosure but disk utility is still reading that the hard drive is there, and I tried to repair disk ...
Stephen's user avatar
  • 1,381
6 votes
4 answers

Sometimes Mac doesn't recognise my external hard drive

I have a Western Digital My Passport Ultra 1 TB external hard drive that is formatted FAT32 and a 16 GB Silicon Power USB thumb drive and both of them uses USB3 but my MacBook Pro sometimes doesn't ...
Amir_P's user avatar
  • 133
5 votes
1 answer

diskutil list shows 20 disk partitions, I only know 3, what are the rest?

Following the post FFFFFFFF problem with hybrid partitioned drive, not able to fix with the guide in other topics, diskutil list gives me the following big list of disk partitions, what are the /dev/...
Miao's user avatar
  • 75
5 votes
1 answer

Resizing dual boot partitions in Yosemite

I have a dual boot Macbook Air with Yosemite and Ubuntu. I would like more space on my Ubuntu partition and need to therefore reduce the size of the Mac partition. I assume this will cause some damage ...
hhhhhhhhh's user avatar
5 votes
2 answers

Finder Reports Disk is Full, Other Tools Don't Account for it

I looked at some of the other Q&A here and didn't see a duplicate of this one (e.g., How can I figure out what's slowly eating my HD space? and other linked and related questions). Finder reports ...
Jim's user avatar
  • 191
4 votes
4 answers

My WD external drive unmounted itself and now does not work

I have a strange problem. Working on an OS 10.9.5 MacBook laptop. Last night, I was exporting a 20-something GB Aperture library from my WD 2TB drive to another hard drive. I left, and when I came ...
Nova's user avatar
  • 141
4 votes
4 answers

50GB of disk space missing

On a 120GB SSD hard drive in a MacBook only 70GB are available. The missing 50GB are not even shown as free space. Here is what the output of Disk Utility looks like: As you can see on the first ...
Stan's user avatar
  • 163
2 votes
1 answer


I know this has been asked on here before, and similarly to the others I have not backed up my data... I found this duplicate and got lost in the answer and didn't want to mess too much with the ...
Dillon Esponda's user avatar
2 votes
2 answers

Blinking question mark on folder on boot

I am attempting to boot up my 2009 MacBook Pro, but when it starts it immediately shows a white screen with a 'question mark folder' — it keeps blinking until the computer shuts down (unless I keep it ...
Kewin's user avatar
  • 21

2 3 4 5