We’re rewarding the question askers & reputations are being recalculated! Read more.

Questions tagged [apache]

The popular open-source Web server application, an implementation of which is included in macOS.

Filter by
Sorted by
Tagged with
2
votes
1answer
63 views

Restart Apache causes applications to react really weird

I have macOS High Sierra running on my Mac, and it has worked fine until now. But today I experienced something very weird. I was trying to restart Apache (a web development server), and then my apps ...
0
votes
1answer
22 views

Apache2 not running on High Sierra without Homebrew

This is a post I have found on this issue: Apache2 (Httpd) not working after update to High Sierra But I have a situation where httpd is not running after setting preference -> sharing ->web sharing ...
0
votes
1answer
4k views

Apache not working on my Mac with Sierra

I've followed instruction on how to activate Apache on my Mac prior to upgrading to Sierra. I got the "It Works" page after entering localhost in the address field, yet after I upgraded to Sierra, I ...
25
votes
8answers
113k views

How to fix 403 in Mac OS X built-in Apache?

I'm trying to set a local environment on my new MacBook Air 13": built-in Apache with my own DocumentRoot, PHP, and MySQL. I usually update /etc/hosts just to run my local websites with a pretty ...
0
votes
1answer
8k views

Unable to access xampp files because of user permissions problem

I've installed xampp on my MacBook with macOS 10.12, Sierra. Everything works fine, but I created php app with slim framework witch creates cache files. The problem is that I have no permissions to ...
11
votes
4answers
51k views

How to remove preinstalled Apache and PHP from Mac OS Sierra

I have been trying to figure out how to completely remove preinstalled Apache and PHP from my macbook pro ... The reason is that I am using the homebrew version of both Apache and PHP. The current ...
2
votes
0answers
76 views

Why is brew always reporting success when failing to start a service?

I'm trying to setup httpd with HomeBrew on a mac. As I painfully learned today, brew services start always reports success, even when httpd fails to start. Example failures reported as success: ...
1
vote
2answers
35 views

Cannot get httpd to listen on port 80

I installed httpd using brew. I edited /usr/local/etc/httpd/httpd.conf and changed: Listen 8080 to: Listen 80 Restarted the service: brew services restart httpd But Apache's still listening on ...
14
votes
5answers
17k views

Apache2 (Httpd) not working after update to High Sierra

I have an issue where Apache will not start after updating to High Sierra 10.13.1. There isn't anything showing in the error logs, but when I try to apachectl start nothing happens. If I run ...
0
votes
0answers
53 views

Cannot access mysql from Perl with SIP enabled on Mac Mojave

I'm using a Mac running Mojave as a dev server. I got Perl talking to MySQL but if I enable SIP, anything that accesses the database chokes. Simply disabling SIP fixes it. I have no idea what this ...
0
votes
0answers
47 views

403 Forbidden on my default *AMP setup in MacOS Mojave

I am using the default Apache + PHP 7.1 on Mojave : (no brew) Server version: Apache/2.4.34 (Unix) Server built: Feb 22 2019 20:20:11 I researched Apache Localhost 403 Forbidden with macOS Sierra, ...
0
votes
1answer
90 views

How do I fix macOS Mojave httpd syntax error in a localhost setup?

System details: OS Host: Mac OS Mojave PHP: 7.1.23 I am trying to set up my local server on a new Mac. I have been following the following instructions on https://discussions.apple.com/docs/DOC-...
13
votes
6answers
103k views

Enable URL rewriting (mod_rewrite) using .htaccess files in ~/Sites on Lion

I cannot get mod_rewrite to work on Lion. I am developing a number of websites locally, in ~/Sites, using .htaccess files. I am on 10.7.3 and I have not touched any configuration files except for ...
0
votes
2answers
353 views

How to view status of service (e.g. whether it's running) in a format similar to Linux `systemctl` using macOS `launchctl`?

How to view status of service (e.g. whether it's running) in a format similar to Linux systemctl using macOS launchctl? I want to view the status of a service in macOS using launchctl in a format ...
2
votes
1answer
37 views

How is my Apache server auto-booting without a LaunchDaemon plist?

A few months ago I setup an Apache server on a Mac Mini running Mac OS 10.14.6. It runs great. Each time I reboot the mac, the Apache service also starts, great. My question is, why? There is no /...
1
vote
1answer
155 views

Fix permissions in Apache

I'm trying to use the built-in Apache server in MacOS mojave. In my browser, accessing http://localhost/~myusername/mypage.html (in case of user dir) or http://localhost/mypage.html (in case of ...
0
votes
0answers
15 views

How to fix built-in Apache webserver read/write permission properly

There are hundreds of questions about it, but I'm still stuck with this problem and looking for a proper solution. The newest solution (mine) fix just the reading issues, it doesn't solve the writing ...
2
votes
1answer
46 views

PHP won't include files properly since updating to Mojave

On our office Mac, we have a local Apache server running through the software AMPPS. Prior to updating to Mojave, everything was working correctly. Now, after updating, there is an issue with using ...
1
vote
1answer
42 views

hosts file: does it pass the domain name? I'm always redirected to the main site configured on the host

My NEW server IP address is 123.456.789.123. Pointing my browser to 123.456.789.123 (http://123.456.789.123) the server serves me site alpha. Now, on the same NEW server I've configured a second ...
0
votes
2answers
193 views

How do you remove MariaDB and NGINX from Mac via terminal?

How do you remove MariaDB and NGINX from Mac via terminal? I am just trying to run Apache2 on localhost:8080 but I get the NGINX welcome page.
2
votes
2answers
470 views

OSX Sierra, trouble with virtual hosts

I'm trying to create a separate virtual host on a Mac for a local project, which would not be http://localhost/ibb but, for example: http://ibb.local. For this I carefully followed the next ...
2
votes
1answer
241 views

ports 80 and 443 suddenly closed on macos server

short story Ports 80 & 443 seems to be closed on my MacOS Server (checked with Network Utility) -- cannot access any website from both local network and internet. Have restarted the websites ...
0
votes
0answers
53 views

httpd-wrapper failing, just httpd fine

Apache is working fine if I start it with /usr/sbin/httpd -k start But If I use the apachectl start command it fails, as does the plist file. It’s only started doing this just since the last couple ...
1
vote
1answer
1k views

Apache keeps saying: You configured HTTP(80) on the standard HTTPS(443) port!

I have configured an SSL web site using the macOS Server app (version 5.3). When I examine the Apache log, I see this message (twice): [ssl:warn] [pid 4120] AH01916: Init: (mydomain.net:443) You ...
26
votes
5answers
20k views

How do I get my user directory working for web sharing again?

I had web sharing enabled in Lion and a web site at http://localhost/~user, where user is my User directory. When I upgraded to Mountain Lion, web sharing (Apache) remained enabled and I can go to ...
3
votes
3answers
4k views

Conflict between internal Apache and Apache installed via Homebrew

I have faced following trouble. I wanted to have multiple versions of PHP so I used this article to achieve this. But I could not stop Apache via sudo apachectl -k stop when running this command I am ...
2
votes
1answer
65 views

CGI scripts won't execute on website

I have a website up and running on the Apache webserver, but the CGI scripts in /Library/WebServer/CGI-Executables will not run. Instead, the text of the file loads in the browser instead. I made ...
7
votes
3answers
18k views

PHP not working after upgrading to OS Mojave

When i try to open localhost it gives me 403 error message like this "You don't have permission to access / on this server." I have tried changing the permission but nothing happens. It worked fine ...
0
votes
0answers
93 views

Apache Netbeans 10 binaries not working

I have recently downloaded the Apache Netbeans 10 binaries from the Apache Netbeans (Incubating) site. I extracted the zip file to /Application/netbeans/. But when I try to run /Application/netbeans/...
0
votes
1answer
66 views

Account with parental controls enabled breaks proxy use

I have a MacBook Air running Mojave (10.14.2). My router is running a proxy using Squid that works fine on the Mac's administrator account and a user account. When the user account has Parental ...
0
votes
0answers
18 views

Firewall off by default, and when I turn it on it doesn't block connections

Yesterday, I had to get a PHP app running locally on my brand new, plain-vanilla Mac Mini. I was disturbed (to put it mildly) to discover that Apache was already installed, and running, and serving ...
0
votes
1answer
3k views

I can’t connect to localhost on Mac high Sierra

I have followed this guide to set-up Apache on High Sierra: https://coolestguidesontheplanet.com/get-apache-mysql-php-and-phpmyadmin-working-on-macos-sierra/ I used it to set it up on Sierra. But ...
0
votes
0answers
779 views

PHP and Apache not working after upgrading to Mojave

I have a very similar question as this PHP not working after upgrading to OS Mojave so it's not a duplicate as I get a different error I had Apache and PHP working absolutely fine running on High ...
1
vote
1answer
181 views

Questions from trouble getting the UniFi Controller to work on macOS High Sierra + Server (port 8080 in use)

After upgrading from Sierra+Server to High Sierra+Server I am running into the problem that port 8080 is occupied by default. This blocks the UniFi controller from launching. After the upgrade, I ...
1
vote
3answers
13k views

Opening apache conf file with write permissions

I'm trying to open the /private/etc/apache2/httpd.conf file to make some changes. I thought I'd be able to open this with the correct permissions from the command line, so I tried: cd /private/etc/...
0
votes
1answer
529 views

Automator app stopped working after updating to macOS Mojave

Today I updated to Mojave because the notifications were killing me. A script I have in automator to launch apache server on startup stopped working after the update. This is all this automator app ...
2
votes
1answer
2k views

remove homebrew apache2 fails

On a new Macbook Pro, I installed apache2 with homebrew, but now want to switch back to native apache2 server. I removed the homebrew package with: brew uninstall apache2 I also removed any ...
4
votes
1answer
577 views

Changing Default Apache version on MacOS Sierra

A DHS sweep of the network showed that one of the researchers Macs is running a non-safe version of Apache (2.4.25) and they would like him to update to at least 2.4.27. He is having difficulty ...
0
votes
1answer
502 views

Apache not running correctly after upgrading to High Sierra

I have an apache web server running on my mac. Since upgrading to macOS High Sierra, if I connect to localhost or 10.0.0.7 in Safari (or any other web browser) I get the message "Safari can't open ...
8
votes
5answers
42k views

Localhost refuses to connect after upgrading to Sierra OS

I have downloaded and installed apache, php, phpmyadmin, mysql via macports. Everything was working fine before upgrading to macOS Sierra. After the upgrade whenever I try to access localhost I get ...
0
votes
0answers
133 views

Enable PHP on macOS Server 5.6

In the most recent update to macOS Server 5.6, Apple had removed quite a number of services from the Server application in favor of built-in services in the system itself. However, now that the ...
1
vote
1answer
2k views

How to set up WebDAV (with wfsctl) on macOS High Sierra with Server 5.6.1?

After having upgraded to High Sierra with Server 5.6.1 I want to recreate the WebDAV shares I had. I've used wfsctl to create a share point. The share point has ACL for a specific user. So far so good ...
2
votes
1answer
1k views

How to start homebrew Apache on boot?

I've switched out the default apache for the homebrew version. I've stopped the default apache starting on boot with: sudo launchctl unload -w /System/Library/LaunchDaemons/org.apache.httpd.plist ...
0
votes
3answers
253 views

Give local PHP Full Disk Access in Mojave

I have a PHP webpage running on the local apache installation. The page uses shell_exec to access the messages/chat.db via sqlite3. shell_exec("sudo -u ben sqlite3 ~/Library/messages/chat.db \"...
0
votes
3answers
2k views

macOS Server http(s) ports bound

I've got a Mac mini 2014 (running macOS Sierra 10.12.2) with the Server.app installed. I was planning on hosting a webserver on this device on the default http(s) ports. However, I've found that one ...
0
votes
1answer
2k views

localhost/phpmyadmin - 404 error on macOS High Sierra

I'm setting up a PHP project on my machine's loalhost. This part is working fine, and it's loading the index.php correctly when visiting http://localhost. However, visiting http://localhost/phpmyadmin ...
1
vote
0answers
231 views

Does the Mojave update wipe the previous Apache settings?

I just updated to Mojave over the weekend and today none of my local Apache addresses work, neither localhost, nor custom domains. I can't find any reference to my previous custom domains in the /...
4
votes
5answers
6k views

XAMPP VM and text editors

I recently installed XAMPP for OS X (XAMPP VM PHP 7.2.1) which now virtualizes the entire box for obvious benefits of higher security. Although I admire the new concept and see its benefits, I cannot ...
4
votes
1answer
24k views

How to properly and for once reinstall PHP/Apache

So I'm struggeling with this since a long time and I'd like to find a proper solution. I have php5.4.. install and I want to upgrade to Php 7. No matter how hard I'm trying to do it I can't seems to ...
3
votes
1answer
297 views

MAMP still can't access Apache after creating local virtual hosts

I had finally got my PHP and MySQL to work again and then I decided to set up local virtual host. Everything was working perfectly up to that point. I have been getting error messages when I do ...