Linked Questions

1 vote
1 answer
6k views

Restricted files on El Capitan? [duplicate]

So I wanted to hide the Finder icon on my Dock. According to this answer - How can I remove the Finder icon from my Dock? I am suppose to edit DockMenus.plist file. When I tried I had no permission ...
Xoroxoxoxoxoso's user avatar
1 vote
1 answer
2k views

Even as admin, I cannot edit DefaultFonts.plist for Notes.app. What am I doing wrong? [duplicate]

I want to modify DefaultFonts.plist for the Notes application. I've tried a few different ways since what worked on old OS doesn't on 10.14 Mojave: I've navigated to the file through finder, went to ...
Will Brooklyn's user avatar
0 votes
1 answer
380 views

How to create/write file under /usr in OS X 10.11 [duplicate]

I was going to compile a php extension using phpize, but it reported some files not found. I googled and found some solutions, In OS X 10.9, we can make a symbol link from /XCODE_PATH/OS_X_SDK/usr/...
0xBBC's user avatar
  • 1
0 votes
0 answers
145 views

How do I overcome "Operation not permitted" when attempting to edit a file as root (admin)? [duplicate]

I'm using Mac 10.13.6. I want to add environment variables to be recognized by my Apache instance. However, I'm not able to edit the file, event when logged in as root ... localhost:Documents davea$...
Dave's user avatar
  • 361
0 votes
0 answers
131 views

cp: ./public.generic-pc.icns: Operation not permitted [duplicate]

On my MacOS Mojave: I'm trying to change the icon of an SMB Windows File server from the old CRT-BSOD icon to something newer like e.g. the NAS icons. I'm fine with just using the NAS icon (the com....
Bjørn Dirchsen's user avatar
0 votes
0 answers
73 views

How to give myself permission to edit the locked hosts file on MacOS Mojave? [duplicate]

I am logged in with my admin account, which is my only account on this computer. I checked under preferences and it says "admin". I have located the file here: /private/etc/hosts When I go to ...
user1721135's user avatar
116 votes
12 answers
170k views

How to use pip after the OS X El Capitan upgrade?

After the El Capitan update, I am unable to run pip install. The error I get is that the "operation is not permitted" when pip tries to create new folders while installing. creating /System/Library/...
web_ninja's user avatar
  • 1,263
55 votes
6 answers
129k views

Mount Ext4 on El Capitan

I recently installed OS X 10.11 on my Mac. I tried to read a SD card with an Ext4 partition which wasn't even shown in Disk Utility, although diskutil did show it as a Linux partition. I can't seem ...
Milliways's user avatar
  • 7,992
59 votes
4 answers
17k views

Find which process receives a given keyboard command

I'm trying to figure out why a certain keyboard combination is no longer working. As an example, Sublime Text 2 ships with a keyboard shortcut for opening the Find/Replace panel: Command + Option + ...
Mark Fox's user avatar
  • 735
30 votes
5 answers
47k views

.pkg for installer hangs on verify

I'm trying to install the Mono MDK, and downloaded the .pkg for 4.2.1 (about 200 MB), when I double click on the package, it opens a "verifying xxxxxMDKxxxxx.pkg" window, which does nothing for over ...
Lost Odinson's user avatar
30 votes
3 answers
166k views

View another user's files in OS X

Is there a way to (temporarily) view another user's file on OS X other than to change the permissions of the file? I'd like the OS to ask for the user name/password. I guess what I'm looking for is ...
John Smith's user avatar
12 votes
3 answers
13k views

Installing ffmpeg from dmg and then running from a terminal, is there a better way?

From here: https://ffmpeg.org/download.html#build-mac I chose static builds 64-bit which too me to https://evermeet.cx/ffmpeg/ I then downloaded this: and opened it using this: which gave ...
uhoh's user avatar
  • 1,738
31 votes
4 answers
37k views

How can I install a new dictionary on OS X for use with the "Word of the Day" screensaver?

The reason is trivial: I am a fan of the "Word of the Day" screen saver and I would like to add dictionaries for languages other than English and Japanese (these are the two that I can select now in ...
scrrr's user avatar
  • 1,073
21 votes
5 answers
13k views

Jittery macOS mouse cursor when hovering over links

I'm experiencing a jittery/buggy/flickering mouse cursor when moving my mouse over hyperlinks. This occurs in both Safari and Chrome. It also occurs in other non-hyperlink instances of the mouse ...
pkamb's user avatar
  • 8,861
14 votes
4 answers
2k views

How can I safely install applications which aren't distributed via the Mac App Store?

To keep things simple, I'd like to only install apps from the official AppStore. But, I'm frequently finding that the apps that I need are not on the AppStore such as Gradle, Carbon Copy Cloner, and ...
rppkgai's user avatar
  • 359

15 30 50 per page
1
2 3 4 5
7