Linked Questions

0 votes
0 answers

macOS not allowing me to change file permissions though I am the sole user/admin [duplicate]

macOS is not permitting me to change the file permissions of any file! whenever I try to add the admin which is me, finder gives me this error: you don't have necessary permission - operation not ...
Sayan's user avatar
  • 2,249
1 vote
1 answer

root permissions [duplicate]

After I installed el Capitan, Little Snitch started complaining about gamed trying to phone home. Research in the net revealed various suggestions, including logging out from the Game Centre using ...
Stephen Winnall's user avatar
-1 votes
1 answer

Cannot Change Permissions for Plist file in Mojave [duplicate]

I'm using Mojave and I'm trying to change the permissions for this file /System/Library/PrivateFrameworks/Slideshows.framework/Versions/A/Resources/Content/EffectDescriptions.plist I want to alter the ...
bobsmith76's user avatar
96 votes
10 answers

Is it 'OK' to use the root user as a normal user?

I have enabled the root user on my Mac so I can log into it and run Finder etc. Being the lazy person that I am, just transferred everything from my home directory to /var/root. I'm not too sure of ...
智障的人's user avatar
  • 1,087
50 votes
13 answers

Can you actually use Terminal to crash your computer?

People who don't understand Terminal are often afraid to use it for fear that they might mess up their command and crash their computer. Those who know Terminal better know that that's not the case - ...
DonielF's user avatar
  • 1,082
69 votes
9 answers

File can't be moved by root on OS X

I tried to move a few files to a subfolder on OS X. One refused to move. It said Operation not permitted. I tried again as root: $ sudo mv file subfolder/ mv: rename file to subfolder/file: Operation ...
eje211's user avatar
  • 833
147 votes
2 answers

How to investigate high kernel task memory usage?

I was using my MacBook Pro (with 16GB of RAM) as usual and out of blue I've this popup that: Your system has run out of application memory. To avoid problems with your computer, quit any applications ...
kenorb's user avatar
  • 12.6k
30 votes
3 answers

View another user's files in OS X

Is there a way to (temporarily) view another user's file on OS X other than to change the permissions of the file? I'd like the OS to ask for the user name/password. I guess what I'm looking for is ...
John Smith's user avatar
19 votes
4 answers

Why do I get "ls: Desktop: Operation not permitted" when I own Desktop?

I'm on Big Sur, and I understand there have been some changes with permissions in macOS since Catalina. I don't understand, however, how it is possible that I cannot ls ~/Desktop when ls -l ~ shows ...
interoception's user avatar
49 votes
1 answer

What's /System/Volumes/Data?

New mac user here (Linux background). I'm running macOS Catalina (Beta5). I've noticed there are 5 volumes in my main disk container. One is mounted at /, that I understand, it's the system, another ...
Dan's user avatar
  • 423
18 votes
3 answers

Catalina not allowing to change read/write permissions despite having SIP disabled

Currently Running: macOS Catalina 10.15.1 Issue: Ever since I upgraded to Catalina, macOS is not allowing me to change read and write permissions on system protected files, hence, I am not able to ...
Sayan's user avatar
  • 2,249
17 votes
4 answers

Trying to set boot-args with nvram gets "general error" on Sierra

I'm trying to temporarily disable KEX signing enforcement on my MBP since my company's VPN client (GlobalProtect) is failing the signature check now. This started yesterday when I did the OS upgrade ...
Michael Oryl's user avatar
13 votes
2 answers

Mac OS/X won't let me mkdir /usr/share/tomcat6, even as root

Running MacOS Sierra (10.12.6) me $ sudo su root sh-3.2# bash bash-3.2# pwd /usr/share bash-3.2# mkdir tomcat6 mkdir: tomcat: Operation not permitted bash-3.2# chmod g+w /usr/share/ chmod: Unable to ...
Greg Dougherty's user avatar
17 votes
1 answer

What and how does macOS Mojave implement to restrict applications access to personal data?

As well as many of the other features talked about during macOS Mojave's release like dark mode and the addition of new apps like Home, another key feature of macOS Mojave seems to be it's heightened ...
Tom's user avatar
  • 645
11 votes
1 answer

Can't write to /usr even with sudo

Here's my problem: sudo php -d detect_unicode=0 go-pear.phar ...should let me run as root and modify /usr & /usr/share directories, but I get this: Below is a suggested file layout for your ...
Anadi Misra's user avatar

15 30 50 per page