Linked Questions

7
votes
1answer
8k views

How to fix GUID hard drive corrupted to MBR

I am on OS X 10.9.5 with a late 2013 iMac. I have a 3TB hard drive that has an unusual problem. It is a Western Digital 3TB Red WD30EFRX. I formatted it with two partitions, both 1.5TB. One was a ...
3
votes
2answers
16k views

Rebuild partition table on external HDD - not writable

I have an external hard drive formatted with 3 HFS+ partitions. To cut a long story short I had it connected to a Windows PC and accidentally started formatting the drive to NTFS. As soon as I ...
1
vote
1answer
9k views

Missing Mac partitions - unrecognized file system

Apparently, I installed Windows 7 via bootcamp and created a new partition in Windows (which probably affected the partition table). After restart, I can't see Macintosh HD in startup disk (it only ...
4
votes
2answers
5k views

Partition map rebuild

I have an external hdd that doesn't mount anymore. I think I screw up with all the research I done and things I try. I have vital info on this hdd and I'm really afraid to lose it. I tried this: ...
3
votes
1answer
3k views

Partition on HFS+ external drive: “Invalid number of allocation blocks”, file system check exit code 8. Unable to repair, even in recovery mode

As the title says, I'm getting the error "Invalid number of allocation blocks" on a particular HFS+ partition of an external drive. I am unable to repair, even in recovery mode. Log results when I ...
2
votes
1answer
1k views

Accidentaly converted from a basic disk to a dynamic one

I got a MacBook Pro (13-inch late 2013 retina) So I installed Windows 7 using bootcamp and all was fine. I then needed to create a 32MB FAT16 partition, when Windows prompted me to convert to a ...
-2
votes
1answer
575 views

Hardrive will not mount after deleting Linux partition. Can’t boot into Mac OS X [duplicate]

I tried to delete a Linux partition on my hard drive. My hard drive was no longer bootable and the type turned into FFFFFFFF-FFFF-FFFF-FFFF-FFFFFFFFFFFF. I tried to follow some of the other ...
3
votes
1answer
323 views

Remove Linux partition on Mac. CoreStorage problems

I have a Macbook pro 2015 with a 256 GB SSD and a Linux partition. I would like to remove the partition. Following the steps written in here, I got stuck in the Modify step. Once I execute the command ...
1
vote
0answers
322 views

Invalid number of allocation blocks in Disk Utility Repair

First of all I hope @klanomath is still active over here as I'm having a similar issue as described in following thread: Partition on HFS+ external drive: "Invalid number of allocation blocks&...
1
vote
1answer
107 views

My whole startup disk has gone blank

After a botched arch Linux install, my whole ssd got wiped. I used a bootable USB drive for Ubuntu to see what happened and saw that all my partitions from the SSD had vanished and the drive was ...