3

I shared a folder from the host system (OSX) and use mount it in the guest system (OSX). But it is mounted only with rwx------ mode. I granted an rw access for the shared folder for a user in the guest system and for everyone as read-only. But in the guest system the folder is going mounted to the /Volumes/ as a shared disk with rwx------ permissions. How can I mount it with rwxr-xr-x permissions?

Update 1:

in the host system it has rwxr-xr-x+ permissions

Update 2:

the problem sounds to be like here: permissions for mounted internal disk [ask ubuntu]. So is it kind of related to fmask, dmask (umask)?

Update 3:

here is similar situation, but on linux 700 instead of 755 permissions on auto-mounted USB HDD. so there is a /etc/fstab.hd file on osx but it considered be useless

Update 4:

it looks like all AFP shares appears as drwx------. How to change it?

  • Please, take a look at chmod. From the "Terminal" prompt, type "man chmod". – Papiro Aug 25 '13 at 12:11
  • :) already tryed. from host system it is already 755 (rwxr-xr-x+), from guest system it doesn't work - insufficient permissions (remount doesn't work, or I don't know all tha options). – static Aug 25 '13 at 15:47
1

You need to specify the permissions when executing mount - the local file permissions or the permissions you set with chmod on the directory to which you mount your share will not be taken into consideration.

You should do mount -t <fs_type> -o m=755 /path/to/source /destination

I'm not sure which filesystem type is what you're trying to mount (is it nfs? or hfs?) - you only refer to a host system and a guest system without any more details. You'll need to specify the correct file system type to the mount command (but I'm presuming you have already done that and it did work). Also, it would be a good idea for you to read the man for the relevant mount command (so, if the fstype is hfs, you'll need to read man mount_hfs; similarly, if it's nfs, you need to man mount_nfs; have a look at the bottom of man mount for more fs specific mount commands).

Hope that helps!

  • It says -o m: option not supported – static Aug 25 '13 at 22:26
  • OK, but can you provide more details? Did you run mount, mount_nfs or mount_hfs? which file system type are you trying to mount? Can you paste the exact command you're trying to execute? mount_hfs also has a -m option, which you could try to use too: mount -m 755 should give you the 755 permissions. – mike Aug 26 '13 at 15:00
  • mount, as you proposed – static Sep 19 '13 at 18:47
  • OK, I really need you to copy and paste the exact command you're trying to type into the terminal. Also, please include the exact version of the OSX you're running. As you can see above in my comment, I've asked you a number of questions, but you're only giving minimal information in response. – mike Sep 25 '13 at 14:35
  • The OP mentioned that "all AFP shares appears as drwx------". So it's about mount_afp. Unfortunately, I get: mount_afp: illegal option -- m. So it looks like mount_afp doesn't support this. – Ortwin Gentz Jan 6 '16 at 11:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .