1

When I plug it in, it doesn't charge. But when I turned it off and plugged it in, it turned on, but didn't charge. What's wrong with it? Is it the charger or the phone?

UPDATE: the charge is going up, but it doesn't say it's charging... I don't know if that makes sense. It doesn't vibrate when I plug it in, it doesn't have the charging symbol, and it doesn't have the charge on the lock screen, yet it's charging(?)

  • 1
    One easy way to test if it's the phone or the charger is to try a different charging cable. – tubedogg Aug 24 '13 at 21:44
2

most likely your 30pin dock port is full of dust and dirt, take a tooth pick, and verry carefully remove any dust that may have been stuck there.

2

The cables go bad so easily, particularly 3rd party. Do you have another to try?

0

With iPhone 5+'s lightning port (I know this isn't for that model but still could be an overlap), my problem turned out to be that lint was inside of my iphone's charger port and was blocking one of the pins from making a connection. Cleaned that out and the problem was solved

0

It used to happen to me on my iPhone 4S. either force reboot your iPhone, pressing home button and power button for a few seconds, or switch it off for a few mins and then start it again. It fixes the issue. I am not really sure what causes it, i guess it sometimes does it on extended use of phone.

0

My iphone was doing literally the exact same as the poster.

I cleaned it out (using dry toothebrush) and It charged again!

  • This is a slightly premature answer without a return on the easy test suggested bu @tubedogg. – dan Aug 28 '14 at 11:57
0

I don't think it's an issue of charger dock or cabl, as I understand your iPhone is charging but not showing any sign, right? If this is the situation then I'm confident that it's an issue of iOS. Have you tried resetting your setting only? I mean don't remove all the data and just reset the settings and check if it works. If it doesn't work then you should reinstall your iOS using iTunes and even if doesn't work then try these solutions to sort out the issue.

Important: Do not try to open or put any hard thing in your iPhone, you may damage it badly, if nothing work then simply take it to the repair shop.

  • The question is from 2013 so you might not get answers to your questions... – fsb Mar 1 '17 at 1:05
-1

Same thing with mine, showed it was charging for 4 hours, but nothing changed. While it was still on the charger, I called it from my husband's phone and it worked! I guess the phone call to it "woke it up".

-2

Mine was doing that too. Apparently, this is due to contact wear, so it needs more pressure closer to the home button to work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .