Here's the story: I recently tried to update my iPod touch 4th Gen. to iOS 4.3. I did make a backup yesterday at 6:30PM, then I clicked update in iTunes. That's when everything went to hell. The first update didn't work. There was an error (I don't remember the exact error) and the update failed. I could still use my iPod, but none of my apps would open. I tried the update again and, after some more trouble, it seemed to work. However this time I couldn't get to my music. It said "You must sync your iPod with iTunes first before you can use Music."

I tried this, but no matter how many times I synced, this problem would not go away. So I figured I would just restore it from my backup. This doesn't work. I keep getting this error: "Could not restore because the backup failed." It says this for every backup. I've tried completely restoring the iPod to both 4.3 and 4.2 and nothing works.

It seems to me like there is a communication issue between the iPod and my (crappy) PC. When I click "restore from backup" this weird little window pops up in iTunes with an indefinite progress bar. Its title is "Restoring from backup" and under the progress bar it says "Estimating time remaining." The real interesting part is that the iPod is unaffected. It doesn't change to the "Restore in Progress" screen or "Sync in Progress" or anything.

I'm really at a loss here.

1 Answer 1


With iOS devices there are a lot of issues that can be happening between iTunes and the iPod. Backups can take a very long time depending on the amount of application data or the size of the camera roll at the time of the backup. Troubleshooting these issues go from very simple troubleshooting steps such as updating iTunes and restarting your computer all the way to the more advanced troubleshooting steps. If you are getting an error code, this can help you determine the exact issue, there is a really great article for troubleshooting the iPod on apples support site @ http://support.apple.com/kb/TS1275

Some steps that you can take to help isolate the issue would be trying a different USB cable (if you have one) or different USB port (should be USB 2.0), if you are connecting to USB through USB hub or extender try plugging it directly in to the computer, creating a test windows user account can also save a lot of headaches by letting you know it is something specific to that user account, and trying to sync music on another computer. I would try walking through that article and if your still having issues after that to try contacting apple or setting up an appointment at an apple store to make sure there is nothing wrong with the actual hardware of the iPod. Best of luck


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .